Sync Problems With Calendar


Last Updated:

  1. garak0410

    garak0410 Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2010
    Messages:
    47
    Likes Received:
    0
    Hi...I am a new Android owner and am really enjoying it.

    The main problem I am having is syncing with Google Calendar. It shows it hasn't synced since August 20th. It is checked to sync and shows the sync (circle with arrows) symbol but it never syncs. In contrast, my GMAIL is having no problems syncing...only the calendar.

    My wife and I share our gmail account to keep calendar's in sync and it happens on her phone too.

    Suggestions?

    Thanks,
    Brian
     

    Advertisement
  2. jimdroid

    jimdroid Well-Known Member

    Joined:
    Oct 31, 2009
    Messages:
    805
    Likes Received:
    106
    Try unchecking, then re-checking the Sync Calendar checkbox.

    I assume you've tried a phone reboot and made sure that Background Data and Auto-sync are on.

    If it's still a no-go, you would probably be best deleting all the Calendar data and resyncing.

    jd
     
  3. garak0410

    garak0410 Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2010
    Messages:
    47
    Likes Received:
    0
    I did the uncheck/re check and several reboots...same problem on both phones.

    I didn't know you can remove a GMAIL account without a factor reset...am I wrong?
     
  4. jimdroid

    jimdroid Well-Known Member

    Joined:
    Oct 31, 2009
    Messages:
    805
    Likes Received:
    106
    You don't have to remove the account, just the calendar data that is stored on the phone.

    To do so, first and foremost, back up your gMail calendar on your PC/Mac (go to Calendar Settings, Calendars, Export Calendars). I've never had a problem deleting Calendar Data, but a backup is a good idea just in case.

    On your phone, go to any Home Screen, then press Menu->Settings->Applications->Manage Applications->Calendar Storage->Clear data.

    Then resysnc Google Calendar and you should be all set.

    If you are at all nervous about doing this, then don't. :)

    jd

    P.S. I'm also assuming that sometime since August 20th, you've had a working data connection.
     
  5. garak0410

    garak0410 Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2010
    Messages:
    47
    Likes Received:
    0
    Looks good so far...will keep an eye on it...thanks for the tip!
     

Share This Page

Loading...