Sync with Exchange - security error, how do i fix?Support


Last Updated:

  1. kt_

    kt_ New Member

    Got my phone yesterday and seems to have accepted my work email (using microsoft exchange) as is listed in my email accounts list, yet when i go into the account i get a message saying

    "unable to connect due to server due to security error"

    is there a phone or email setting i need to alter to get the sync to occur???

    Advertisement
  2. kt_

    kt_ New Member

    Ok friend fixed for me, it needed administrator privileges which is apparently an option when first setting up on phone.
  3. RITLTD

    RITLTD New Member

    Can you let us know how this was achieved.
  4. pdjthe3rd

    pdjthe3rd New Member

    Yes, I would be keen to here from anyone who knows the answer to this.

    Connected my my work (nhsmail) account and it has levelled the phone. seems that a MS exchange that is applying policies to the device (specifically encryption i think) can cause the device to hang. Bootstrap incompatability? or to do with above?
  5. caitferrara

    caitferrara New Member

    Please do explain Kt_ - I am having the same issue and my work IT guys are stumped. Vodafone is no help either...

    thanks!
  6. s_sri

    s_sri New Member

    Kt_
    Can you please guide step by step, i too have the same problem...

    thanks...
  7. s_sri

    s_sri New Member

    finally, with lot of struglle, I found the solution. After creating a exchange prfile in your phone, set a logon screen pswd and it is nothing do with NT or exchange paswd. Just reboot and sync you will start recieving your outlook emails.......
  8. LaTuFu

    LaTuFu Well-Known Member Contributor

    For me, the solution to "unable to connect due to server due to security error" was so relatively simple I had a facepalm moment.

    At the setup screen where the domain/user name/etc is entered, at the bottom of the screen, make sure BOTH boxes are checked. (Use SSL and Accept all security certificates). If your exchange server does not route through a secure site, you may need to uncheck both.

    I realize I dug up a zombie thread, but I posted my solution anyway since I found the thread doing a google search for a solution.
  9. rocking23nf

    rocking23nf Member

    my fix is even easier, after entering all correct active sync settings, it kept failing. After around 3 hours of calling the phone company and samsung, none of which could really help, i noticed there was a notification icon at the notification area, which i found that i could drag down. There was a hidden popup asking me to accept the security settings from the active sync web server

    They were telling me its our server, i created the server and have 100 iphone users connected via active sync so i knew the settings where right.

    so frustrating, i almost sent my phone back.
  10. vermanurag

    vermanurag New Member

    Thanks rocking23nf. Simple solution but veyr frustrating until I read this thread.
  11. Louise85

    Louise85 New Member

    I know this is a really old thread but could really use some help please. Work for the NHS and we currently have around 50 Samsung Galaxy S2 devices using NHS mail. Had no problems/issues on initial set up, started using this smartphone around May 2012 and have been issuing them up until and including this month. Since the beginning of this year, I've been inundated with problems with NHS mail synchronising on the Samsung. They have all been working fine, they haven't changed their password or been locked out, but all of a sudden just stopped synchronising. Tried all the usual, checking battery, signal strength, switch on/off, hard reset. In some cases, going into Exchange Server Settings and re-entering the mail password etc has refreshed it and started syncing again. But in several cases, I've had to delete the email account and try setting up again and have got the following error messages so have then had to perform factory reset of phone and then set up again.
    "cannot connect to server"
    "this server requires security features that your Android device doesn't support, including: (null)"
    "the server responded with an error; please check your username & password and try again" (usually for an incorrect user name or password it would simply say "invalid username or password")​

    Now most of these have then worked again and not complained since. But one or two, even after all of this, still brought up those error messages. I have then ended up pushing them to one side for a few hours and then when I went back to them, managed to complete the email set up once again.

    Yesterday, I got a new error message altogether! A user reported in the afternoon that her phone had not synchronised her email in about 4 hours. Towards the bottom of her screen, it was constantly displaying the small message "Unable to open connection to server due to security error" She hadn't been locked out, hadn't changed her password and nothing else had happened to explain it. I tried to refresh it by re-entering password in Exchange Server Settings but came up with the following error: "Setup could not finish. You entered an incorrect server address or the server requires a protocol version that email does not support" This has me completely lost. I did all of the above, deleted the email account and tried again, same message. I then performed a factory reset of the device and tried setting email up again - same error message. Our IT department can't think of any reason to explain it and I can't seem to find anything online. Vodafone have said everything is fine as far as they can see.
    Has anyone experienced any of the above issues and does anyone know any reason/solution?
    Thanks
  12. geoffibs

    geoffibs Well-Known Member

    A few of us have had these problems since moving to JB and server 2010. We never seem to get the popup for allowing security settings (not in the notification area either unfortunately) so it just won't talk to it properly.

    Is your setup similar?

    Weird thing is, some are ok!

    It has to be something silly as going back to ICS or recreating the account on Exchange seems to cure it.

    Weird thing is, Its partly working as it knows if you put a bad password in so its definitely the security settings after that.
  13. geoffibs

    geoffibs Well-Known Member

    Right, it seems to do with the security on the Active Directory account itself. (In my case)

    Go into AD for the user account, security, advanced and tick "Include from object parents"

    Not had one fail again yet so fingers crossed.
  14. Louise85

    Louise85 New Member

    Thanks for the reply - I'll talk to our IT dept about Active Directory and see if that works.

    Sorry, what's JB?

    I just can't figure out why they have worked perfectly well for months, and then all of a sudden they stop synchronising.
  15. geoffibs

    geoffibs Well-Known Member

    JB = Jellybean. I just noticed it as it was roughly the same time I had issues.

    There could be a few reasons. Had your IT upgraded Exchange or any part of Active Directory? Migrated exchange databases? Changed security principles? There's quite a few things really but have a look at the "Inheritance from Parent" IT will have to use Active Directory manager, not users and groups to get to the security area if they are using 2008R2 but I'm sure they will know that.
  16. thjam1

    thjam1 New Member

    Hi,
    I fixed this by getting our IT administrators to tick "Allow non_provisionable Devices" on the Activsync Policy screen (on the Exchange / email servers)
    Jon

Share This Page