1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[T-Mobile] Anyone Know Where To Find HTC One M7 RUU for TMob?

Last Updated:

  1. mike1000

    mike1000 Well-Known Member

    Looking for an RUU for USA TMobile HTC One M7.

    HBoot 1.44, Radio 40.14.3250.15

    Anyone know where to find one please, kinda desperate.

  2. scotty85

    scotty85 Guides Guide

    i have so far only seen developer and international RUUs. no sprint,att,or t mobile :mad:

    what issue are you having?
    mike1000 likes this.
  3. mike1000

    mike1000 Well-Known Member

    Thanks for the answer, you've helped a lot - in as much as - that makes the decision to just send this phone back easier.

    My next question is, if i'm returning an M7 that is bricked because of a corrupted TWRP, how would I brick the phone to a point where it's just a black screen, therefore hiding TWRP?

    I don't really want any advice as to unbricking, simply because I've spent the last 3 days doing just that and it seems I attempted to flash a bad rom with a bad TWRP and have since tried every step known to man: reflash TWRP, reflash cwm, use all in one toolkit.....the phone is bricked and needs to be exchanged.

  4. ScandaLeX

    ScandaLeX Wasn't Me

    Ewwww this is NOT my area of expertise so I'll just say I hope you can exchange it with no worries.
  5. mike1000

    mike1000 Well-Known Member

    Bottom line is, I have insurance and the deductable is $175 so it's possible I could be out by that amount by simply saying I dropped it in the toilet/lost it/destroyed it etc

    If it costs $175 to learn my lesson, no worries, I'll eat it, but like everyone else, I don't want to eat it.
  6. scotty85

    scotty85 Guides Guide

    what happens when you flash from twrp to CW or vice versa? does the recovery still change? if so you could always find a stock recovery and flash that,so at least it would boot to a stock recovery.

    however,if you change your mind on un-bricking,im sure its possible if you let us know what happened and what youve tried. an s-on device is only giving you access to boot,system,and recovery. all the vitals(radio,hboot,etc) are still proteced,and therefor next to impossible to brick with software. not booting is different from being hard bricked :)
    mike1000 likes this.
  7. mike1000

    mike1000 Well-Known Member

    No, corrupted recovery refuses to be over written and I've tried every single conceivable way of doing it possible. Fastboot, adb, all-in-one-toolkit, nothing. Even tried flashing a TWRP downgrade but nothing sticks. I do have a stock recovery, it was the first thing I did.

    And sure, I accept the difference between not booting and bricking but if your device isn't booting because it never will, it's a brick, although I do accept your point about not being able to completely brick through software. That was something I wasn't sure about.

    Put simply, in the very very rare event of flashing a recovery that fails and then trying to flash a rom that fails because you assumed the recovery was fine, it's very difficult to recover.
    scotty85 likes this.
  8. scotty85

    scotty85 Guides Guide

    i am just trying to help you not have to eat $175 ;)

    what happens when you boot to the corrupt recovery?

    have you tried to launch recovery into memory in hopes of at least getting back to a working phone?( fastboot boot recovery.img )
    mike1000 likes this.
  9. mike1000

    mike1000 Well-Known Member

    I hear ya and appreciate you taking the time to try and save me $175 and I'm grateful for that, so thank you.

    When I boot into twrp it's there as if it's working fine. Yet everytime I attempt to run a cmd (reboot bootloader) i get a message from within twrp that says: 'would you like to root your phone now, swipe to root.'

    The phone was rooted at the start and I know for a fact it 'stuck,' because I made sure to check super SU was working and downloaded titanium for confirmation also.

    So at that point I have a stock rooted M7 and at that point I should have stopped.

    I then tried to flash Trickdroid, which then stuck at 30% of download. In researching a resolution I was told to flash rom without aroma installer, which I attempted and constantly got an error message. I then tried adb sideload, no dice and pretty much everything else you can think of.

    I'm basically stuck in a TWRP bootloop that won't let me do anything else, whilst also refusing to be downgraded/overwritten.

    There's a lot more to it than that, but take that as the cliffnotes.
    scotty85 likes this.
  10. scotty85

    scotty85 Guides Guide

    hmmm that is very strange.

    are you still able to get to fastboot,and get a response from: fastboot devices

    if so,try and boot clockwork:
    -put cw image into your adb/fastboot directory
    -put phone in fastboot,plug in,open cmd,change to fastboot working directoty
    -boot cw with:
    fastboot boot imagename.img (where imagename is the exact name of your CW image)

    if that works,try and enable usb storage so you can move a different rom or nandroid to your sd card.

    try flashing a simple stockish rom,to see if it gets you back to a working device.(youll likely have to fastboot flash the boot image afterward,im not sure how devs are scripting their roms)

    alternately,if you have a stock nandroid,restore it. if not,there is a t mobile nandroid here: http://forum.xda-developers.com/showthread.php?t=2207874 (tho from the CID,it may not be t mobile US)
  11. mike1000

    mike1000 Well-Known Member

    Yes, can operate in fastboot but adb is hit and miss, due to the nature of adb and windows 7 and driver conflicts, but essentially i can access fastboot and adb. Fastboot is basically saying that anything I attempt has worked, when in fact it hasn't.

    I've tried your suggestion of flashing cwm - literally - 100 times. No dice. Same for twrp. Fastboot gives a 'success' message for anything I try to flash, but when I then reboot i'm still in twrp 2.5.

    I appreciate your willingness to help but the bottom line is I've gone beyond everything you're suggesting because I've tried those things and had no luck, which is why I'm kinda resigned to exchanging the thing, but exchange will run into issues when they reboot it back at the warehouse and get stuck in a twrp bootloop.
  12. mike1000

    mike1000 Well-Known Member

    And just to clarify, this is not total disaster. If I can't just simply exchange I will have to pay $175 deductable but I can probably get $250 for the HTC One S I will be selling, so although I will be out $175, it's not actually going to come out of my pocket....well....it is, but i'm sure you see my point.
  13. scotty85

    scotty85 Guides Guide

    this comment makes me thing you havent tried what i sugested. i know you have said you have flashed recoveries multiple times,but what im suggesting is to boot recovery directly into phone memory.

    the command used to flash recovery is:
    fastboot flash recovery imagename.img

    the command to boot recovery is:
    fastboot boot imagename.img

    my aoplogies if you had realized this,but the commands are similiar,and in these forums this is commonly confused. from my perspective,you havent given much information,just general comments about spending "3 days working on it","trying everything under the sun",etc. i dont doubt one bit youve been working on it for 3 days,i can tell your fustrated. however,you havent given me anything to determine whether your a complete noob,who has just not entered commands correctly,or your an advanced user whose encountered an out of the ordinary(wich may or may not be fixable) prollem.

    again,its hard for me to believe there is no solution for you,other than swapping out the phone. but if i am to help,were going to have to have to go all the details,look at your code boxes,etc. all kinds of stuff. ultimately its up to you. if you want help,we are here.

    ethically tho,i cannot offer advice on how to purposely brick your device to hide whatever is goofed up.

    the above command,should boot you directly into clockwork,no reboot and boot back to required. in the cmd window it should look something like this:
    Code (Text):
    2. c:miniadb_m7>[COLOR="red"]fastboot devices[/COLOR]
    3. HTxxxxxxxxxx    fastboot
    5. c:miniadb_m7>[COLOR="red"]fastboot boot recovery.img[/COLOR]
    6.         downloading 'boot.img'... OKAY [  1.518s]
    7.                        booting... OKAY [  0.005s]
    8. finished. total time: 1.523s
    mike1000 likes this.
  14. mike1000

    mike1000 Well-Known Member

    Wow, this is getting stranger. Firstly, thanks for the helpful instructions, I managed to flash cwm immiedietly. I then went to flash the trickdroid rom and it rbooted at the exact same place (30%) and then rebooted into recovery.....twrp. So cwm was flashed and im now back at twrp. Does that make any sense?
  15. scotty85

    scotty85 Guides Guide

    yup... it makes perfect sense. twrp is permantly installed on your phone,and cw is just running in memory. so when CW initiated the reboot recovery,it rebooted to the recovery partition,i.e. twrp.

    try booting cw again,then move a different rom to your sd card. (one that doesnt use aroma) and try to flash that.
    mike1000 likes this.
  16. mike1000

    mike1000 Well-Known Member

    To confirm, you mean a specific M7 rom right? And also, I have no way of pushing the rom to the phone, do you mean flash in adb? I think what I mean is I'm not sure how to get that new rom onto the sd card for cwm to see.
  17. scotty85

    scotty85 Guides Guide

    there should be an option in cw recovery to enable usb storage,wich will allow you to move a rom to the sd card. i use twrp normally,but lm begining to not be a fan of it. let me boot cw and make sure that option exists there

    cw also should have an adb daemon running,so if you want to simply adb push to sd card, thats certainly anotehr option :)
  18. mike1000

    mike1000 Well-Known Member

    This is the problem i have encountered from day one and the thing that imitially led me to believe TWRP was corrupted (can now see it's not.) TWRP was refusing to mount any storgae but now have the same on cwm.

    If I could just simply mount then I would have downloaded a different rom long ago, so while I really appreciate the help and advice, that option is now open to us.

    The good news is we now know TWRP is probably not corrupted :)

    I could try adb pushing a different rom, is there a tutorial on here anywhere?

    By the way, the error in cwm is: "error, cannot mount sd card."
  19. scotty85

    scotty85 Guides Guide

    yes,looks like twrp is fine. i havent been able to mount usb storage there(theres not even an option :mad: )

    im unable to mount usb storage in cw either,so its not just you. worse case is that we do not have an adb deamon running either :mad:

    let me try the touch edition and see if that works...
  20. mike1000

    mike1000 Well-Known Member

    The other issue I'm now having and have had all along is adb is sketchy. Currently not recognizing device, as has been the case in twrp, and then all of a sudden it will see it. Very frustrating, although as I already have said, that is a very very common issue with adb/windows, as i'm sure you know.
  21. scotty85

    scotty85 Guides Guide

    are you trying to use adb in recovery? or does your phone boot into the OS?
  22. mike1000

    mike1000 Well-Known Member

    recovery, have no os.
  23. mike1000

    mike1000 Well-Known Member

    Let's take a step back here: We know fastboot is fine so we know the drivers are fine, even though ADB is sketchy and I have had adb working 50% of the time.

    As it stands right now, I'm in twrp and i'm successfully in adb. Seems to me I need to download another rom zip and try to get it to sd.

    So here's the questions: Do I download a device specific m7 rom and is there a tutorial for adb flashing a zip to sd card.

    If it doesn't work after that we could maybe try something else, but it seems to me you're right - if we can get a good rom on the sd card we can install in recovery.
  24. scotty85

    scotty85 Guides Guide

    ive been trying the last 30 minutes to update to newest drivers and make adb sow up in recovery... with no success :mad:

    if you can get your phone seen in adb,just try to push to sd card:

    adb push romname.zip /sdcard/

    that should get it there. then just flash. :) sorry for the delayed response there. got anotehr idea that may work as well...
  25. scotty85

    scotty85 Guides Guide

    also,if you could go to fastboot and do a fastboot getvar all

    and then paste the output here for me... :)

Share This Page