1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[T-Mobile] Argh, can't get a GPS lock

Last Updated:

  1. zanthal

    zanthal Well-Known Member

    I rooted, installed a couple of ROMs with TWRP, due to problems with those, I reverted to a backup. Since then I can't get a GPS lock no matter what I do. Up until I rooted this week, the GPS worked fine. It's hard to believe it's a hardware failure conveniently timed exactly when I rooted.

    I've been using a GPS Status app to see if any satellites are connected to at all, none are.

    If I load an app that uses precise location, it will just show Searching for GPS... for 10+ minutes which is when I shut it off.

    I just did a factory reset tonight, with no effect.

    I read something that tightening down the screws under the back panel can help, I did find two of the screws about 1/16th of a turn loose, had no effect.

    I don't believe I have an overheating problem, the screen does get a little warm to the touch but never even close to hot.

    an old article I found from last spring mentioned that Yahoo Weather app being removed solved a lot of GPS lock problems, but that app isn't included with my SGH-M919.

    I know that GPS problems are somewhat common with the GS4. I am definitely in need of troubleshooting help.

    My GS4 is within warranty for another 10-11 months, but I use an app six days a week on the job, it's indispensible to what I do, and I'm sure it would take a week or two to get a replacement.

  2. Rukbat

    Rukbat Well-Known Member

    Maybe not that long, since they probably have a decent stoock of refurbed US models,

    The problem is probably one or both spring fingers that contact the antenna not being tensioned enough. That's why tightening he screws might help. But opening it up while it's under warranty? I'd sooner send it back. Remember to get an RMA and a shipping label you can print.
    zanthal likes this.
  3. zanthal

    zanthal Well-Known Member

    Are you saying that a typical root wouldn't cause this problem?

    And I sure was tempted to get the Note 3 last month, that thing is awesome.
  4. zanthal

    zanthal Well-Known Member

    So Walmart Family Mobile processes the warranty return.

    I do need to verify the reversal process... so far:

    I have used Odin v3.07 to install TWRP, then did a full backup. I then flashed a ROM and reverted to that backup, flashed another ROM, and reverted to that backup again.

    Now I know I can use Odin to put back the stock TAR for my device, but I do wonder, will Walmart Family Mobile see what I've done, my warranty then being void?

    Do I need to remove TWRP? If I'm going to send it back, I want to get as close to stock as possible.

Share This Page