[T-Mobile] Galaxy s4 rooting problems

Last Updated:

  1. algar32

    algar32 Member

    Just attempted to root my galaxy s4 tmobile.

    motochopper method:
    How to Root Galaxy S4! - YouTube

    I used the motorchopper method and it installed super user, but super user doesn't work. Super user says : the super user su binary must be updated.

    then I tried twrp method:

    when I tried to boot into twrp mode it didn't give me the desired screen (it gave me a list of 5 small blue text options- reboot apply update....etc and there was a picture of a dead android guy with No command underneith, but this wasn't the desired twrp menu).

    Why doesn't this work? Could it be because I got the update? How do I check if I got the update?
    Is there anyway I can revert to my stock s4 without all this rooting crap I put on it? I will just stick with it as is for now until someone makes a tmobile rooting tutorial. Thanks.

  2. Atma

    Atma Well-Known Member

    Hi algar :wavey:

    If you want to go back to stock, you can follow this Odin guide and install the UVUAMDL stock rom.

    It sounds like you are on the MDL version. You can go to settings > the more tab > scroll down to about device, and see what it says under baseband version and build number, It will probably be M919UVUAMDL.

    When you installed TWRP it sounds like it didn't stick and the recovery you went to was the stock recovery. If you want to root with TWRP, follow this guide. When Odin is done and your phone starts to reboot, hold your up volume until you see the TWRP menu.

    Download this kernel. Thanks to mattlgroff in this thread. Put the kernel on your sd card. Download SuperSU and put it on your sd card. Go to TWRP and tap 'Install'. Navigate to those 2 files and install them. Reboot and now your rooted on the stock rom.
  3. algar32

    algar32 Member

    Thanks for your help. My base band was as you said : M919UVUAMDL.

    I don't necessarily want to do TWRP, but I would like to do what's best. Is there another method better than TWRP? Thanks again!
  4. Atma

    Atma Well-Known Member


    Personally I consider TWRP the best. If you want to try Clockworkmod recovery, download it from that link. Install with Odin just like you would TWRP and root the same way. Whichever one you decide to use, after you get rooted, go back to recovery and make a backup. Very important to do that. If you ever have a problem, or you're trying a rom you don't like, you can just restore that backup.
  5. tastycaramel

    tastycaramel Guest

    I am unable to root my S4 through motochopper and odin.
  6. Atma

    Atma Well-Known Member

    Did you try what I suggested in the 2nd post? Install recovery with Odin. Use recovery to install the kernel and then the supersu file?
  7. Atma

    Atma Well-Known Member

    Wait. You have the i9505. This method won't work for you.
  8. Atma

    Atma Well-Known Member

  9. tastycaramel

    tastycaramel Guest

    MANY THANKS!!!!!!! I finally got my phone rootrd!!!!:D:D:D:D
    Atma likes this.
  10. algar32

    algar32 Member

    Thanks for your help. I will be reattempting twrp later today and will post back with the details. Thanks again!
    Atma likes this.
  11. algar32

    algar32 Member

    Will rooting allow me to receive updates still? Thanks.
  12. Atma

    Atma Well-Known Member

    No, you would have Odin back to stock to receive an ota update. Usually, the update firmware will be available to download and you can install it with Odin. You would just have to reroot after.
  13. algar32

    algar32 Member


    Tried restoring to original firmware with odin and it failed. Here is the message log:
    <ID:0/003> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> M919UVUAMDL_M919TMBAMDL_M919UVUAMDL_HOME.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/003> Odin v.3 engine (ID:3)..
    <ID:0/003> File analysis..
    <ID:0/003> SetupConnection..
    <ID:0/003> Initialzation..
    <ID:0/003> Get PIT for mapping..
    <ID:0/003> Firmware update start..
    <ID:0/003> sbl2.mbn
    <ID:0/003> NAND Write Start!!
    <ID:0/003> sbl3.mbn
    <ID:0/003> rpm.mbn
    <ID:0/003> aboot.mbn
    <ID:0/003> tz.mbn
    <ID:0/003> boot.img
    <ID:0/003> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    <ID:0/003> Removed!!
    <ID:0/003> Added!!

    Any suggestions?
  14. Atma

    Atma Well-Known Member

    Reboot your phone and computer and try again. Also check developer options and see that USB debugging is checked. Make sure your using a good USB cable.
  15. algar32

    algar32 Member

    I initially had usb debugging on, but I don't think I can go back and put it on now because I can't get to my setting or access my phone. The only page that comes up when I turn it on is the one that says " there was an error while updating your firmware, please connect to kies" (or something to that extent). I am leaving work now, but I will try rebooting my computer and using a different cable when I get home. Thanks for your help.
  16. Atma

    Atma Well-Known Member

    Odin should still work at that screen if you can't get to download mode. I'm not sure why it failed. Probably most common is a bad connection or power loss. Try another cable if you have it or another usb port.
  17. algar32

    algar32 Member

    It was the usb cable. That's probably what messed up my TWRP attempt. Thanks so much for your help.
    Atma likes this.
  18. Atma

    Atma Well-Known Member

    You're welcome. Glad you got it working. :)
  19. michaeljmellon

    michaeljmellon New Member

    Sorry I know this is not under the correct thread but it popped up in a google search for my issues and I'm going to give it a whirl anyway.

    What if I cannot unroot because my phone supposedly isn't rooted?
    I've gone through the process with motochopper. Everything went fine.
    Rebooted, went in to SuperSU and attempted to download the update to no avail.
    Downloaded Titanium Backup to see if I was in fact rooted... And I'm not.
    Try to root again with Motochopper, but it fails and says the files already exist!

    One big fricken circle!! Help please!
  20. Kelmar

    Kelmar Done by choice VIP Member

    What phone do you have? What carrier?

    Have you tried updating what you can through SuperSU?
  21. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member

    If you aren't getting root access that means you aren't rooted which is a good thing. All you would need to do to unroot is factory reset your phone.

Share This Page