[T-Mobile] [root?] Samsung Galaxy S3 SGH-T999 T-Mobile on Android 4.3

Last Updated:

  1. kevinnatorr

    kevinnatorr New Member

    So I recently got a Samsung Galaxy S3 SGH-T999. I opened it up and updated it to Android 4.3 thinking I wouldn't have a problem when rooting later on. I tried a normal root method using Odin through the most common method mentioned throughout threads. Installed the root file, flashed clockworkmod, installed SuperSU, and all. However after finishing the process and trying to run SuperSU, I got a notification saying

    "There is no SU binary installed, and SuperSU cannot install it. This is a problem!
    If you just upgraded to Android 4.3, you need to manually re-root. Consult the relevant forums for your device!"

    Seems like the root wasn't successful. I've looked everywhere to try to find a way around this but most methods on threads are aimed towards phones running <Android 4.2. If anyone could help me out I'd greatly appreciate it. Sorry in advance for noobin' it up.

  2. Rukbat

    Rukbat Well-Known Member

    You have to manually push the binary to the phone with ADB. It's in just about every instruction page I've ever read.
  3. GTWalling

    GTWalling Well-Known Member

    It is due to the new Security in 4.3. There is a rom at XDA without the security already rooted that will help. The new security along with KNOX will not let SuperSU run. Do not have the link available at the moment.
  4. Brandon4466

    Brandon4466 Member

    1. Disable SuperSU by going to Settings > Application Manager > SuperSU > Uninstall Updates > Disable.

    2. Install Superuser by JRummy Apps Inc. from the Google Play Store.

    3. Open superuser, a prompt will be displayed asking you to update the su binary. You should be asked for root access.

    4. Enable SuperSU, by searching SuperSU in the Google Play Store and taping enable.

    5. Start SuperSU, if prompted to update us binary, do so.

    6. Uninstall superuser. NOTE: unstable to have 2 superuser apps active.

    Hope this helps! Email Mr at spongebob.brandom@gmail.com if you need further help.
  5. barney_rebel

    barney_rebel Well-Known Member

    Gave this a shot, had no luck.

    I didn't find any superuser from JRummy:


    I did try to disable, and try the other superuser apps (Chainfire, Clockwork). None of them prompted to update the su binary.

    Tried this too:

    How to Fix Android 4.3 Jelly Bean Rooting Problem for Galaxy S3/S4/Note 2/3 - W0lfDroid

    As mentioned before, looks like the only option is custom ROM. This is sad.
  6. funsturr

    funsturr New Member

    I also had problems with 4.3 and Knox, I had succeeded by flashing chainfire's updated superSU from his download page and then reinstalling, once reinstalled, it prompted to disable Knox. Hope this helps.
    barney_rebel likes this.
  7. barney_rebel

    barney_rebel Well-Known Member

    Thanks. If you don't mind me asking, what is involved with flashing the SuperSU? I just tried a simple install to the latest Jan 20 SuperSU and that was prevented by Knox.

    EDIT -

    I gave this a shot:

    xda-developers - View Single Post - [Q] "There is no SU binary installed and SuperSU cannot install it"

    and flashed v1.25 from Recovery Mode. Same problem. I uninstalled SuperSU and reinstalled it, and doesn't prompt me about knox and still got the "...no SU binary installed" (with the Knox shield appearing at the top). Sigh. I'll give it another go.

    EDIT 2 - duh, 1.25 is old. Let me get a later one.
  8. barney_rebel

    barney_rebel Well-Known Member

    OK So it has to be v1.86. Latest (1.91) has issues, so I am reading. I tried v1.91 and SuperSU will not uninstall/will not update. I then went down to 1.86 and all is good!

    I can't thank you enough!
    funsturr likes this.
  9. shack2436

    shack2436 New Member

    My S4 1337 was rooted before I got to new 4.3 update now it says no superuser binary installed .I try to delete superuser but it won't let me . I've tried to reroot with motorchoper didn't work tried to update superuser zip didn't work anybody know what I can do

Share This Page