[T-Mobile] Unable to add Google account to rooted HTC One


  1. sotolu

    sotolu Member

    I purchased the phone on Craigslist and everything works except for the fact that I cannot add my Google account. I get a "Couldn't sign in. There was a problem communicating with the Google servers. Try again later" message. No google account = no play store = no apps.

    Phone is unlocked and rooted and I know absolutely nothing about flashing, unlocking etc...

    It is not a google issue as I can add my account to another phone. Google, Tmobile and HTC contacted but unable to help.

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Welcome to the forum :)

    Can you get any data connection at all? I know you said "everything works" but I want to be certain about this (e.g. that you can browse the web or something).

    If data is working but you can't connect to Google, it might help to know what software the phone is running. If you go to Settings > About > Software information, what does it say (all information, not just the Android version)? There's other stuff I could ask, but that would probably do for a start if you are new to this.
    scotty85 likes this.
  3. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello and welcome to the forums . no play store . wow can I ask what ROM are you on if it sounds true you may be on the mokee custom ROM . it Dont have Google play and also has a zip file to remove the app and contents from the device . but to repair you will need the Google framework app , the play store app, the lib files and etc . but as the other forum member asked what ROM are you on .
    scotty85 likes this.
  4. sotolu

    sotolu Member

    I tried doing this via cellular connection and via wifi. I get a connection on both, can surf the web, text, send emails...

    Software information
    Android Version 4.4.2
    HTC Sense version 535
    Software number Android Revolution HD 51.0 by mike1986
    HTC SDK API level 5.68
    scotty85 and Hadron like this.
  5. Hadron

    Hadron Well-Known Member Contributor

    Thanks, that's very helpful.

    Ok, so the phone is running custom software, but it's a recent version of a well-respected ROM.

    Unfortunately I have to sign off right now. I would suggest a factory reset and, if that doesn't fix it, flashing the latest version of the ROM, but haven't time to type instructions now. Probably someone else will have by the time I'm back :)

    It's ok, this is fixable.
    scotty85 likes this.
  6. sotolu

    sotolu Member

    Easy enough that someone w NO knowledge can do it? Sure hope so
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    It's pretty easy. I think your rom will have an advanced power menu,so hold power for a.second,then tap reboot,and hopefully you get a menu from wich you can select recovery.

    Explore the menu options until you find "wipe data/factory reset". After you've completed that,choose an option to reboot. The menus are slightly different between clockwork and twrp recoveries,so we can't tell you exactly what to not knowing wich one you have.

    A word of warning: do NOT wipe system,boot,or any other partitions! :eek: this will wipe the os from your phone and make recovery more complex. All you want is "wipe data/factory reset"

    Hopefully that will wipe all.the previuos users data and get things working correctly :cool:
    sotolu likes this.
  8. sotolu

    sotolu Member

    Did the wipe and reboot and... Still the same error Just wished there was a simple dummy proof way to restore the original HTC ROM.
  9. Hadron

    Hadron Well-Known Member Contributor

    You could try flashing a new copy of the ROM. Here's what you need to do:

    * First, boot back into recovery and check what recovery, and what version, you have (it should tell you when you are in recovery). I suspect that if you have ARHD 51 you will already have a recovery that's capable of flashing the latest (ARHD 52), but best to check. TWRP 2.6.3.3 is what we're hoping for.

    * Download the latest version of the ROM from here: [ROM] Android Revolution HD 52.0 | High Quality & Performance | Android 4.4.2 KitKat | HTC Sense 5.5 | 4.19.401.9 | Sense 5 Toolbox 2.7.1 | Sprint Support | T-Mobile Wi-Fi Calling - xda-developers. It's a zip file, and you want it on the phone's /sdcard partition - somewhere you can find it easily. Do not unzip it.

    * Boot into recovery again.

    * Do the same wipe as before, to be safe.

    * Select "install" from the recovery menu. Select the zip you want to install and confirm that you want to go ahead.

    * If the installer asks any questions, just accept the defaults.

    * Reboot when finished.

    This process will replace your old ROM with the new version, so if something is actually wrong in the ROM this will fix it.

    There are ways of flashing back to stock, but we'd have to work out which stock ROM is the correct one (the packages which do this, ROM Update Utilities or RUUs, check which network the phone was originally made for and only work if this matches). We could have a go at identifying that and see whether we can find a suitable RUU - as long as you have a Windows PC using an RUU is pretty simple once you've got the right one. But this should be no more difficult.
    sotolu and scotty85 like this.
  10. sotolu

    sotolu Member

    When I install in recovery I get a "This operation may install incompatible software and render your device unusable" message. Needless to say (remember I am NEW) I didn't do it.
    scotty85 likes this.
  11. Hadron

    Hadron Well-Known Member Contributor

    That's the standard warning. It just means that you are changing system software and do so at your own risk.
    sotolu and scotty85 like this.
  12. scotty85

    scotty85 Guides Guide


    In a worse case,we can try and find you an ruu(factory software) but the from flash is a bit quicker and easier at this point. :)
  13. sotolu

    sotolu Member

    It worked, definitely easier than I thought. Now if there is a way (maybe an app) that will allow me to do wifi calling (I have T-Mobile service and the signal at home is not that good) I would be happier.
  14. scotty85

    scotty85 Guides Guide

    if thats the only thing you miss,you could flash this rom,wich includes it: [ROM] Android Revolution HD 52.0 | High Quality & Performance | Android 4.4.2 KitKat | HTC Sense 5.5 | 4.19.401.9 | Sense 5 Toolbox 2.7.1 | Sprint Support | T-Mobile Wi-Fi Calling - xda-developers

    its using the same base as the rom you just flashed,and wont be much different than what youve currently got.

    if you want all your t mobile bloat back,you could flash this rom,wich is based on the official t mobile kit kat update: [ROM][MAR 03] United Advance v6.2.2 | 4.19.531.10 | Official | STABLE | WiFi Calling - xda-developers

    if you want to check some other roms,you can look for them here:

    GSM one forums(compaitble with your t mobile phone)
    HTC One - xda-developers

    t mobile specific forum:
    T-Mobile HTC One - xda-developers

    stock based roms will be in the "android development" sections,and roms based on google source code( other wise know as AOSP) will be in the "original android development" sections

    i personally do not run t mobile software on my t mobile one,as it seems the us carrier builds are typically a bit buggier than the european unbranded builds. hope that helps :)
  15. sotolu

    sotolu Member

    The first ROM; isted is the one I flashed that fixed the Google account issue. What do I do to turn on wifi calling?
  16. scotty85

    scotty85 Guides Guide

    I've not run that rom,so I couldn't say for sure. Id have thot that during the install,there would be an option to enable it,then after boot you'd turn it on somehow in settings(not running a t mobile rom so I can't remember exactly how)

    Or it may just naturally be part of the rom.

    Search the dev thread for "wifi calling" or similar and see what you can find on it. If you need to select an option during install,you can simply reflash it. :).
  17. robo71

    robo71 New Member

    I found this same issue occurs when installing Viper Rom custom firmware. It's a great rom, and it allows you to do everything. Including uninstalling applications. If you use that option and delete google mail, you get this exact same issue... you need google mail app to communicate to google servers, even if you don't use gmail.. :)
    This fixed the issue for me!
    Even though the thread is old, this might be usefull for people stumbling on the exact same issue.
  18. Hadron

    Hadron Well-Known Member Contributor

    Funny: I use ViperOne with GMail removed and have no problem (I also remove G+, Hangouts, Google Search, Play Music/Movies/Books etc). So I don't think the GMail app is the key (I also remove a lot of the HTC apps which I don't use).

    I do leave the Google Account Manager and Play Services installed though.

Share This Page