Takes a long time for calls to come through.. any fixes?


Last Updated:

  1. mjcritchie

    mjcritchie Well-Known Member This Topic's Starter

    Joined:
    Oct 5, 2009
    Messages:
    53
    Likes Received:
    2
    For quite a while now, people have been saying how long it takes for me to answer my phone, even though it's usually on my desk and I get there after a couple of rings.

    So today I tested it out. I rang my mobile number from my landline, it connected and started ringing, but it got to about six rings before the LED on my mobile started flashing and a further two rings until it started ringing!

    I'm on T-Mobile, but it seems to connect OK, just take a while to register on my phone. Obviously this isn't the end of the world, but I use my mobile for business and it doesn't make me look very good!

    Does anyone else have this problem? Does anyone know of any solutions?
     

    Advertisement
  2. tailsthecat

    tailsthecat Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    171
    Likes Received:
    2
    i have the cdma hero and would ABSOLUTELY LOVE to alter the slot cycle index...so the device will page the tower more frequently. any insight to making this change would be much appreciated
     
  3. tailsthecat

    tailsthecat Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    171
    Likes Received:
    2
    i figured it out on my cdma hero...
     
  4. mjcritchie

    mjcritchie Well-Known Member This Topic's Starter

    Joined:
    Oct 5, 2009
    Messages:
    53
    Likes Received:
    2
    Not sure what this means. Does it fix the issue I described?
     
  5. pdrhan

    pdrhan Well-Known Member

    Joined:
    Feb 13, 2010
    Messages:
    59
    Likes Received:
    3
  6. _MarkC

    _MarkC Well-Known Member

    Joined:
    Feb 6, 2010
    Messages:
    62
    Likes Received:
    2
    Ziani posted this solution which worked for me:

    Try this below:

    type *#61# type this as if you typing in someone’s phone number then press call. it should show your current ring time

    then type *004*<voicemail number>*11*<delay in seconds>#
    where it says voicemail number put in your service providers voicemail number........where it says delay in seconds type in 30 if that&#8217;s what you want

    e.g. on ORANGE *004*07973100123*11*30#

    then press call

    then type *#61# then press call and it should show the change in ring time.

    The delay was causing my calls to go to VM before I could even answer. Have also found the following link on the Sprint forum but not sure if it can be related to GSM specific issues:
    http://androidforums.com/sprint-htc...ther-end-few-times-before-ringing-hero-4.html
     
  7. tailsthecat

    tailsthecat Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    171
    Likes Received:
    2
    i have the cdma hero on sprint. i entered ##data# the clicked edit and then entered my msl code when prompted. i lowered my slot cycle index to 0 rather than 2 so my device now pages the serving tower every 1.2 seconds or so rather than every 5 seconds. thats all there is to it for the cdma hero. my device rings almost immediately after placing test calls to it.
     
  8. mjcritchie

    mjcritchie Well-Known Member This Topic's Starter

    Joined:
    Oct 5, 2009
    Messages:
    53
    Likes Received:
    2
    Just spoken to someone at T-Mobile (150 from any T-Mobile phone) and they seemed to sort me out.

    I mentioned about changing the MSL (post #17 on this thread) and that seemed to get the tech help girl to understand what I was talking about.

    In the end I entered

    **61*{long number - assume my MSL}**25#

    Not sure exactly what that did, but it seems to have sorted the problem. Only get one or two rings now before it starts ringing on my Hero.
     
  9. mjcritchie

    mjcritchie Well-Known Member This Topic's Starter

    Joined:
    Oct 5, 2009
    Messages:
    53
    Likes Received:
    2
    Hmm.. after spending a bit of time with this the fix described above doesn't seem to have worked.

    People are still complaning that I'm taking ages to answer the phone, even though sometimes I'm picking it up during the first ring!

    Does anyone else have this problem, or have any solutions?
     
  10. mjcritchie

    mjcritchie Well-Known Member This Topic's Starter

    Joined:
    Oct 5, 2009
    Messages:
    53
    Likes Received:
    2
    I followed punkzanyj's advice over on the Sprint Hero forum (thread here) and it seems to have helped speed up my phone in general, which helps reduce the lag before my phone actually rings.

    His tips are posted below for convenience (I don't take any credit for this):

    -clear your browser cache
    -clear your browser history
    -backup sms messages so you can delete threads periodically
    -On the G1 -- keep at least 25-30mb of memory free. Dipping below 25mb free I start to see lag very often.

    I have no more than 2 widgets per screen, and I don't have a home replacement -- Just a waste of space, and since the normal home application is still installed AND running regardless, you've now got another app running in the background.

    --Peroidically going to menu>settings>applications>manage applications and doing the following.

    -Sort by size
    -Start at the top tapping on apps
    -If available tap the "clear cache" button
    -For SOME apps (BE CAREFUL) using the "Clear Data" button can be helpful. But be very very careful, clearing data may remove login information, settings, playlists, or other important things that you don't want to have to re-enter again.

    Things like facebook, the browser, maps, weatherbug, BuddyMob, tend to cache content and this can eat up memory. The Marketplace app is THE biggest culprit, especially if you spend a lot of time window shopping through the market.

    Doing all this stuff I can EASILY get back about 5-12mb of phone memory.
     

Share This Page

Loading...