Tasker and PIN lock


Last Updated:

  1. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,510
    Likes Received:
    230
    I have my phone set up to require a PIN after the screen locks. I don't need it to do this when I am at home though so I would like to use Tasker to disable this when I am at home connected to my wifi.

    I can create a profile tbat detects the required state but I cannot disable the PIN lock. I used the Keyguard Off action but it doesn't seem to work. My phone activates the profile but I still have to enter the PIN.

    Has anyone else managed to do this on an S4? Is Keyguard Off not the correct action?
     

    Advertisement
  2. XplosiV

    XplosiV Master X is Watching You VIP Member

    Joined:
    Jun 10, 2010
    Messages:
    5,422
    Likes Received:
    1,969
    There's a dedicated Tasker forum here Tasker - Android Forums where people are more likely to give you much more relevant advice, i've reported your post just to try to get it moved over for ya. :)
     
    lotus49 likes this.
  3. AntimonyER

    AntimonyER AF Addict VIP Member

    Joined:
    Jun 18, 2010
    Messages:
    13,646
    Likes Received:
    8,004
    Thread moved to the Tasker forum. Good luck!
     
    lotus49 and XplosiV like this.
  4. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
  5. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,510
    Likes Received:
    230
    Although that wasn't exactly what I was after, it did give me the information I needed to create a profile that did what I needed so thank you very much for your help, I appreciate it.

    For some reason using Keyguard doesn't seem to work but using the Secure Settings plugin and PIN disable/enable did the trick.
     
  6. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    NP. I saw your thread in the S4 section and said "Hey, I like that idea!"

    Just a matter of finding the information that worked. :)
     
  7. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    Having messed about with this for ages (one x), i noticed that keyguard disable isn't in the administrative rights section of secure settings, whereas pin/password disable is, which is why it works.
     

Share This Page

Loading...