Tasker - Jelly Bean question


  1. Methos1979

    Methos1979 Well-Known Member

    New to Tasker and I've been playing around with it today. Seems pretty cool so far but a long way to go. Most of the simple things I could program quickly are already being done by Smart Actions.

    Anyway, phone is a Motorola RAZR HD MAXX running Jelly Bean 4.1.1 which I updated to a couple days back before installing Tasker. While poking around tonight in my Settings I found this:

    Settings > Accessibility > Services > Tasker - JB off

    Anyone know what this is? Should it be on? I'm just curious. Like I said, just starting out and I've written four Tasker programs that all work well so I'm loathe to mess with stuff. As an old Navy guy, the motto "if it ain't broke, don't fix it" is kind of a mantra with me!

    Advertisement
    :
  2. chrlswltrs

    chrlswltrs Well-Known Member

    There are some things Tasker will not be able to control if accessibility for Tasker isn't turned on. I don't remember exactly what Tasker is unable to control.

    BTW... Another Navy guy here, 7 years, ELT (MMN), shellback :D
    Methos1979 likes this.
  3. Methos1979

    Methos1979 Well-Known Member

    Good to know. Maybe I'll just turn it on and see what happens! I did run into a problem last night when I tried to write a simple program to turn on the GPS it flagged me saying it was not able to do this which I thought was odd. I'll turn it on and see if I can then write the program.

    As for the Navy - 6 years here, IC1/SS, bubblehead (nuc fast attack subs) :)
  4. silentwitness

    silentwitness Well-Known Member

    on my sgs3 if i turn that option on all it does is make my phone more irritating to use. It starts talking like for example when i open a folder my phone says "Folder Open" and same way when i close it says "Folder Closed" Also if i try to change screens it reads out the screen number. If i disable it in accessibility the talking stops. Maybe its got nothing to do with tasker if so please let me know how to get rid of it.
  5. chrlswltrs

    chrlswltrs Well-Known Member

    In Accessibility there should be Tasker along with other apps listed. From what you are describing it sounds like you have TalkBack checked also.

    Tasker by itself will not do anything just because that option is checked. You have to create profiles and tasks for anything that you want Tasker to do.
  6. silentwitness

    silentwitness Well-Known Member

    talk back is not checked. I originally thought it was liteflow lite that was causing my phone to speak and since then i have removed it but it didnt solve the issue.

    as far as profiles setup i have
    GPS - on when app started
    Silent - as per timing
    Wifi unlock - turns off pin lock screen when connected to home wifi and enables when disconnected
    Bluetooth Unlock - same as above but with bluetooth
    Photo email - emails intruder snap but does not work with pin lock
    Wifi location enable - enables wifi when within cell tower
    Get Light - adjust screen brightness
    Display off - adjust screen brightness
    Display on - adjust screen brightness
    Battery full notification
    Bluetooth off if not connected.
  7. Methos1979

    Methos1979 Well-Known Member

    After turning Tasker - JB to 'on' in Accessibility I was able to write a program to turn on the GPS - go figure. I have not noticed any talking anything since turning it on. In fact, other than the GPS thing, I have not noticed anything different - yet. Stay tuned...
  8. silentwitness

    silentwitness Well-Known Member

    maybe its something with the s3 and tasker?
  9. chrlswltrs

    chrlswltrs Well-Known Member

    That is what it sounds like to me, something Samsung has done to Android.
  10. silentwitness

    silentwitness Well-Known Member

    ya hoping some1 else with the s3 and tasker could check also and see.
  11. S3 and Tasker. Same behavior. Tasker-jb checked and my phone won't stop jabbering. Talkback is not checked. It kinda tuned my phone into my wife. :)

    Unchecking eliminates the TTS, but tasker is less effective. Many profiles no longer function.

    It must be a Samsung thing. No problems of the my old moto.
    silentwitness likes this.
  12. taskersteve

    taskersteve New Member

    Samsung S3 here, cyanogenmod 10 nightly. Enabled Tasker - JB, it doesn't read everything out to me. It did fix an issue where I wasn't able to change the display brightness for more than a fraction of a second though as well as allowing me to set the ringer volume off.

    When it wasn't enabled I still had TTS. Also talkback is disabled.
Loading...

Share This Page