Tasker suddenly stopped working


Last Updated: 2012-09-18 22:44:42
  1. Pinmac1

    Pinmac1 Well-Known Member

    I have a profile for Tasker which turns sound off etc when I charge it at night. It didn't work one night and I realised that Tasker had disappeared from my phone! I was a bit baffled but had it backed up with Appsaver so reinstalled it. Now every time I try to open it it force closes immediately. I bought it before it was available on Google Play so it doesn't show as one of my Google apps so can't delete and re-download from Play.

    Does anyone have any thoughts as I'm really missing all my Tasker profiles and I also want to move Tasker onto my new Galaxy Note? Thanks.

    Advertisement
  2. jonjonjonjonjo

    jonjonjonjonjo Active Member

    i had the same problem. i uninstalled it, deleted the "tasker" folder on the SD card, and cleared the dalvik cache and reinstalled, and it worked find from then on. not sure what caused it in the first place.

    As for the Galaxy Note, you can find the APK for tasker (once it's installed, of course) in the /data/app folder (requires root) under ".net.dinglish.android.tasker-1.apk." from there, you could transfer it over to the new device. i'm pretty sure that's legal, if you did already buy it, but i'm honestly not sure, so don't quote me on the legality. but that's the way to do it.
  3. UncleMike

    UncleMike Well-Known Member

    If you purchased Tasker directly from the developer you should have a validation key from your original purchase; you'll need that after you re-install. The direct-purchase version can only be installed on one device at a time. The Play Store version can be used on any device that's using the same Google account that was used for the original Play Store purchase.

    Removing and re-installing the app make fix the problem, especially if you're able to wipe the Dalvik cahce, but you'll need your backed-up profiles to restore from. These are saved in /sdcard/Tasker/userbackup.xml.
  4. Pinmac1

    Pinmac1 Well-Known Member

    Hi thanks for the replies. I've still got a problem, just not the same problem! I've stopped worrying about the Desire as I've moved onto the Galaxy Note now. I emailed Pent, the developer for help and received a reply in 14 minutes! I've now installed the direct-buy version on the Note and validated it with the code I had still floating around in my emails. So far, so good but I have tried to restore my profiles from the SD card but it says "Warning: couldn't read backup data, sorry". I can see the profiles in the file mentioned by Uncle Mike so if the worst comes to the worst I can re-create them but it would be easier to restore them if I can. Does anyone have any ideas please.
  5. andymand

    andymand New Member

    Running Tasker on an ancient EVO 4G, it recently (like over the last couple months) would quit and restart all day long, despite reboots and whatnot.

    I found this thread, backed up my tasks, uninstalled Tasker, reinstalled, and tried to restore my userbackup.xml file but get the same "Warning" (I think it should be an error, right?) as Pinmac1 reported.

    (I have a nightly task to make a dated backup of the xml file, so I tried to restore the most recent such backup and got the same error.)

    I've searched this forum and Googled for solutions to "couldn't read backup data", to no avail.

    Help?
  6. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    I moved this to our shiny new Tasker forum where hopefully a pro user can help you out.:)
    D-U-R-X and andymand like this.
  7. Pinmac1

    Pinmac1 Well-Known Member

    Hi, sorry to see that you're having the same problem as me. Unfortunately, I never did find an answer and ended up recreating my profiles. Hopefully, someone else might be able to help.

Share This Page