1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Tasker Wifi profile


Last Updated:

  1. psaini

    psaini Member This Topic's Starter

    Joined:
    Nov 26, 2010
    Messages:
    5
    Likes Received:
    1
    hi guys i am trying to get a profile setup for my wifi but that doesnt seems to work very correctly

    Here is what i did

    Cell near<scanned cells near my house> ---> wifi set on
    Wifi near<my SSId>
    <-- wifi set off

    Now i did this thinking if in my area using scanned cells plus in range of my wifi----> it should turn on

    And if the above criteria doesnt match then it should go off

    Please advise if i am doing it wrong

    i was also thinking when i reach back home phone should say welcome home or something ( was trying just for fun) but that doesnt work properly either i was using it with my wifi profile but the it keeps on reading the message few times i was thinking everytime phone changes the cell it reads the message to me. :(

    Will appreciate your help
     

    Advertisement
  2. UncleMike

    UncleMike Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    2,319
    Likes Received:
    482
    I'm not sure what you're trying to convey with this formatting, but your verbal description of what you're doing sounds correct. Make sure you have Toggle Wifi enabled in the Wifi Near context. If it still doesn't work, I would remove the Cell Near context as the next troubleshooting step.
     
  3. psaini

    psaini Member This Topic's Starter

    Joined:
    Nov 26, 2010
    Messages:
    5
    Likes Received:
    1
    Thanks mike

    Its the way it looks on my tasker screen

    Ill try to explain it differently

    1 click on new, profile name wifi
    2. clicked on state and selected cell near
    3. scanned the cells and click on done
    4.It takes you to task edit page click on + sign
    5 click on net and selected wifi
    6 in wifi window set = on
    7back on the main window of tasker and clicked on cell near and select add
    8.select state then select wifi near
    9 put my ssid and clicked on done
    10. clicked on wifi on and selected add exit task
    11 clicked on + sign and clicked on net
    12 selected wifi
    13 wifi set-> off
    14 done
     
    Matt31 likes this.
  4. UncleMike

    UncleMike Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    2,319
    Likes Received:
    482
    If that's EXACTLY what you did, then you're missing the Toggle Wifi option in the Wifi Near context. When Wifi is off, this allows Tasker to turn it on for the purpose of checking Wifi proximity.
     
    Matt31 likes this.
  5. Matt31

    Matt31 Well-Known Member

    Joined:
    Aug 30, 2011
    Messages:
    111
    Likes Received:
    9
    This is a really old thread, but stumbled upon it because I am trying to get my wifi to actually turn on and off when I am in my wifi zone.

    Going to give this a try and see if this set up works, havent been able to find one that did so far....

    Question - if you selected the wifi toggle in the wifi near setting, since it keeps checking to see if you are close to your wifi, does that mean it will drain the battery more?
     
  6. UncleMike

    UncleMike Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    2,319
    Likes Received:
    482
    I have Wifi Near profiles enabled all day and don't see a significant difference in battery life.

    If you're worried about it or it becomes a problem, you can add a location context so that wifi is only scanned when you're near home.
     
    Matt31 likes this.

Share This Page

Loading...