Telus Fascinate Soft-BrickedSupport


Last Updated:

  1. OtterBoxing

    OtterBoxing Member

    Hey guys,

    I'm trying to help a friend with a phone he bought off someone.. He told me it wouldn't power on.

    note: I'm by no means an expert myself

    But if I tried holding the volume up rocker and power and I get a screen with 7 lines of red text.

    RST_STAT = 0x1
    PMIC_IRQ1 = 0x3
    PMIC_IRQ2 = 0x0
    PMIC_IRQ3 = 0x0
    PMIC_IRQ4 = 0x0
    PMIC_STATUS1 = 0x80
    PMIC_STATUS2 = 0x0

    From this point the phone only responds by powering off by holding the power button.


    However, I can get it into download mode by pulling the battery, holding the volume rocker down, plugging it into the computer, then reinserting the battery.

    I tried to flash back to stock by using the files found in the following thread:

    [TELUS ONLY] [GUIDE] Complete Guide to Flashing Custom ROMs On Your Telus Fascinate - xda-developers

    s1_odin_20100512.pit in "PIT"
    T959TLJL3-REV03-ALL-low-CL763100.tar.md5 in "PDA"
    T959TLJL3_FROYO_Phone-CL763100.tar in "PHONE"
    SGH-T959D-CSC-TLSJL3.tar.md5 in "CSC"


    Unfortunately every time I try and run ODIN it fails at Kernel... My ODIN log, reads as follows:

    <ID:0/007> Added!!
    <ID:0/007> Odin v.3 engine (ID:7)..
    <ID:0/007> File analysis..
    <ID:0/007> SetupConnection..
    <ID:0/007> Initialzation..
    <ID:0/007> Get PIT for mapping..
    <ID:0/007> Firmware update start..
    <ID:0/007> zImage
    <ID:0/007>
    <ID:0/007> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)


    I tried one other version of ODIN, but with that, I couldnt even get it to recognize the phone.


    Not sure what my next step should be in hopes to help unbrick this phone... any help in this regard would be much appreciated.

    Thanks in advance.

    Advertisement
  2. OtterBoxing

    OtterBoxing Member

    I tried running ODIN with the separate file parts; PIT, PDA, PHONE, CSC... and I noticed that the only process it fails on is PDA, everything else goes through just fine.


    Any ideas at all?
  3. lakshans

    lakshans New Member

    Hey I'm having the exact same problem. I've tried so many things. Please, I'm desperate. Anyone know a solution?
  4. I have the fix
  5. I did this process to unbrick mine.

    First download these odin files.

    Unbrick Telus Samsung Fascinate

    Then follow these instructions.

    Open ODIN. Put the files in this exact order in odin.

    s1_odin_20100512.pit in "PIT"
    T959TLJL3-REV03-ALL-low-CL763100.tar.md5 in "PDA"
    T959TLJL3_FROYO_Phone-CL763100.tar in "PHONE"
    SGH-T959D-CSC-TLSJL3.tar.md5 in "CSC"

    Once this is complete... NOTE Do not plug phone in until this is done. Once you have completed this then hold down volume rockers and plug usb in to phone. Once it shows your phone is ready press start and wait for it to say finish. Do not unplug phone until it is compltley turned on..
  6. bobmutchseo

    bobmutchseo New Member

    it is not clear which phone you are referring to here, SGH-T959D or SGH-T959P, they are both called Fascinate. what model are you referring to?
  7. superbigcat

    superbigcat New Member

    (i put the link in the tittle. you'll have to type in the link as i'm not allowed to post links on my first post...)

    download all the files from the thread link above.

    i had to get my phone into download mode without screen input. i held both up and down volume buttons, plugged in the micro usb connected to my computer. there should be a usb plug in tone. after it's plugged in, you may get the red line glitch, other screen glitch, or blank screen on your phone. ignore this and press the volume up key once.

    there's a program called 'zadig' in the 'drivers' folder in the heimdall zip file. launch this program, click 'options > list devices' from the menu. if your samsung galaxy shows up in the drop menu, click install driver. if it asks, click install anyway.

    after that, power off the phone, get back to download mode following my directions above, then follow the directions from the rest of the thread link above. you may not get the same output results (uploading kernel 100% etc...) but if it reboot the phone to the startup screen, then you've unbricked your phone.

    hope this helps...

Share This Page