telus rugby lte(pro) rooting issue

Last Updated:

  1. scotcho

    scotcho New Member

    Hello all. band spanking new when it comes to this forum and when it comes to andriod...and rooting android. Its a very informative site so i thank you.

    anyway to the grit of things. I recently attempted to root my phone, I was able to get as far as loading CWM on my phone and booting into it. Here is were i get stuck. I try to install a zip from the sdcard and i get a message "Cant mount /sdcard/"
    i've tried manually mount from cwm
    i've tried clearing caches
    i've tried factory restores
    i've tried google

    Anyone have any i dea what could cause this , or a point in the right direction? Sorry if this is a noob question. usually i can figure out these things on my own.but this one has me stumped........and with a phone that is now getting warrenty (i hope) work done. but thats another story all together haha

    also i should say it is a Telus Rugby LTE (model# same as PRO) running Jelly Bean.

    Thanks everyone.

  2. kemonine96

    kemonine96 Well-Known Member

    Can you try the TWRP image at as well as the root instructions from that thread as well? The Jelly Bean update tweaks a few things that cause the ICS root method to no longer work. The rooting method described at the above link works on ICS and JellyBean.
  3. scotcho

    scotcho New Member

    I will definetly give that a try once i get my phone back. From what ive read, before my first attempt at rooting. The only difference was how to get into CWM. apparently there is more to it.
    rookie mistake i guess.

    And thank you for the reply.
    I expect to have my rugby back by next week. Then i will give'er a try and post my results here.

    thanks again

    JACK_DAGNIELS New Member

    I was wondering if this issue had been resolved as well. I just got my Rugby LTE a few weeks ago and was hoping to root mine as well.
  5. Herb9453

    Herb9453 New Member

    Hi I have just attempted to root my phone. I have done quite a few other phones but am a little stuck here!

    I got odin to go successfully and did everything correctly. But when I go back to recovery mode it is still on Android Recovery. I go back to the Odin mode and it says that the binary was successful. That it is custom. I go back to recovery try to install the and it is having a problem with the E: signature crap. I believe I dealt with this before but have not done a samsung phone can u please let me know what I can do to correct this :))).


Share This Page