Terrible 4g download speeds and wifi droppingSupport


  1. big_tiger

    big_tiger New Member

    Just picked up the Motion yesterday, and ran speedtest. Im getting 400-600kBps down and 4mBps up. I dont know if it matters, but I am on the cheapest 4g plan (testing to see if its worth the money). The first test was stock rom, no root. I am rooted and have the de-oxed rom now.

    The wifi is randomly dropping as well. I have my old evo 4g and it isn't down when the Motion is.

    Advertisement
    :
  2. twogbsd

    twogbsd Well-Known Member

    You have most likely gone over your 4G usage. The cheapest plan ($40) is 400MB of 4G, then you get throttled at 3G speeds on 4G. This sound like the case. I recommend you upgrade to the $50 plan. You can use up to 2.5GB of 4G data.

    As for the WiFi, can you discribe it more in detail? Does it drop when you turn off the screen? What kind of router are you connected to?
  3. Gman9831

    Gman9831 I'm no Senior Guide

    500MB & thats not 3G speeds, 5mbps upload?
  4. Gman9831

    Gman9831 I'm no Senior Guide

    OP have you checked with metro to see if you went over the data cap which isnt likely by what I said up there. Maybe you should file a complaint on there facebook page
  5. Matthew83

    Matthew83 Well-Known Member

    I have no answers regarding the 4G speeds. However, regarding the WiFi problem I have a feeling it is caused from the "MetroPCS Easy WiFi" app that comes pre-installed. I highly recommend disabling that app. After you disable that app the default Android Wifi manager will take over and is much easier to use.
  6. sammyz

    sammyz LG Whiz Kid Guide

    Yea, my wifi wouldn't forget networks due to that app...
  7. Warbonnet

    Warbonnet Well-Known Member

    The Metropcs EasyWifi is a pain, disable or uninstall it if you can. As far as the speeds go I have seen that with mine it will be sub 1mbit down and 3-4mbit up. I don't think it is them throttling you but rather the local network (towers) coverage area.
  8. rooob

    rooob Well-Known Member

    i have the $60 where everything is supposed to be unlimited and my 4g has been horrible, actually it is non-existent. i only get 1x or EV, not sure what is going on, i have restarted quite a few times but nothing, should i go back to the previous firmware?
  9. Gman9831

    Gman9831 I'm no Senior Guide

    1. Have you ever had 4G before on your motion?
    2. Is wherever you are under 4G coverage?

    If yes to #2, call metro and ask to make sure your sim card is properly registered
  10. rooob

    rooob Well-Known Member

    yeah i have had some issues with 4G for the past 3 weeks maybe, it was on and off, but since 3 days maybe, it has been gone, so i thought it might had something to do with the update, but not sure.

    But thanks, i might call just to verify!
  11. Ubercharrge

    Ubercharrge Well-Known Member

    Have you tried updating your PRL? Dial *228 and update your phone to the latest roaming lists.
Loading...

Share This Page