Terrible Bluetooth sound quality since 4.1 & 4.0.4Support


Last Updated: 2013-06-26 23:12:45
  1. paleodust

    paleodust Well-Known Member

    Good question! :rolleyes:

    Advertisement
  2. Trooper

    Trooper Well-Known Member

    In my experience, 4.0.2 was fine, whether on stock or a rom based upon it. I still believe its a radio and/or driver problem. It happens to me on 4.0.4 roms, regardless of which rom I have installed. It happens on Liquid, AOKP, CM9 etc.

    I may (even though I don't want to do this since reception is better) flash 4.0.2 radios back and test. But there is something in the 4.0.4 update that has fubared bt audio quality while on the phone for sure. It is totally unusable. :(
  3. paleodust

    paleodust Well-Known Member

    If you do flash back, please let us know what the results are. I'm not willing to do it, at this point, but I'm hoping somebody's willing to take one for the team. :)
  4. SHIVA77

    SHIVA77 Well-Known Member

    This is total waste of time. We were so waiting for the 4.0.4 and what we got, unusable BT in call audio and rapid discharge of battery.
  5. Trooper

    Trooper Well-Known Member

    I can only report botched bt audio on phone calls. Battery life on stock 4.0.4 was really good for me to be honest.
  6. quickaudi

    quickaudi Well-Known Member Contributor

    so, I think I have the BT issue - honestly don't use mine that often, so I haven't paid attention to how bad it is.

    I'll make it a point to flash the 4.0.2 radios some time this week and report back.
    Trooper likes this.
  7. Trooper

    Trooper Well-Known Member

    You know what, even though I dont really want to, I will flash the 4.0.2 radios today and report back either later tonight or tomorrow.

    Please do this as well if you don't mind, so we can see what's what.

    Cheers.

    EDIT: Radios have been flashed. Will try a phone call on the way home tonight to see what's what. :)
  8. SHIVA77

    SHIVA77 Well-Known Member

    what's involved in "flashing the radio?"

    could someone pls provide step by step instruction and if it can be done on a stock phone. Thanks.
  9. quickaudi

    quickaudi Well-Known Member Contributor

    Can't be done on stock phone
  10. Trooper

    Trooper Well-Known Member

    Well folks my suspicions were correct. Flashed the old radios and low and behold bluetooth audio is now like it was before. Like I have stated in the past, I knew that it was something with the radios. What I don't know is if the radios are somehow combined with the bluetooth driver. I encourage anyone having this issue please try flashing the older radios and let me know how it goes.
    quickaudi and paleodust like this.
  11. paleodust

    paleodust Well-Known Member

    Does it require root?
  12. Trooper

    Trooper Well-Known Member

    Yes it does. I guess your phone is not rooted?
  13. SHIVA77

    SHIVA77 Well-Known Member

    That's what the Samsung agent on the phone suggested. He said for me to send my phone in so they can flash the memory, he didn't say the "radio" but I think that's what he meant.

    So, what's the solution for those of us with stock SGN. I can't use the bluetooth and hate the rapid discharge of battery now.

    We need help for those of us with unrooted phones.
  14. Trooper

    Trooper Well-Known Member

    Open up a ticket with Verizon Samsung and Google. I don't believe that this will be fixed quickly in my experience. Only thing to do if you don't want to root is keep calling Verizon. They will keep sending you refurbished devices. After you have swapped out a few times demand to switch go another phone.


    Or seriously consider rooting your device.
  15. quickaudi

    quickaudi Well-Known Member Contributor

    Did the same thing this afternoon, per your request, when I got home.

    4.0.2 Bluetooth was crystal clear. Heck, I could hear stuff in the background I haven't heard in, well, since I was on 4.0.2.

    4.0.4 Bluetooth sounds like they are talking through water.
    paleodust and Trooper like this.
  16. Trooper

    Trooper Well-Known Member

    Thanks man, appreciate it. Great way to explain the problem. People sound like they are talking through water.

    Well we are now two for two on 4.0.2 radios. Why Verizon why? Wonder if any GSM users are experiencing this?
  17. paleodust

    paleodust Well-Known Member

    Ironically, it was supposed to have cleaned up radio issues. Can't they just fix something without breaking something else?
  18. Trooper

    Trooper Well-Known Member

    That's not always the case. Not sure if a dev can fix it, but perhaps. Hopefully 4.1 will get us all back on track.
  19. SHIVA77

    SHIVA77 Well-Known Member

    VZW is sending me a new Nexus and they said they'll make sure the unit being sent doesn't have the issues I am experiencing. Will keep you guys posted.
    quickaudi, paleodust and Trooper like this.
  20. quickaudi

    quickaudi Well-Known Member Contributor

    definitely keep us posted. i'd be willing to flash back to stock (*gasp*) and take mine in to make them fix it if that's the case.
    Trooper likes this.
  21. paleodust

    paleodust Well-Known Member

  22. SHIVA77

    SHIVA77 Well-Known Member

    The problem with the jelly bean is that, VZW will most probably not release it for 2 months after its official launch. so, I need to resolve my BT issues now.
  23. quickaudi

    quickaudi Well-Known Member Contributor

  24. paleodust

    paleodust Well-Known Member

    Darn! I was hoping it would be closer than that!

    Well, let us know as soon as you can if it works!
  25. paleodust

    paleodust Well-Known Member

    Aaarrgghhh!!!!!!!!

Share This Page