Tethering HTC Hero to Windows 7 - Please help!

Last Updated:

  1. Cornishjake

    Cornishjake Member

    Hi all,

    First off I need to say that I have tried most of the tricks I have found to make this work. Downloaded and tried the 3 latest versions of HTC Sync, installed the drivers manually (first off using Vista x64 drivers, then using win7 drivers from 2.0.18 sync update), downloaded and installed windows mobile device centre to get some of the mobile services (this was recommended on another guide). Rebooted and reinstalled multiple times, it feels like I've tried everything.

    Ok, so I have the latest ROM for T-Mobile, latest Sync, my Windows 7 Home Premium is fully updated (or was before I came home a few days ago), installed the drivers. I CAN sync my phone with my computer, I can also take files from the phone via usb.

    My problem lies in the fact that as soon as I turn on Mobile Network Sharing, it tries to install the drivers and then says it can't. So I install them manually, but during the install of them it tells me 'This device cannot start. (Code 10)'. This is in regards to the NDIS drivers. I know I have them all up to date etc, but this is really infuriating. In the devices and printers screen the android phone is coming up as 'HTC NDIS Device #3' (3 because I have tried it so many times) with the little ! by it and it's fix is to try intsalling again which of course gives the same problem. As soon as I turn off the MNS it goes back to sync + usb connection fine and I can again search it for files etc.

    No matter what I have done, I cannot seem to get the device to 'start' which is what it wants. I was able to get this to work on my old laptop on winxp, but now I have upraded that to win7 as well.

    I'd really appreciate any help on what seems to be an old topic here, as when I came home to my parents for easter (they refuse to get the internet :confused:) I thought this would be easy like it was for winxp and I need the internet to revise for exams.


    P.s I am currently using PDANet, but it is really slow compared to how it was on my laptop, and when the trial period runs out I can't log into my uni files to download lecture notes.

  2. Slug

    Slug Check six! Moderator

    Hi Jake, try this:

    1. Open Device Manager
    2. Expand the USB Controllers section
    3. Right-click on each device in that section and select "Uninstall"
    4. Once all USB host controllers have been removed, restart the system
    5. Windows will load and reinitialise all the host controllers
    6. Now try to enable MNS.

    No guarantees, but this procedure has solved all my mystery USB-related problems over the years so may work for yours.
  3. Cornishjake

    Cornishjake Member

    Thanks for the advice Slug,

    I tried your solution, and after lots of problems with keyboard and mouse (both being usb haha) I managed to turn off the usb devices and restart, which didn't help.

    The problem appears to be with the NDIS device driver - which appears in the network adapters section on the device manager with the infinitely infuriating ! next to it and still telling me it has a code 10 and can't start. Has anyone else had this problem? I read a guide where the code 10 was normal in xp or something, but that was before the NDIS drivers were installed completely, which in this case they are. Or at least they are supposed to be.

    If any other solutions spring to mind, please let me know as this PDANet thing is rubbish and browsing on my phone isn't an option since it can't display the things on my uni website.


    Edit: I managed to get an install for the NDIS drivers that said they were installed correctly, and then when I plugged the phone in it still had the ! with the code 10 error. :(
  4. antipesto93

    antipesto93 Well-Known Member

    i dont alot of that tech speak, but if you are trying to connect to htc sync.,..just uninstall all the drivers ( start fresh) and then plug the phone in, turn the phone if, turn the phone on ( while still plugged in) and done...
  5. Cornishjake

    Cornishjake Member

    It's a strange problem I have antipesto, I can sync and get data off the phone but not tether it to my computer to use it as a modem. :(

  6. antipesto93

    antipesto93 Well-Known Member

    cant you just use pdanet? thats what i use with windows 7? works perfectly
  7. Cornishjake

    Cornishjake Member

    I'm using it but its only trial, and its really slow. I need to use https to get lecture notes and when the trial ends I can't use that protocol.
  8. Lesman

    Lesman Member

    I've run Easy tether on XP for almost 2 years. No problems on 3 machines. I can't get to work on my new Win7 machine. I've downloaded the new HTC syc. I've downloaded the latest 64 bit drivers. They are older than the the 3.0 Sync's drivers. I've installed/uninstalled Easy tether 64 bit twice. It just doesn't see the phone.Easy tether works great for data. It's slow(3G) but works great.

  9. Lesman

    Lesman Member

    I check my laptop with XP. It wasn't working. It was the cable. I was using a dual micro/mini usb cable. When I switched to a cable for the Hero....everything worked. I wasted 3 hours on a non issue. The cable I was using allowed charging but no data transfer.


Share This Page