Tethering Prevail to an Android Tablet via Infrastructure Mode


  1. Jerry in WA

    Jerry in WA Active Member

    Is anyone successfully tethering a Prevail to their Android tablet wirelessly? How about with the usb cable?

    I'm having trouble getting tethering to work on my new Transformer Prime (updated to ICS 4.0.3).


    I'm trying to connect it to my Samsung Galaxy Prevail (CM7 mod, GB 2.3.7). For connecting my laptop or desktop to a tether, I had been using the app Barnacle wifi tether. Sadly, the Transformer (and all androids) can't see my ad-hoc network.

    I'm still trying to make the Google app Android-Wifi-Tether (v3.1 Beta-11) work for tethering in infrastructure mode, something the tablet supports. I've set it to Samsung Indulge and softtap in the settings according to this thread. I set it to channel 6 as well.

    The Prime can see and connect to the network, but I can't access the internet. No traffic. My home computer reacts the same.

    The Prime usually shows the wifi bars in blue when its connected to my house. While connected to this (wifi tether) network, it's in grey with little up/down arrows occasionally showing in center.

    I suspect I just need to tweak app/phone settings.

    Any ideas?


    Side note - The Transformer Prime is off the hook! I recommend it. :D

    Advertisement
    :
  2. Jerry in WA

    Jerry in WA Active Member

    [SOLVED] Credit goes to forum users Necrotoxin and 82iNqcQP in this thread, I'm just summing it up for dummies like me. ;)


    Use Prevail to create an Infrastructure Network (instead of typical ad-hoc):


    • With a rooted Samsung Galaxy Prevail,
    • On PC (or phone), Download android-wifi-tether from here (direct link) and copy it to your SD card (if on PC).
    • On phone, open File Manager, locate the file you downloaded (Download folder or somewhere on SD card) and install it.
    • Go to Play Store (Google Market) and search for "abd terminal emulator" app and get one. I used the free one listed first.
    • Open the abd emulator and you get a command prompt.
    • Type:
    • get dns
    • Within the text, you should see the Boost Mobile DNS servers #s you'll need. There are a few, The ones you want are paired together and look like mine below. Write them down and exit the app.
    • Mine are:
    • 66.1.0.132
    • 66.1.0.133 (Yours should look similar)
    • Open the wifi tether app, open settings,
    • Open "Device-Profile"
    • set to Samsung Galaxy Indulge
    • Open "Setup-Method"
    • set to Softap for Samsung (master)
    • Open "Change preferred DNS"
    • set to ...1st # string you wrote down (mine was 66.1.0.132)
    • Open "Change alternate DNS"
    • set to ...2nd # string you wrote down (mine was 66.1.0.133)

      Tether should now work for tablets. Set up encryption within app.

      To Prevent wifi from turning off at phone sleep...:
    • Press Menu hard-key (enter phone settings)
    • open "Settings"
    • Open "Wireless & Networks"
    • Open "Wi-Fi Settings"
    • Press Menu hard-key
    • Open "Advanced"
    • Open "WiFi Sleep policy"
    • set to Never

    After changing those settings, the tether works for everything. Android tablet, laptop, desktop... I hear this network is also good for gaming systems like the PSP, 360, etc which can't see/use ad-hoc tethering... :D
  3. kevincott

    kevincott Well-Known Member Contributor

    Nice.

    Glad you posted the solution, I am sure it will help others in the future.
  4. Jerry in WA

    Jerry in WA Active Member

    Re-posted better instructions up there. Hate searching through threads 5 years later. :)
  5. briisback

    briisback Member

    OK got somewhere.. downloaded the (yellow) wifi tether from Google play. Opened it up hit menu went into settings. Hit change device profile. Changed it to: generic ics. Setup to auto.

    The Samsung prevail recognized my warps Wi-Fi! NOW, here's what's going on. Prevail says it is obtaining IP address and keeps saying it over and over. It will sometimes say remembered than start obtaining the IP again. Than it will say remembered than disabled and won't actually connect. Why? Any help here?
  6. Necrotoxin

    Necrotoxin Well-Known Member

    Sounds like there is an issue with the DHCP server on the warp. I'd suggest taking it off auto and trying other similar phone's configurations. Other things to note:

    For some reason sometimes things don't like to connect when the AP is unencrypted.

    Sometimes things don't like to connect when the AP is encrypted.
    ^Try both, first try unencrypted if nothing then try encrypted.

    Change the channel.

    Try the above step for the SGP in the second post.

    Basically change everything one thing at a time until you have a working installation, at this point I typically uninstall the app, then re-install it with the exact setup I find to be working, this will clear out the unused binaries and I just find it to be a good practice to start fresh after troubleshooting and finding a solution.

    I don't personally have a warp so I haven't had a chance to play around with it, I actually have only ever had the prevail and a chance to play with my dad's iPhone. Anyway, good luck and here's hoping you can be the guy who discovers the method for the Warp.

    Also, I personally try to avoid any form of auto-configuration, sure in a lot of cases it makes things simpler but you're not learning anything from just tapping and going. :D
  7. briisback

    briisback Member

    Finally got a infrastructure connection from the warp to prevail under yellow WiFi tether.. will have step by step log on how to soon. Check it out!

    Attached Files:

    Lordvincent 90 likes this.
  8. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Congrats! That's awesome! I'll have to check it out when i get back home. :) (i have a donor, and my rm uses the warp as his primary)
    liltwentytwo likes this.
  9. wilfredojr978

    wilfredojr978 Well-Known Member

    With the samsung prevail.I use the yellow wifi tether app(which i guess is not available in the play store but in blackmart)I go into setting change device profile to samsung captivate or fascinate,then setup method to softnap for samsung.scroll down to preferred dns and put the above dns settings.And should work perfect.It sometimes will restart if your battery gets too hot.But other than that its fine.I use ps3 with it all the time and hardly hvae any issues besides the restarting.

    Also does any have any other dns.I have notice you could use 66.1.112.0,and 66.1.120.0 and so forth.I would like to see which is the main dns before its broken into seperate proxies.:confused:


    Don't know if it will boost speeds,but i would bet it might be faster like being first in line than 20th in line
  10. Topken

    Topken Well-Known Member

    I use 8.8.8.8 and 8.8.4.4 which is googles dns servers and they work well for me.
  11. wilfredojr978

    wilfredojr978 Well-Known Member

    Its wierd cause when i leavre those default i can't get internet to anything trying to connect to my hotspot
  12. creed10

    creed10 Well-Known Member

    Strange, I'm having the EXACT same problem! Except I have the tf101. The thing is, before I flashed cm9 on my tf101, tethering worked perfectly fine. Of course, I used wireless tether, not wifi tether:cool:
  13. wilfredojr978

    wilfredojr978 Well-Known Member

    Tf101 is which phone
  14. TheRealMillah

    TheRealMillah Well-Known Member

    This isn't working for me.

    I went to the market and searched for "abd terminal emulator" the 1st app that came up for me was "Android Terminal Emulator"

    I installed it, opened it and typed in "get dns" just as it was showed.

    It says "get: not found"

    Am I using the wrong app?

    [​IMG]

    [​IMG]
  15. wilfredojr978

    wilfredojr978 Well-Known Member

    Its getprop or try getdns
    TheRealMillah likes this.
  16. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    wilfredojr978 likes this.
  17. TheRealMillah

    TheRealMillah Well-Known Member

  18. TheRealMillah

    TheRealMillah Well-Known Member

    So I go my DNS info and followed the steps above.

    When I start to tether is says: "tethering started with errors, check log"
    but I can't check the log because there's no log file.

    Then when I stop the tether it says: "unable to start tethering, is your phone rooted?"

    And my screen looks like this: "Your phone is currently running in an unknown state - try rebooting"

    [​IMG]
  19. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Did you set profile to indulge and method to soft tap?
  20. TheRealMillah

    TheRealMillah Well-Known Member

    Yes, I followed ALL of the directions listed in the directions.
  21. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Sry, just trying to be thorough..... Usually there is a blue icon in the status bar (but i just tried with miui and no icon, but it's working fine for me)
    This is the version i have
    http://db.tt/yIWp6nkh
    It's not the newest one, but it works every time on my phone.
  22. TheRealMillah

    TheRealMillah Well-Known Member

    I'll try this one. Thanks.
  23. DarkJedi

    DarkJedi Well-Known Member

    I use Beta 6. Along with using the Indulge/SoftAP settings, I had to change the LAN network to use a different subnet than default. It then worked for me. Didn't need to change the DNS.

    Just something for others to try.
    Lordvincent 90 likes this.
  24. TheRealMillah

    TheRealMillah Well-Known Member

    Nothing seems to be working. I think I give up for right now. *sigh*
  25. wilfredojr978

    wilfredojr978 Well-Known Member

    I use the newest put Samsung fascinate soft AP
    And change my dns
Loading...

Share This Page