text message errorwhen i send a text message i get an error that says message sent using invalid num


  1. outkast25

    outkast25 Well-Known Member

    when i send a text message i get an error that says message sent using invalid number of digits. please resend using 10 digit number or valid short code msg 2114. but the number is correct and ive sucessfully texted that same number from my contacts before. i havent changed or altered that contact at all. what is this about??!!


    [​IMG]

    Advertisement
  2. jdmckay

    jdmckay Active Member

    I have got the same error on a couple of people.
    At first I thought I had the contact saved wrong.
    But it wasn't that. It happens when replying to a message that was received.
    I have had it happen on 2 separate text message threads. And it is definitely reoccurring.
    I can't figure out how to get it to go away.
  3. anticitizenone

    anticitizenone Well-Known Member

    it looks like you are trying to send a text to a 4 digit number

    that would be what I think is a "short code" you have to call sprint and have this turned on because most of the time its turned off

    I had this problem trying to send a text to google 411 at 466-453
  4. icecold

    icecold Well-Known Member

    I have had this happen a few times when trying to Swype a contact name in. Instead of selecting the appropriate contact, I ended accidently hitting the number equivalent of the name...
  5. garak0410

    garak0410 Well-Known Member

    Has anyone resolved this yet? I accidently sent a text to a home phone number and now, anytime I open an existing text message, it displays that error again...in the notification bar, if you try to go to the next, it goes to a new text message..if you discard and then go into another existing message, same thing all over again. Frustrating to say the least!
  6. ncbrowns

    ncbrowns New Member

    My wife is having this problem also. The contact has a 10-digit number with the same area code as her phone. However, when the message is sent, it's being sent using the 7-digit number. The "9230" above is from the Sprint error message; it has nothing to do with the number being sent to.
  7. Kossack

    Kossack New Member

    Hi All,

    I have the same problem---and cannot text my wife (we text throughout the day) and I cannot figure out a solution. If anyone resolves this, please post! Driving me batty since April 7th.
    Could it be related to a virus or app bug?

    Thanks!
    Kossack
  8. garak0410

    garak0410 Well-Known Member

    Not sure if this is the same problem but mine went away by sending another text to the CORRECT number of the person and then I saw the original error message in the conversation...I held down on the error and chose delete and problem went away...
  9. mynewandroid

    mynewandroid Active Member

    I'm having the same issue when texting my wife. This just started happening a few days ago.

    Her contact name/number is set up correctly as 727-xxx-xxxx. I am able to send her a message as a new thread with no problems. Once she replies and I go back into the messaging app it drops the area code and just shows her contact name and number as xxx-xxxx. Then I can't reply within that thread without getting the "9230 message sent using invalid number" message. Have to delete the thread and start another to reply to her text. This is a major pain in the a$$!

    Anyone figure out a fix yet? I have tried deleting and creating a new contact for her several times and it does not fix the problem.
  10. nssgmail

    nssgmail New Member

    I too am having the same problem that just started this week, but on only one of my contacts. If I reply to a text from my daughter, it drops the area code; if I try to send a text from the contact list, the area code shows in the contact, but drops it in the text; if I goto compose new text and type her name, the correct 10-digit number shows up and it goes through. I have deleted all threads between us, deleted her contact, hard reboot and added new contact, but it still wants to drop the area code. If I put in a fake number and send a text from contacts, the area code is included, but not her cellphone number. It is very frustrating and can't figure out why, on her number only, that the area code keeps dropping in messaging!!! Help, if anyone knows why this is happening 2 months after updating my phone and why only on this one particular number...
  11. nicole_epic4G

    nicole_epic4G New Member

    THANK GOODNESS, I'M NOT THE ONLY ONE!
    Just started happening last night.
    Only when I text my boyfriend.
    I've tried resetting my phone, deleting all of my history,
    all my texts, recent calls, logs, everything.
    And the problem still occurs,
    I tried deleting his contact and only entering the number,
    After deleting all of my history,
    And the same thing happens.
    Please please, somebody must have figured it out by now!
  12. Spider247

    Spider247 New Member

    I asked someone for a number and they texted it over to me without the area code. I sent a text before noticing and now even with the right 10 digit code it will not stay. I have deleted the contact and all traces of the message thread. I have removed the battery and re-entered the contact and highlighted default for the number. Every time they respond it reverts back to the 7 digit version of the number and I can't respond. First time I've had this problem. Had phone since last year and have several hundred contacts. Not going to reset to factory just for one issue. There must be a way to get in and edit the root directory for contacts to really wipe out the info. Because clearly deleting it is not enough.
  13. mynewandroid

    mynewandroid Active Member

    I contacted Sprint support back in April. They recommended I do a hard reset and wipe the phone. I backed up my contacts to the SD card and wiped the phone. Reinstalled all apps and imported contacts back in.

    Good news: It fixed the missing area code issue. I also found my battery life to be much improved after the hard reset. Not sure, but I must have had some apps that were eating my battery up.

    Bad news: The problem has just come back (for the same contact no less) so it looks like my fix lasted only two months.

    This is a software glitch that Sammy needs to fix!
  14. QACoach

    QACoach New Member

    Same problem here. Prob first appeared when I tried to text a contact that only had the 7 number phone number in my contact list. Figured that one out pretty quickly, added the area code (same as mine) and successfully sent the text message.

    When I got his reply back, and sent another reply, and got the error message. It was then that I noticed that his reply to me was ID'ed only with the 7-digit ph number. I'm guessing this happens only when in the same area code as the person replying to you. I can create a new message and send a new thread, but anytime I reply to his messages, it errors out because of his 7-digit number.
  15. AndroidSPCS

    AndroidSPCS Well-Known Member

    This issue just started happening last night on my Epic. Very frustrating! I can't believe Samsung has not issued a fix for this bug yet!!

    This is one major bug that really is hindering usability.
  16. marleyac

    marleyac New Member

    Just like mynewandroid, I went to the Sprint Store after having this issue with my husband's texts and they recommended a hard reset. UGGGG. I did it and it fixed the issue but yesterday, this crap started again with a different contact. He has a different carrrier and doesn't even use an android phone, but was someone I had been texting more frequently.

    I can't believe the only solution is to do the hard reset again.

    I'm not sure if it related but I was having issues at the same time this started syncing my Google tasks with Astrid Tasks and Jorte. It wasn't the syncing, per se, that was the problem, but even when I changed the task due date, when I synched to Google, the dates changed and deleted tasks returned. I sync every day and this was a new behavior.

    Could this be some kind of virus?
  17. captron

    captron New Member

    One guy who manages a Sprint repair shop and seemed to really know his sh*t told me to delete the contact and reinstall it and the 7 digit dial thing is supposed to go away. It is worth a try. Please report back success or failure.
  18. Chris76316

    Chris76316 New Member

    My mom was just having the sameproblem with her phone and asked m to lok at it. like all ofyou i tried numerous different things to no avail. then i tried deleting everything having to deal with my contact (messages, contact info, and even the eror messages she was geting back rom trying to send a text to me) and then tried to start a new message. i then typed my number into the new mesage field, typed a message and hit send. i got the new message with no poblem. i hadn't been receiving texts from her for a couple days. as of right now thisworks so give it a try and see if it wrks for you guys. Hope this helped!
  19. luvcoffee

    luvcoffee New Member

    Uggg! I have the same problem I've tried deleting contact then having them text me back but it dropped the area code AGAIN!!!! so irritated right now! Galaxy S from sprint now the (EPIC fail phone)
  20. ko57

    ko57 Member

    I had this problem, deleted 7 digit # and msg, it went away. Entered contact w/10 digits. Notification eventually showed up again so took battery out for about a minute and the stuck notification finally disappeared.

    Keeping fingers crossed.
  21. geedavey

    geedavey New Member

    I've been having the same problem. Sprint sent me an update, no effect. I deleted the contact from my phone and from Gmail contacts, and checked Facebook-contact is 10-digit there. No effect. Finally I click+hold on the last message i received FROM this person, at the context message chose "edit contact" and added in the area code. I'll let you know if it works.

  22. ko57

    ko57 Member

    What ive had to do was delete the message, contact, and then addthw contactw/ the area code as needed. Ive also triedtaking out the battery with the phone still on then restarting it. It doesnt qlways work but usually does.

    I think getting rid ofcthe source contact that is in error and all messages relating to the contact including the error msg from Sprint helps. Then take out battery/then re insert to restart the phone.
  23. knicholson1

    knicholson1 New Member

    This worked for me. It will remove your old text messages (and call history probably), but leave your contacts unchanged.

    1. Delete the message thread for the contact causing the issue. I'm not 100% sure this is necessary.
    2. Click the Home button to go to the main screen.
    3. Go to Settings >> Applications.
    4. Choose the All tab to show all installed applications, including system and preinstalled apps.
    5. Find the application named Dialer, and tap it.
    6. Click the Clear Data button, and then Yes on the confirmation dialog.
    7. Find the application named Dialer Storage, and tap it.
    8. Click the Clear Data button, and then Yes on the confirmation dialog.

    You should be good to go now.
    ko57 and DannyB like this.
  24. ko57

    ko57 Member

    hey knicholson1,

    Does this delete (any of) the call logs? Sounds like it clears the memory cache for the dialer, but just wondering if this would delete anything else, thanks...

    ko
  25. drexappeal

    drexappeal Well-Known Member

    Oddly enough, I'm getting this text message, but only when I receive a Voicemail. I tried to do what knicholson1 recommended, but the Clear Data was greyed out and not clickable.
Loading...

Share This Page