1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Text message indicator WON'T go away :(Support


  1. steveu694

    steveu694 Well-Known Member

    I pre-ordered my S3 from Sprint and got it on the 21st. After a day or two I noticed I kept having a text notification even though I didn't have an unread text. I did 2 battery pulls, 2 factory resets. Nothing worked. I read each text individually, deleted all the texts, this did nothing. Notification still stays. I was pissed off, so I held down HOME and cleared the RAM. This only worked UNTIL I got a new message - then it starts all over again.

    I went into Sprint on Sunday for the release, thinking my phone was faulty, I traded it for another S3. An hour after I got home it did the same exact thing as my previous phone. I texted myself to test it. After a few texts, there is that damn 1 again by the envelope.

    I messed with the volume thinking that maybe because it was silent, the text would show because there was no sound - NOPE. I pulled the memory card thinking that caused it to sync to my new phone - NOPE.

    I googled it a lot and have heard others having this same issue around the world. Can anyone help?

    Advertisement
    :
  2. CPado

    CPado New Member

    Hi Steveu694. Im having the same problem so i thought i would come on here to check it out but i always have it on my phone icon and it pisses me off. Did you find out how to remove it?
  3. jimbo1mcm

    jimbo1mcm Well-Known Member

    A different forum suggested turning off the stock messaging app and installing GO SMS. Not a perfect solution, but give it a try and let us know if it works. I am waiting on my S3, so I can't try it.
  4. steveu694

    steveu694 Well-Known Member

    I found the solution. Settings...developer options...uncheck do not keep activities. Fixed!!!!
    ahbaumonkey and jimbo1mcm like this.
  5. hawksight

    hawksight New Member

    I found the solution. Settings...developer options...uncheck do not keep activities. Fixed!!!!

    this does not work, i have all so tried the clearing out the ram, this does remove message only for it to return, once another text as been received.

    , yet to find a full and correct manner how to resolve this issue, with the stock message icon from saying i have a message, when they have all been read. I was hoping the new update from samsung was going to solve this. i have 2 sam g s 3 , one that as this issue and one that does not, even if they are running the same op and software build.
  6. Jan Shim

    Jan Shim Active Member

    I had the same notification annoyance not too long ago and thought it was a software bug (and this is my first Android device coming from iPad 2 and Nokia E71). The solution couldn't be simpler (for me anyway). When you receive a notification for an incoming call or missed call or text message, they first appear in the notification bar.

    Hitting "Clear" does not remove the notification flag that appears on top of the app icon. This only clears the pull down notification page. To remove the flag, you have to tap on the app itself then tap on the event that triggered the flag and it'll disappear. Same goes for miss calls and SMS.

    Hope this helps.
  7. Emily113

    Emily113 New Member

    The same thing is happening to me, I re-read all my messages, including mine. I changed the settings like everyone said to, and it still won't go away. The only thing that stops it, is if I restart my phone. They need a better fix to this before I drain my battery more than it already drains itself...
  8. Chandria

    Chandria Well-Known Member

    Get Handcent and turn off stock messaging...problem solved. ;)
  9. steveu694

    steveu694 Well-Known Member

    Delete thread. I found the issue 2 months ago....
  10. Mr. Ed

    Mr. Ed Well-Known Member

    Interestingly enough I fixed this for someone last week...all we did was delete the shortcut icon and re add it
  11. bprice

    bprice Active Member

    I have this same issues with VZW VVM and with missed calls. Rebooting fixes it but not a solution.
  12. daggers

    daggers New Member

    Just bought a new S3 and had this issue. Tried clearing messaging ap and various other things to no avail. Then cleared the RAM and sorted it.

    If you don't know how to clear your RAM just hold down the home button (i.e. bottom middle), select task manager and choose the RAM option. This is not a risky thing to do.
  13. wxbear73

    wxbear73 New Member

    I am having this problem with my Sansung Galaxy Rugby Pro. The messaging icon is stuck with 3 on it but there are no messages in the folder. This happened before and it was stuck with 3 on it as well. The AT&T store ended up having me do a master reset, which was a complete pain. This has to be a software glitch. I'm hopeful it will eventually get fixed.
Loading...

Share This Page