Text message (SMS) turns into MMS when it is too largeGeneral


Last Updated:

  1. Sensai

    Sensai Member This Topic's Starter

    Joined:
    Aug 3, 2011
    Messages:
    7
    Likes Received:
    0
    hello guys

    I have a Samsung Galaxy S4 GT-I9505 running on Android 4.2.2

    The problem is that whenever I try to send a text message (SMS) that is too large, my phone converts it into a MMS which is meant for photo's and stuff. How do I make my phone just send a second text message instead of having it converted to a MMS? it is annoying because alot of my friends don't have MMS activated on their devices, is there any way to change this?

    thanks in advance
     

    Advertisement
  2. scott_

    scott_ Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    100
    Likes Received:
    11
    About all I can say about the stock sms app, if that's what you are using, under the settings for mms, if you tick the box for "MMS Alert". You will get a notice when your message becomes a MMS message. At this point just back up a few characters till it switches back, either save as a draft or send, and then start a new message.
    BTW sms message character limit is 160, including punctuation's.
    This is how I used to send long messages with my old RAZR2, and Mez.

    Can't say if any market messaging apps work any better for segmenting/partitioning long sms messages.
     
  3. Sensai

    Sensai Member This Topic's Starter

    Joined:
    Aug 3, 2011
    Messages:
    7
    Likes Received:
    0
    well thanks for the tip but that was basically what I was already doing, it's simply annoying that it chooses to convert it into a MMS message rather than just splitting it up into two SMS messages.. yes I'm using the default touchwiz app
     
  4. Darnell0216

    Darnell0216 Well-Known Member

    Joined:
    Feb 15, 2011
    Messages:
    825
    Likes Received:
    197
    Mine automatically creates a second SMS. There's a counter above the send button that starts at 160/1 and will change to xx/2 when I run out of characters in the first one and start a second one. Either there's a setting that your model has or there's a system level change made by carriers when they customize the OS.
     
  5. hohoratza

    hohoratza New Member

    Joined:
    Jan 27, 2014
    Messages:
    1
    Likes Received:
    0
    Hi Sensai,

    I signed into this forum to be able to answer to you because I had the same problem until today. I have a Galaxy Note 2 so the solution should work for you too.
    You just have to go to messages - settings - MMS settings - Creation mode - click on Restricted - and then click on MMS alert.

    That's it!

    In this way it should let you compose an SMS made from 10XSMS. Around 1500 characters. After this it says that the message will be converted in MMS (it has 2kb) but if you restricted already the sending of this type of messages you will have no worry!

    Before I made this change I was able to send arround 3xSMS in a single SMS before it was changing it automatically into MMS!

    Hope it will help you!
    Bye!
     
  6. Husnain Kazmi

    Husnain Kazmi New Member

    Joined:
    May 27, 2015
    Messages:
    1
    Likes Received:
    0
    I have a better thing which you told us.
    On the play store, there is an application "BigSmS". Just install it,then you will be able to send text message upto 2600 characters. It will not be change to MMS.
    I hope it's a better idea.
    Regards :Husnain
     
  7. Sir Andinas

    Sir Andinas New Member

    Joined:
    Jul 15, 2015
    Messages:
    2
    Likes Received:
    0
    Open sms app, open setting, find text message setting, find input method, change to gsm alphabet.
    That's it.
    You will be asked to change setting if you tap send but ignore it anyway.
     
  8. Sir Andinas

    Sir Andinas New Member

    Joined:
    Jul 15, 2015
    Messages:
    2
    Likes Received:
    0
    Open sms app, tap option and go to sms setting. Find text message setting, change input method to gsm alphabet.
    That's it.
    It will ask you to change the setting when you push send, but ignore it anyway
     
  9. moonex

    moonex New Member

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Hey!
    Hohoratza, no, there is no ˝That's it˝ !!!!! I did it on my S4 Active, Gt-i9295, but the phone send all the text in MMS mode... So, something else there's needed!
     
  10. moonex

    moonex New Member

    Joined:
    Feb 26, 2013
    Messages:
    3
    Likes Received:
    0
    Hi!

    Sir Andinas, you didn't mention that, all this ˝talk˝ is about sending sms with diacritic's!!!! In my language, hungarian, there are many diacritics, and if I have a bit of self respect to write correctly, I need diacritics!!! - but if I turn into gsm mode, there will be only few diacritics used, many of them not appear. So, what to do? :( :(
     

Share This Page

Loading...