Text Message Vibrating Alert


Last Updated:

  1. CSTblank

    CSTblank Well-Known Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    98
    Likes Received:
    0
    When I put my phone into vibrate mode (either by using the rocker, or going through settings) my phone vibrates when receiving calls, but not when receiving emails or texts, they just stay silent, so I am completely unaware that I have received anything. Is this actually how Motorolla designed it's phone, or am I making a mistake?

    I receive texts/emails much more than phone calls, but am not always in an environment where I can have my ringer going off. Is there a way to set my text and email alerts (and any other alerts [voicemail, etc.]) to vibrate when in vibrate mode.
     

    Advertisement
  2. JayDH

    JayDH Member

    Joined:
    Nov 15, 2009
    Messages:
    20
    Likes Received:
    0
    I am having the same problem. I can't locate the setting to turn on vibrate alerts for texts and emails. I'm curious if anyone has figured this one out.
     
  3. CSTblank

    CSTblank Well-Known Member This Topic's Starter

    Joined:
    Nov 29, 2009
    Messages:
    98
    Likes Received:
    0
    It's borderline frustrating for me to have an hour or two go by without noticing my phone vibrating only to look at it and have 100 or so missed alerts.

    Lol, at least with my "dumb phone" text alerts went to vibrate when the rest of the phone did too.
     
  4. bmar29

    bmar29 Well-Known Member

    Joined:
    Nov 20, 2009
    Messages:
    69
    Likes Received:
    2
    messaging>menu>settings
    all the way down at the bottom check vibrate
     
  5. Redflea

    Redflea Well-Known Member

    Joined:
    Oct 6, 2009
    Messages:
    2,623
    Likes Received:
    289
    Try using Handcent...better SMS than stock, tons of custom notification options as well. Trumps the native SMS app. Free.
     
  6. Crucifier

    Crucifier Member

    Joined:
    Dec 3, 2009
    Messages:
    11
    Likes Received:
    0
    Missed call will also allow you to add a custom vibrate to sms notifications.
     
  7. JayDH

    JayDH Member

    Joined:
    Nov 15, 2009
    Messages:
    20
    Likes Received:
    0
    THANKS! I have been searching for that for a month.
     
  8. digitalscorpion

    digitalscorpion Active Member

    Joined:
    Dec 20, 2009
    Messages:
    28
    Likes Received:
    1
    this works, BUT, now when ur droid is on ring, it vibrates AND rings. not what im looking for :/ Alot of members complaining.... sure hope moto will update this, it will kill it for me on the droid
     
  9. droidosis

    droidosis Well-Known Member

    Joined:
    Dec 22, 2009
    Messages:
    111
    Likes Received:
    25
    download the app "ring toggle" Put the widget on your screen, It lets you switch between ring , vibrate, ring & vibrate, or silent mode when you touch it. Quick and easy. The apps have separate setting for vibrate i noticed .. The gmail app, and built in SMS app, you have to go into the menu button when your running each app and check 'also vibrate when receiving SMS' or 'also vibrate when receiving email' Yeah, it will ring & vibrate at the same time if your on ring mode, not sure if it does it on ring ONLY though. but you need to have that option checked, and when you set the phone to vibrate only mode, it will vibrate on txt or email. it's working for me, and i have no problems. -droidosis-
     
  10. droidosis

    droidosis Well-Known Member

    Joined:
    Dec 22, 2009
    Messages:
    111
    Likes Received:
    25
    i tested it with ring toggle widget, when it's set on ring only, it just rings..no vibrate w/notification, only on ring and vibrate, does it do it. vibrate only, does as it says. works fine? -droidosis-
     
  11. bmar29

    bmar29 Well-Known Member

    Joined:
    Nov 20, 2009
    Messages:
    69
    Likes Received:
    2
    if vibrate is checked like i mentioned above, and you put it on vibrate, it will just vibrate
     
  12. cybercruiser

    cybercruiser Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    378
    Likes Received:
    29
    The problem is, when I have speaker turned on, it rings and vibrates.

    I'd want the email / text to be the same as the ringer's setting ON / OFF / VIBRATE, but NOT both ring and vibrate, very odd...

    And, yes, that's using the ring control widget.
     
  13. bmar29

    bmar29 Well-Known Member

    Joined:
    Nov 20, 2009
    Messages:
    69
    Likes Received:
    2
    ohh ok. well maybe theres an app that does it
     
  14. DroidSloth

    DroidSloth Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    45
    Likes Received:
    8
    Been using handcent forever, love it, USED to be able to vibrate when texts came in, suddenly stopped. I have been doing tons of crap to the phone including a lot of customizing with Locale. I decided I must have done too much so I formatted the SD card and did a full wipe / factory reset of the phone. Even with the stock messaging app and menu -> notifications on and vibrate on new sms checked, the phone still would not vibrate when a new text came in.

    This is driving me crazy. I do not want to have to install Locale again, but this fixed it when it started happening a month or so ago. I have no idea why it stopped vibrating on text again, but it is seriously frustrating. I just rooted and installed the latest 2.1 ROM this morning and I still do not get vibration when I receive text. Handcent notification settings are set to always vibrate, but it will not vibrate. I'm losing my mind here.
     
  15. jmt9779

    jmt9779 Well-Known Member

    Joined:
    Jan 4, 2010
    Messages:
    540
    Likes Received:
    56
    Droidosis is right.

    I'm coming from a Blackberry and I've had my droid for 24 hours and this has been royally pissing me off (I love everything else about this phone...except maybe some limitations with the calendar). i'm using handcent for texts, have gmail, and yahoo email (yeah, I know about the yahoo emails issues but it's working for me so far), and calendar notifications. when i would put the phone into "vibrate" mode, it would only vibrate on calls and NOTHING else. I looked high and low and checked and unchecked and rechecked a million little boxes. then i downloaded the ring toggle widget and it works perfectly. I just checked both email accounts, had someone call me, had a calendar notification go off, and just received a text and they all vibrated as they're supposed to. (And when i put it back on "ring" mode, they all rang with no vibrations.)

    So the bottom line is:

    1) Ring toggle is simple, easy, clean, has a horribly ugly icon but is FREE :) And most importantly, it works.
    2) Credit to droidosis. Thanks, bro!
     
  16. droidosis

    droidosis Well-Known Member

    Joined:
    Dec 22, 2009
    Messages:
    111
    Likes Received:
    25
    No problem! Glad it worked. Been using it for a while.

    Not sure exactly what settings the app is doing when you select "ring only".

    If you lower the ring volume on the phone manually all the way down, it goes to vibrate mode......if you lower it just once more, it goes to silent mode. That is it though, any more lowering of the switch it doesn't go to a ring only setting.

    So not sure what the ring toggle app is doing when you select ring only mode.

    but as we determined, as long as you tell sms and gmail to vibrate individually in their settings - it works with ring toggle app!

    -droidosis-
     
  17. ssantan2

    ssantan2 Well-Known Member

    Joined:
    Nov 24, 2009
    Messages:
    352
    Likes Received:
    20
    you chould also change ur messaging ringtone to silent. thats what I do
     
  18. nickfro

    nickfro Member

    Joined:
    Nov 13, 2009
    Messages:
    6
    Likes Received:
    0
    I've read about quite a few folks (on 2.0.1 and 2.1, rooted and non-rooted) having issues with the vibrate notification ceasing to function for one or more applications. Despite the settings all being correct, it just won't work. In most cases, the phone *will* still vibrate for incoming calls.

    While some folks have returned their phones for new ones, and others have had success using 3rd party apps (Missed Call, for example), digging around on a Motorola forum, and dealing with the problem myself over the past 48 hours, has convinced me that this is, in fact, a software problem - not a hardware one.

    Android apparently has a quasi-hidden setting that manages the vibrate notification. It is possible (somehow) for it to get flipped to "do not vibrate" and once it is there, there doesn't seem to be any way (at least with the standard OS) to fix it.

    Here's the fix. Download the free Sound Manager application from the Market. It has mixed reviews, but that's ok, you're only going to use it for one thing: fixing your vibrate notification. Install and launch the app, press the menu key, and select Vibrate Setting. I suspect that if you have been having vibrate 'issues', you will see that the notification setting is on "Dont Vibrate" [sic]. Change it to "Vibrate Whenever Possible" (or "Vibrate Only When Silent" if you like) and exit the app. You should now find your vibrate notifications working again.

    Not sure what the cause of this problem is, but keeping this app around should take care of it.

    Original solution was found here: https://supportforums.motorola.com/message/85815#85815

    Enjoy.
     
  19. FrayAdjacent

    FrayAdjacent Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    274
    Likes Received:
    4
    I'm using HandCent and it WILL NOT VIBRATE. Under any settings or circumstances. I set it to vibrate always, tried every vibrate pattern... nada.

    Then I tried the app that Nickfro posted, and if I turn on vibrate there, HandCent will vibrate normally. The BAD thing is, vibrate is turned back OFF when you restart. Have to go back in to the Sound Manager app and turn it back on. WTF?
     
  20. nickfro

    nickfro Member

    Joined:
    Nov 13, 2009
    Messages:
    6
    Likes Received:
    0
    I'm not having that problem, Fray...which leads me to believe you have an app running that is mangling the vibrate setting. I suspected Bedside (which I have since uninstalled, despite LOVING that app), but it could be anything (I reckon) that manages notification settings. Again, I used Sound Manager once and the setting has survived multiple restarts...
     
  21. angelrodriquez

    angelrodriquez New Member

    Joined:
    Apr 28, 2010
    Messages:
    1
    Likes Received:
    0
    I just downloaded the app and can not get it to work properly. I have a Motorola Droid. I went to Settings>Sound&Display>Ringer Volume AND UNCHECKED the box "Use incoming call volume for Notifications." I then went into Sound Manager and went to Menu>Vibrate Settings. I set both the 'Ringer Settings' and Notification Settings' to "Vibrate Whenever Possible." I then used the toggle on the right side of my Droid to set the volume to "Vibrate." HOWEVER, it still refuses to vibrate whenever I get a notification.
    Is anyone else still having this problem? I just want to have my phone vibrate for every notification when the phone itself is set to "vibrate." Please help me or send me an email.
     
  22. bills534

    bills534 Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    63
    Likes Received:
    5
    I use handcent sms and under the notification options you can set to vibrate always, never, or only when the phone is set on vibrate. Just tried it out and it works fine.
     

Share This Page

Loading...