text messages not taking FOREVER to be recieved


Last Updated:

  1. niea

    niea Active Member This Topic's Starter

    Joined:
    Apr 1, 2010
    Messages:
    31
    Likes Received:
    2
    I've got an N1, using the $10 web plan, and for a while everything had been working great.

    Well for the last 2 months or so, about 50% of my messages (both SMS and MMS) aren't received for a while. We're talking anywhere from 30 minutes to 2 days to never. On my end the message looks like it was sent just fine, but the recipients say they never got it. I'm sending to multiple phone times across multiple networks. The problem also happens when I message my husband, who also has an N1 with the same data plan on a family plan.

    What gives? He doesn't appear to have the same problem, though he doesn't text nearly as much as I do.

    I don't want to call CS because I don't want them to realize I'm using an N1 and then switch my data plan.
     

    Advertisement
  2. truoc444

    truoc444 Well-Known Member

    Joined:
    Jan 12, 2010
    Messages:
    46
    Likes Received:
    2
    Have you tried putting the sim back into a dumbphone and sending a few text messages and get someone to send you a few. Then put the sim back in your N1. I had this problem with an unlocked Blackberry running on an iPhone plan on my work phone and it cured the issues i had with receiving texts and calls.
     
  3. Swizz

    Swizz Well-Known Member

    Joined:
    Nov 10, 2008
    Messages:
    730
    Likes Received:
    95
    When in doubt, get a new SIM.

    And don't worry about being forced to change your internet plan. T-Mobile will only force a change when you take a subsidy on a new phone.

    If you are still worried, go to a corporate store and get a new SIM. Half the time, when you tell the rep(who works on commission) that you need a new SIM, they will get you in and out as quickly as possible to move on to someone who may buy something.
     
  4. niea

    niea Active Member This Topic's Starter

    Joined:
    Apr 1, 2010
    Messages:
    31
    Likes Received:
    2
    The SIM I have is pretty new. . .4ish months? I got it right before I got my N1 in March. Messaging was working perfectly until the last month or so, I guess I could try another anyway though.

    Thanks for the heads up on Tmo pricing policy. I just am enjoying the $10 web for phones plan and would hate to get slammed with the higher data plans.

    I could put the SIM back in a dumb phone but it's hard to test since the problem only happens every now and then. Most messages go through timely so it's hard to tell if it would be fixed or not.
     

Share This Page

Loading...