Text messaging truncates area codeSupport

Last Updated:

  1. JimJimmy

    JimJimmy New Member

    I am going crazy! Every time I try to text my wife's phone from my contacts, it removes the area code and errors out when trying to send. I have edited the contact info and sure enough it has the correct 10 digit number.

    I have tried deleting the her contact info and recreating it. No dice. I again deleted her contact info, went to her phone and sent a text to mine and replied. The incoming message has the correct 10 digit number. Replying again stripped the area code and tried to use the 7 digit number. Of course this failed.

    Any ideas? I need some help here. I am not sure if this is an issue with the phone or with AT&T.

  2. socalrailroader

    socalrailroader Well-Known Member

    Does she have a different area code? I thought SoCal still had 7 digit dialing within area codes, we still do up here in the 707 in NorCal. Where I grew up, West Covina, it was 213 when we moved there in 1976, then changed to 818 around 1984 when I was in Junior High and then to 626 in the early 90's, crazy! lol I'm old, I graduated from Covina High School in 1990 :D
  3. hockeybrad

    hockeybrad New Member

    This appears to be an Android problem because as I'm searching for the solution to our new Epic, I see multiple phones have this problem. I haven't found a solution yet.
  4. NoJokenVA

    NoJokenVA New Member

    Clear data in the Dialer and Dialer storage.... under manage Applications> All.

    Good to go afterwards!...

    If you ever called one of your contacts without using the area code. This is what causes your issue when you are replying to contacts SMS messages. Send a NORMAL MESSAGE FIRST after clear data and data storage... If you have Google Voice app on your phone.. Dont send to that first... It will screw up your phonebook.

    Good Luck... I'm good to go!
  5. jaytothedee24

    jaytothedee24 New Member

    If I clear Dialer Storage, I won't lose contacts, right? I'm trying to fix a coworker's phone and don't want to lose her contacts.
  6. mogey

    mogey New Member

    Here is the fix. I have tested it and it works.

    First the issue is you once texted someone with a 7 digit number. Most likely becuase you stored them in your contacts that way. Even if you update the contact info it will always drop the area code from all future messages to that person. Everyone that was stored correctly will message correctly. Deleting the contact and reinstalling them will not work. Importing the contact again will not work. Deleting the message thread and starting a new thread will not work.

    Here is what you need to do.

    Clear data in the Dialer and Dialer storage.... under manage Applications> All.

    That is Settings - Applications - Choose All to view All choices - then find Dialer and clear the Data. Repeat this for the Dialer Storage as well.

    I personally also deleted the message thread first from the text message window and my log history which is a menu item from your call screen.

    This process will not delete all your contacts.

    The only other fix to this problem is to reset back to factory defaults. I don't suggest this at all.

    Good to go afterwards!...
  7. cowward

    cowward New Member

    Perfect instructions!!!
  8. wa2tuff

    wa2tuff New Member

    When I go to Dialer Storage to clear it, there is no button that says clear data like there was in Dialer. Is Force Close the same thing? I haven't done that yet cause I don't want to screw anything up. I also haven't had the opportunity to send a text to the one number that is screwed up.

Share This Page