Text problem: The application Messaging (process com.android.mms) has stopped unexpectedly.Support

Last Updated:

  1. ev1ltw1n

    ev1ltw1n New Member

    Hi All

    There is another post on this problem but it's in the Epic 4G forum not Galaxy S. The solution was a factory reset which I don't want to try yet until I've exhausted other possibilities, so please forgive me for starting a new thread.

    I have a Samsung Galaxy S, T-Mobile UK. Last week I hacked the phone to change the product code from TMU to XEU in order to update the firmware to Froyo 2.2 (a particular reason I don't want to factory reset as I don't know how it will affect a rooted phone). Update went fine, Froyo works well, but I've lost the ability to send or receive text messages. Everytime I try to read or send an SMS, I get a blank screen and after about 20 seconds the message "Sorry! The application Messaging (process com.android.mms) has stopped unexpectedly. Please try again. Force close". Also, all saved threads were showing as 0/* suggesting there are no messages in the threads.

    I have installed Handcent which works fine so I can now send and receive texts, but I would like to fix the issue if possible. Googling the problem suggests deleting all messages/clearing cache which didn't help.

    Any suggestions will be gratefully received!

  2. beer-in-box

    beer-in-box Well-Known Member

    Can it be a memory issue? Because sometimes that happens to me with the other applications? Just telling.
  3. ev1ltw1n

    ev1ltw1n New Member

    Thanks for the quick reply beer-in-box.

    I don't think it's a memory issue. I cleared all my messages and cache and it still happens. Also, it only happens with messaging, no other apps. According to the Settings menu I've got 1.71GB available on Internal phone storage and 5.73GB available on the Internal SD card.

    Since it only started happening since the Froyo 2.2 update I'm thinking it's probably a bug with the new firmware, but I'm pretty clueless with Androids as I'm a new user.
  4. beer-in-box

    beer-in-box Well-Known Member

    I was talking about RAM, but it seems you don't have any problems about that too. Is your phone rooted? If so, you can change your stock messaging application with an 'optimised' one. These things are optimised by some users. You can look for it.
    For example, I am using an optimised TouchWiz and it is so good for now.
  5. ev1ltw1n

    ev1ltw1n New Member

    Yes my phone is rooted. I will try an optimised Touchwiz. Thanks so much for your help!
  6. djmoogaloo

    djmoogaloo Member

    Had the same problem, the only solution I found was system reset which meant I lost my Angry Birds progress!
  7. dw7629

    dw7629 New Member

    can u help me download 2.2 for my samsung?
  8. ev1ltw1n

    ev1ltw1n New Member

  9. leonel77

    leonel77 New Member

    Hello i have found that the problem was with an mms the was recieved - I have installed Handcent which works fine went into the sms deleted the MMS that i have recieved and there you go i count access my Messages again.
    aneeshtk likes this.
  10. leonel77

    leonel77 New Member


    Hello i have found that the problem was with an mms the was recieved - I have installed Handcent which works fine went into the sms deleted the MMS that i have recieved and there you go i count access my Messages again.
    californiaflip likes this.
  11. lookingkarma

    lookingkarma New Member

    I having problem with "Market" application with same error.
    Today I fixed my HTC EVO phone.
    I don't know this solution is working for you or not. Try!!

    1. I had ROM Manager program. if you don't have it, install it from the Market.
    2. open the ROM Manager
    3. find "fix permission" and run.
    4. reboot the device.
    5. then you can open the application w/o any problem.

    That's it.
  12. seepage

    seepage Well-Known Member

    Probably not
    you probably have a different phone
    you are probably in the wrong forum
  13. icklepez

    icklepez New Member

    Hi All,
    I have a messaging problem with my Samsung Galaxy S, this thread has been helpful in trying to track down my problem but i'm stuck again.

    I just received a text from my colleague but I can't open my inbox - it comes up with the 'force close' box, I installed Handcent as suggested above to get to what sounds like the corrupt message but it also forces close on that. Don't really want to do a factory reset as it sounds like you lose quite a lot, any other suggestions before I resort to that?
    Thanks :)


    I'm having the same problem as described above, however, with a slight twist. I have a Samsung Galaxy S 4G from T-Mobile. I get the message when i receive an MMS from ONLY 1 contact! I can receive MMS messages from other contacts. Here is everything that i have tried so far:

    1. Deleting the contact and having the contact send me a message.
    2. Battery Pull
    3. Hard Reset
    4. Had the contact successfully send an MMS message to an HTC Sensation phone and i successfully forwarded that MMS to my phone.
    5. One T-Mobile Tech insisted that my contact's phone was too old. Kyrocera Lingo with Cricket Mobile.
    6. Contact sent an MMS to my old Blackberry (non android) phone using the SIM card from the Galaxy, no problem.
    7. One T-Mobile Tech insisted that it was not a T-Mobile network issue and only a problem with the phone itself. T-Mobile sent me a brand new phone. I put my SIM card, battery and SD Card in the new phone, had contact send me an MMS and it still Force Closed.

    T-Mobile has officially closed the trouble ticket and suggested i contact Samsung. 2 online chats with Samsung Tech Reps were fruitless.
    A Voice Support rep has been working on this issue with engineers and EVERYONE that i talk to is baffled as to why this is happening.

    Anyone care to take a stab??


    After working all the way up to Level 3 Tech Support with Samsung, it was proclaimed to be a compatability issue between my phone and my friend's phone, a Kyocera Lingo. The rep with Samsung had a Galaxy S and inserted a SIM card. My friend sent him an MMS and the Galaxy could not open the message. The rep tried to open up the message several times and was successful after downloading and installing SAVE MMS from the Android Market. Now all of my MMS messages are in one folder and if i want to view them (as opposed to a thumbnail preview) i save them to my SD card. Unfortunately, if the MMS comes with sound, the two are separated into files which are played separately. I guess this is an issue that can only be resolved by one of us getting a different phone.
    I hope this helps ANYONE out there with a similar problem.
  16. californiaflip

    californiaflip New Member

    You're the man! Awesome! I installed Handcent as you suggested and deleted the last two messages before the error happened.

    Messaging is now working fine. Such a simple and easy solution (and Handcent is a much better App!)

    I'm guessing that there is some form of sms dbase where inconsistency between the application registry and the dbase causes the error, deleting the rogue sms or mms gets rid of the problem.

    Unless there is such a thing as a SMS virus which has hidden characters that can affect an android phone . . .
  17. californiaflip

    californiaflip New Member


    Definitely a rogue SMS, it was a text SMS sent by one of my hacker friends with an android phone. I have SMS backup/ restore. After restoring the old SMS database with his offending SMS, the problem came back.

    SMS virus! scary. . .
  18. aneeshtk

    aneeshtk New Member


    Actually I have moved a old message in SIM to Phone memory.
    Afterwards the sms application stopped unexpectedly.
    I installed third party app "go sms pro"
    Then deleted the copied message from inbox of phone memory.
    Now the default sms app is working fine.
    thank u very much for ur input.


    After 15 months of dealing with this issue and going between T-Mobile and Samsung Tech Support, i was finally able to do a warranty exchange. I now have the LG MyTouch 4g phone. Guess what? I STILL get the "processing com.android.mms has stopped unexpectedly" message when i receive an MMS from ONE contact. Sounds like this is an ANDROID problem. NOBODY has been able to figure this out.

Share This Page