Text to Speech TTS Not Working Car & Driving ModeSupport


  1. consultant

    consultant Well-Known Member

    Phone is rooted but stock ROM. I can't get incoming text messages or emails to be read via TTS no matter what I try. I remember it worked a long time ago. I'm using Widget Locker for lock Screen with slider and Nova Launcher and GoSMS Pro for SMS. Checked settings under Accessibility and Google Text-to-speech engine is selected and Driving Mode slider is ON. So here's what I've tried and it has made not difference.

    - Put phone into Driving Mode via toggle
    - Put phone into Driving Mode AND "Car Mode" via Llama event
    - Freeze GoSMS Pro via TB to force use of stock Messaging App
    - Check stock Messaging app settings: Notification=ON
    - Turn Widget Locker OFF (so no slider or passcode needed)

    I tried all of these things in various combinations and nothing would activate the TTS for incoming text messages.

    Any other suggestions?

    Advertisement
  2. funkylogik

    funkylogik share the love peeps ;) VIP Member

    I dont know how to fix that but i used to use the app "Speak It" to read out my texts and it worked pretty good apart from if people put "xx" at end of a text, it read them as roman numerals lol :)
  3. consultant

    consultant Well-Known Member

    I stumbled across a thread from last year and some others had the same problem and found it worked when they ran S-Voice. I have my double tap home mapped to Google Voice Search instead of S-Voice so I never use it. I launched S-Voice, and then TTS works. However, if I do long press and swipe S-Voice away from the open apps list, the TTS stops working.

    Having to remember to keep S-Voice running seems ridiculous. Guess I'll have to go with a third party app and hope it works with GoSMS.
  4. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Hmm one of the first things i did with this phone (maybe 3 days) was disable s-voice and Speak It definately still worked. Dont think i ever tried the native way of doing it though..
    Maybe check that youve set the phone to use Googles tts engine and not Samsung's.. like, if youv set it to use samsung tts and then disabled s-voice, that could be whats causin it?

    P.s, Go Sms has been my default sms app for a couple of years now :thumbup:
  5. consultant

    consultant Well-Known Member

    Well I'm not sure what you mean by 'disabling' S-voice, but I may have read a thread on how to do that. All I did was load Home2 Shortcut or whatever to remap double press of home button to Google Voice Search instead of S-Voice. The app is still there so it's not 'disabled' per se, but maybe I need to reset some setting?

    Anyway, I've come close to achieving what I want through third party apps, but not quite there.

    Getting close. Turned off option on GoSMS to disable other messaging notifications (fixed CloudSMS issue).

    Found two promising apps:

    SMS+Car - Does the job but the it doesn't use the native Google voice recognition and more importantly doesn't read calendar reminders. What it DOES do is mark the SMS messages it reads as read!

    Enhanced SMS + Caller ID+ - This is the better app, it cleaner, more options, used native Google voice recognition. It's missing one thing though, DOESN'T MARK THE SMS AS READ! Dealbreaker.

    Search continues...

Share This Page