Texting error from 9230, 2112 error?Support


Last Updated:

  1. Idleisaac

    Idleisaac New Member This Topic's Starter

    Joined:
    Jan 27, 2013
    Messages:
    2
    Likes Received:
    0
    I'm getting a "You rced this message because you sent a text to a number without the area code or used an invalid short code msg 2114." text when I send a text to ANYONE in my contacts, it just started about 3 hours ago when I woke up.
    I've even tried texting though the default program, GoSMS, and a free-texting program called "HeyWire", and I still get the message. (I even tried texting my phone's number through HeyWire, still got the message)
    Things I have tried:

    • Turning off phone, taking out battery for a few minutes then rebooting.
    • Turning off phone, taking out battery and SD card, putting them back in, rebooting.
    • Erased all of my text conversations.
    • Erased all Dialer & Dialer Storage data.
    • Backed up all of my contacts, then erased them from my phone, then tried texting one of them with just the number (No longer a contact)
    • Tried texting while on 3G/WiFi.

      None of those worked, and I've tried each multiple times. I"m still able to connect to 3G/WiFi, but for some odd reason I can't connect to the internet with 3G,,,
     

    Advertisement
  2. Dracable

    Dracable Well-Known Member Contributor

    Joined:
    Oct 11, 2012
    Messages:
    614
    Likes Received:
    108
    a quick google search gave me this. might be relevant. might be just a setting in ur sms program. also, have u just tried putting a 1 in front of the area code? give it a shot.
     
  3. varenHjames

    varenHjames Well-Known Member

    Joined:
    Jul 23, 2012
    Messages:
    177
    Likes Received:
    13
    also, try taking out the sim....and leaving it out...or backing it up, formatting(or just erase, who knows) then trying? are you rooted? and if so, do you have any odd permissions that pop up?
     
  4. Jeni_James

    Jeni_James Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    212
    Likes Received:
    12
    VM just redid their ENTIRE system. Phone numbers NEED to be like this: (***)***-**** or they WONT work.
     
  5. Moth Speck

    Moth Speck New Member

    Joined:
    Feb 24, 2013
    Messages:
    1
    Likes Received:
    0
    All my phone numbers are just like that, and I still cant send or receive texts. And it seems VM is STILL updatng their system....for TWO weeks or more now.:mad:

    Is it likely this text problem is related to this update?
     
  6. Jeni_James

    Jeni_James Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    212
    Likes Received:
    12
    Call them...
     
  7. nigt4003

    nigt4003 New Member

    Joined:
    Jul 8, 2015
    Messages:
    1
    Likes Received:
    1
    I found out that updating your PRL helped me in this situation. Im not sure the cause, but it may have fixed it.
     
    roadkill42 likes this.
  8. roadkill42

    roadkill42 Well-Known Member

    Joined:
    Jan 22, 2013
    Messages:
    2,142
    Likes Received:
    379
    Good glad u got it fixed
     

Share This Page

Loading...