The application settings (process com.android.settings) has stopped unexpectedly. please try again.Support


Last Updated: 2012-11-09 08:56:48
  1. CCCC

    CCCC Active Member

    Interesting. On my Droid X, I get this message when I tap the battery icon while my phone is plugged in to the wall charger. Displays this message, then gives me the icon to force close. When I unplug the phone, it's normal and shows me the information such as time since unplugged as well as the normal information about percentages for what applications have used battery on the phone.

    I am running (2.2 froyo stock). No modifications or leaked downloads have been used on this phone. Have not reached anywhere near a 70 application milestone as well. Also have done a factory reset once now, as to correct this problem...but still persists.

    Curious if anyone else is experiencing this problem, as I have read of this for a few different android devices (i.e. evo 4g and an epic).

    Advertisement
    sexylover1 likes this.
  2. RHS

    RHS Active Member

    I noticed mine doing that today, but with it unplugged. After waiting awhile, it works again.
  3. dlim98

    dlim98 New Member

    same problem, unplugged
  4. mpalsson

    mpalsson New Member

    I also get this message, but it's when the phone is not charging. I did pull the battery for a minute and when I restarted the phone everything is working fine for the moment.
  5. binary visions

    binary visions Well-Known Member

    This is a widespread problem and there are lots of threads on it.

    Theories on why are varied but many people agree that if there is no battery data for the phone to show you (i.e. it is plugged in, or was only just unplugged), the application will force close.
  6. Hrethgir

    Hrethgir Well-Known Member

    I get this all the time, even after the phone has been off the charger for hours. Then it will suddenly work, and even though it had been FCing all day, it will know how long it had been unplugged and what apps had been using the battery. It seems like the underlying program is working fine, but whatever part of the battery monitor displays the info has a glitch of some kind.
  7. Wug

    Wug Member

    Model: DROID X
    Android Version: Froyo 2.2 OTA
    System Version: 2.3.15.MB810.Verizon.en.US
    Root status: Rooted

    This problem has been really bugging me, with no solution posted anywhere on forums. I spent forever trying to figure out a way to fix the Force Close battery problem; "com.android.settings has stopped unexpectedly..."

    I found a solution; at least I think so (it could just be a coincidence):

    1. Download Super Battery by tobyyaa.
    2. Install it
    3. Charge with it open (or maybe not even, I haven't tried any other way):
    4. When its done, unplug it with Super Battery still open.
    5. Close out of Super Battery (via back key or home button)
    6. Now try out the android battery monitor --> it should work now, and keep working!
    7. The only drawback so far is it seems that super battery might actually drain the battery according to the android battery monitor (but I don't think its really accurate, because my battery is running really well, better than it ever has before; I think that maybe it displays this because the program was open when I was charging)

    --Does this solution work for any of you, or did I just get lucky and the glitch randomly stopped for me?

    Hope this helps.

    Check out the other apps I use and love:
    MyApps at AppBrain.com
  8. Wug

    Wug Member

    UPDATE

    Ignore my "solution" its false. It just happened to start working again for a little. Also superbattery is wack, dont download it.
  9. TKWEBB4

    TKWEBB4 New Member

    i am getting the same error message when i receive calls and when i go to sounds. I have a huawei ascend and i have only had it for a week and i can't hear anything on my phone through speaker it doesn't even ring or play music this is really making the phone useless do anyone have any idea how to get this working, i have already taken the battery out millions of times and i have uninstalled all apps that i downloaded!
  10. spankyward

    spankyward New Member

    I had the same issue. I've had the phone a week. When I'd get a call it would pop up and not let me answer it. I had to do a complete factory reset and so far it's fixed it. No issues. Hopefully it will stay that way. One possible reason might be an ap I downloaded called AVG antivirus. I installed it again, then read some bad posts on it and uninstalled it. Fingers crossed.
  11. cloud2or3

    cloud2or3 Member

    When I get the error.

    I went to my contacts. Found who i wanted to call. Tapped it. gets me to the details of the contact. tap the phone number. and thats when i got the error.

    It seemed to be on only that contact. if it happens more I can post.

    I really want to like this new android phone, but i am really beginning to wonder...............

    I've been spending the last week trouble shooting...
  12. Pentil

    Pentil New Member

    Can some one help me? I am using Froyo 2.2 and APN is not working any time I tried to connect it says process com.android. settings has stopped unexpectedly.
  13. MarvDawg

    MarvDawg New Member


    How long has it been since you did a factory reset?
  14. ppacie

    ppacie Member

    Hey Guys,

    I'm having the same error message when I try to add an Android Widget. I've tried to take out/in the battery, restart the phone, etc. but the error message is still appearing.

    Is there any solution?

    Thanks.
  15. traumajunky

    traumajunky New Member

    I get the message when I try to add a widget to my home screen on my Samsung Gem. It's a new phone for me, only had it a week, and I definately have nowhere NEAR 70 apps, I think I have 10!! I don't want to master reset it......seems like too much of a problem, especially if it doesn't work!!
  16. iagman

    iagman New Member

    I received the "process com.android.settings has stopped" error message whenever I tried to add widgets by long-pressing on Home screen then choosing "widget" from popup box. None of the other choices (Shortcuts, Folders, Wallpapers) caused this error, only Widgets.
    The way I got rid of this annoying message was to go to Menu/Settings/Applications/Manage Applications/Map/Uninstall Updates
    I had updated my Google maps a week or so before so I did not associated that as the cause of my error dialog box.
    Now I can add widgets again but am back to the basic Google Map that came with phone. Seems Google map update causes the problem on my Samsung.
    ibanut, fear2falter, eltsirg and 2 others like this.
  17. eltsirg

    eltsirg New Member

    Same symptom, same fix.
    Using Telstra T3020.
  18. drtariko

    drtariko New Member

    Thank you very much, you saved me a lot of time, I always wipe data and make factory reset.I could not know why it gave me that annoying message with widget install
  19. fear2falter

    fear2falter New Member

    Unistalling the updates fixed the problem up, for my little Samsung Gem. Guess we have to wait and hope google map's comes out with a patch to stop this problem.
  20. flyonblueskyy

    flyonblueskyy New Member

    Thanks. it worked :)
  21. ibanut

    ibanut New Member

    opps, it started again now when i use my usb button, ugh!
  22. subhasunil

    subhasunil New Member

    my phone has no ring tone witha message PROCESS COM.ANDROID.SETTINGS

Share This Page