The Droid:Bionic can do CMDA/4LTE and GSM/HSPA+ [IMAGE INTENSIVE]Tips


  1. Alex Wekell

    Alex Wekell Active Member

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Advertisement
    BRAINZ2013 and chmodx like this.
  2. Groid

    Groid Well-Known Member

    How does one go about getting a Go or ATT sim card?
  3. Lars

    Lars Well-Known Member

  4. oppie

    oppie Member


    Got mine on ebay for 2$
  5. oppie

    oppie Member

    I think I might try Straight Talk. Unlimited for 45$ is very tempting. Would save me about 100$ a month if it works!!
  6. jaym40998

    jaym40998 New Member

    Is it really as simple as the pictures indicate? Or was there any type of rooting, or unlocking, etc?
  7. Lars

    Lars Well-Known Member

    Root not required. Sim unlock not required.
  8. jaym40998

    jaym40998 New Member

    Lars, if Root nor unlock was used then how did you do it? I just tried it and it wouldnt recognize the ATT GSM card. Is there something I am missing with your instruction images above?
  9. romeodakins

    romeodakins Well-Known Member

    So on stock you can just pop in tmobile card? Also whats tmobile edge.
  10. Lars

    Lars Well-Known Member

    You have to edit the Non volatile memory with RadioComm to tell it to listen to all the GSM bands. It is detailed in the threads I linked. "Unlock" is a vague term that usually applies to a SIM lock which this phone doesn't have.

    T-Mobile USA generally doesn't work though a few people have gotten lucky. I think it is because of their AWS layout for 3G/4G which is not standard. Maybe the Bionic can't read those T-Mob sims properly.
  11. jaym40998

    jaym40998 New Member

    Lars, Sorry but I am not seeing the links that you are referring too. FOrgive me as I am new to blogging and forums and such.
  12. Lars

    Lars Well-Known Member

    post number 3 of this thread links to the xda thread

    The steps are as follows:

    Connect the Bionic using PC ONLY MODE
    23. Google and DL radiocomm (latest version) I believe I used 11.2.1 but can verify later
    24. Let radiocomm install and also install needed drivers
    25. Follow these instructions to enable the GSM radio:

    In Radiocomm go to MA->CDMA1X->QSC60x5
    After it comes up, switch to FTM Common1 tab and wait for the phone to enumerate purple.
    On the upper right side in the NVAccess, scroll to NV item 1877 NV_RF_BC_CONFIG_I
    Read the value from the device
    Replace the first 8 bytes (16 digits) with: 8703E80400000200
    Write the data to the device and powercycle.
    This will enable GSM/UMTS bands.
  13. bionicdroiding

    bionicdroiding New Member

    Hi,

    This thread has been realy insiteful, thank you very much!

    I recently got a droid bionic and I did the steps of changing the nvm with RadioComm and changing the setting to WCDMA (there were two options WCDMA only and WCDMA preferred). I tried both, and it always comes up to tell me that the sim is not recognized. I tried editing the APN information but I'm not sure if I have it all right (I am in Cairo i tried mobinil sim card, vodafone sim card and etisalat).

    When I go into the *#*#info#*#* menu--under info and "GSM" says "Out of service".

    I attempted to go into my settings and go to "Mobile Network" then to "network mode" i get this error "The process com.android.phone has stopped unexpectedly. Please Try again." Then it exists and goes back to settings.

    Any ideas as to what the problem is? Thanks :)
  14. Lars

    Lars Well-Known Member

    It will always say "SIM card from unknown source" that is normal even on working ones. Just click ok.

    Try setting it to GSM/CDMA instead of WCDMA from the ##PROGRAM menu

    Make sure you let it sit for some minutes. It doesn't immediately find service.
    After you have successful voice service, then worry about data and APN issues.

    I assume the cards you tried work with other unlocked phones. I believe the Bionic is triband GSM not Quad band so 850mhz (I think) doesn't work.

    I also assume you are NOT on ICS!
  15. setasojiro

    setasojiro New Member

    Hey Lars i just got the droid bionic to work for a gsm network in Mexico but cant access mobile networks! each time i try to it says "com.andriod.phone has stopped working" the a Force Close window and soon after it disconnects from the network for a while then it reconnects...

    so do you have some advise for this problem?
  16. Lars

    Lars Well-Known Member

    You need to add the apn for your new sim card after inserting it. Dial ##program from the stock dialer. pwd 000000

    To change gsm mode dial *#*#info#*#* and select wcdma only or gsm/cdma auto prl depending on your gsm network.

    Not sure what you really mean by accessing networks.
    setasojiro likes this.
  17. nickstr

    nickstr New Member

    can it do data and surf the internet
  18. Droid DOES

    Droid DOES New Member

    I just got a Bionic from a friend a few days ago, with the intention of activating it on Straight Talk. I have my SIM which is listed as "Package - Regular Bring Your own ATT" on the sales receipt. I also have the $45 prepaid card. I live in the US and only plan to use it here. The phone is completely stock. I tried going into Wireless & Networks > Mobile Networks add the APN info but I don't have an option to add a name. Could someone help me? Thanks in advance!
  19. Thom

    Thom Premium Guide Member Guide

  20. OutOfPhase

    OutOfPhase Premium Member Guide

    A quote from the beginning of the thread. Try the first link.

    Yep. Walmart Straight talk would be the easiest. On T Mobile you will only get Edge. this requires a Seam NVM Edit and *#*#info#*#* to WCDMA to work. Instant travel phone!

    http://androidforums.com/motorola-droid-bionic/543927-world-bionic.html

    http://forum.xda-developers.com/showthread.php?t=1297714
  21. Lars

    Lars Well-Known Member

    Read the post TWO up from yours! :confused:
  22. Droid DOES

    Droid DOES New Member

    Did that. I have voice on my Bionic but no data yet. The status_bar says "AT&T" when I pull it down. I've added the APN that I got with my SIM and saved in the ##PROGRAM menu. I've changed the Network Mode to GSM auto (PRL), WCDMA only, GSM only, GSM/CDMA auto (PRL), and WCDMA preferred and none of them change the data part. After rebooting, it defaults back to WCDMA preferred. Not new to Android, just to this side of it. What do you think I'm missing?

    Edit - I've done the steps in Radiocomm and that's when my phone started saying AT&T

    Edit 2 - Ignored the force close in Wireless & Networks and added the APN there. Set the Network Mode to WCDMA only and then waited a couple of minutes. Toggled Airplane Mode and I now have 3G!! Sorry for the n00b questions!!
  23. Lars

    Lars Well-Known Member

    Cool. It does take a bit the first time to fully auth on a new carrier. When I came back from Indonesia, It took the phone half an hour for the Verizon sim to fully function again. At first nothing, then text only, then text and voice, then 3G data and finally 4G too.

    Lots of waiting (patience) is needed while the phone figures out which end is up.
    thebodi2007 likes this.
  24. Droid DOES

    Droid DOES New Member

    Got a notification about an update tonight. Will it remove everything? I'm rooted with Bionic Backstrap and CWM recovery but am on the stock ROM, do you think the update would be blocked?
  25. Thom

    Thom Premium Guide Member Guide

    Please post your question requiring root in ... All Things Root.

    ... Thom
Loading...

Share This Page