The horrible trap of the motorola charm - Help me out of a bind?


Last Updated:

  1. Zenofsong

    Zenofsong Well-Known Member

    Firstly, let me apologize if I am posting this in the wrong forum but I have got little response in other places due to the seeming lack of popularity of this phone.

    I am a t-mobile motorola charm user.

    Yesterday I installed a recovery for the Charm by polovinamozga (xda-developers - View Single Post - Motorola Charm!)

    And after booting recovery succesfully, attempted to install his Custom motoblur-free rom (xda-developers - View Single Post - Motorola Charm!) Which fails with the error

    "E:Failure at line 4: copy_dir Package:system System: Installation aborted."

    ,which I realize might be due to my ignorance of the first three steps of this process: "adb usb", "pkill adb", "adb remount" - (Which I tried to type into terminal, phone connected via usb, only to receive a message telling me that this command doesnt exist)


    After 24 hours of frantic googling I am feeling tired, aggravated and starving for help from anyone who knows anything about the topics covered.

    At this point I am most interested in getting back to stock, where I can actually use my phone instead of being stuck in clockworkmod.

    Thank you for your time and patience in reading my request. Prompt responses will be rewarded with emoticons and adulation.

    Advertisement
  2. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    You got error messages for the first 3 steps, so you decided to proceed to step 4? Is it any surprise it didn't work? :)

    Before you try this, you need to get adb working, since apparently adb is required for the procedure you are following.

    Sometimes ADB is bundled with the package you're trying to install. If not, you can get it by downloading the Android SDK (google it). It will be in a folder called "platform-tools" or something like that.

    You also need to have the drivers for the phone installed on the computer. I don't know about the Moto Charm drivers. They should have came with the phone... on the SD card maybe? But you'll need the drivers for adb to work.

    Google is your friend here. Unfortunately, you don't have a popular phone, which means the rooting community will be small. But see if you can find out how others got adb working.

    Once adb is working, steps 1-3 should succeed, and then you can move to step 4 :)
  3. shawn1224

    shawn1224 Ex CEO-DNPSEA foundation VIP Member

  4. dan330

    dan330 Well-Known Member

    how did you get root access... without adb and drivers?

    if you do have root..
    before you tried flashing a new custom ROM.
    DID YOU DO A NANDROID BACKUP?
  5. Zenofsong

    Zenofsong Well-Known Member

    Thank you for your help.

    After installing new drivers the computer still fails to recognize the usb in the phone. I've also noticed that once the motorola logo comes on for few seconds the usb light (where the cable connects to the phone) that is usually on goes off.

Share This Page