The "Linux questions (and other stuff)" thread


  1. Davdi

    Davdi Well-Known Member Contributor

    A B
    1 COL3 COL4
    2 100 100 B2=A2
    3 25 125 B3=B2+A3
    4 250 225 B4=B3+A4
    5 100 325 B5=B4+A5

    NOTE: If you copy B3 and pase it to B4, B5 .... Excel will keep the row/column numbers correct so the whole column works.
  2. 9to5cynic

    9to5cynic Well-Known Member

    Here's a little tip that might save some of you some time... (not moody, no doubt she's a master at this after all her *nix experience :p )

    So I was working with a config file, trying out some changes... so I had to take a config and change on part over and over....

    cp config.conf{,.conf2}
    ls
    config.conf
    config.conf2

    sed -i 's/windows/linux/g' config.conf2

    It's nice to save yourself time by using awesome utilities instead of manually editing files. :)
  3. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Has anyone been experiencing any lockups on Ubuntu 13.04? Can barely run some commands in terminal to get the OS set up the way I want it to before it goes all Iceman on me. :(

    lol
  4. 9to5cynic

    9to5cynic Well-Known Member

    Hmm.. I haven't run 13.04 yet.. but I think I read they switched to a different... something - WM, DM, something. Mir, I think. Could be the cause?

    Maybe try boot to an alternate DM and see if that helps.
  5. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Truthfully, I'm no linux guru. I know very very basic stuff about the OS. However, some google searches have led me to various possibilities for what is going on. Some suggest it could be the kernel, others say it's the GPU drivers, and another thread says it could be lightdm.

    There's no pattern to how long the system stays active. It could be immediate or it could be 10 minutes. My frustration has reached the peak, so I've quit searching for answers lol, which is what ultimately lead me to this lovely thread.
  6. Dngrsone

    Dngrsone Well-Known Member

    I'd heard ugly things about 13.04, so I stuck with 12.04.

    Now considering a move to Mint.
  7. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Are the differences that vast between 12.04 -> 13.04?
  8. Joelgp83

    Joelgp83 Well-Known Member

    Heh, I moved on to the 13.10 pre-release myself. Turns out the GRUB setup installed with 13.04 kept trying to chainload to the Win8 partition directly when I selected Win8 (thus failing to find any Win8 bootloader code), instead of chainloading to the Win8 entry of my EFI partition. 13.10 picked everything up properly.

    Also, I still can't get HDMI audio working (got an AMD E1-1200 APU, so its an ATi 7310 gpu), either on the open source Gallium driver or the proprietary AMD sets. I've heard it's a kernel issue, but.....not even the current 3.10 mainline has the audio fixed. :(
  9. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    *Arghhhh* It seems that neither Ubuntu or Mint want to cooperate with my PC. No clue what the issue is, but both freeze right after logging in.
  10. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Want to be a tad bit more specific? :) What kind of PC, which version of Ubuntu or Mint, what exactly happens, what else have you tried, etc.
    NYCHitman1 likes this.
  11. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    I actually figured out what the problem was. It finally spat out an error code, so at least I had something to troubleshoot. Turns out that it was the GPU driver. All is gravy now.

    To answer your question though, there literally isn't anything else to describe. That's exactly what happened. I would log in and the system would lock up immediately. Keyboard and mouse would become unresponsive, then my monitor would turn off because no signal was being found. As for versions, it was Ub 13.04 x64 and Mint 15 x64 though.

    EDIT
    PC is custom built:
    • CPU: Intel Core i7-3770K
    • RAM: Corsair Vengeance 16GB (4 GB x 4) @ 1600 MHz
    • GPU: EVGA Nvidia GTX 580 SC
    • SSD: Samsung 840 Pro 256GB
    • HDD: Seagate Barracuda 1TB
    palmtree5 likes this.
  12. 9to5cynic

    9to5cynic Well-Known Member

    Well, glad you got it sorted out... And I'm sure it wasn't your intention, but I'm pretty jealous of your computer. :)
  13. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Hehe. I just want one of the newer GTX 6-series cards, and I'll be set for a long while.
  14. fixitevilson

    fixitevilson Active Member

    And when it does, its 97% more likely to be unrecoverable.
  15. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    You're OBVIOUSLY not a Linux person, right? This is seriously one of the funniest--and most outrageously incorrect--things I've read in a long time. :laugh:
  16. Prinny

    Prinny Resident Linux Nutcase Guide

    My linux box had a 'virus' once...the hard drive wasn't feeling well ;) a quick swap and we were back in business!

    But seriously. I can't say linux viruses do not exist...but it's so rare and hard to come across one. To my knowledge, at least. Moody, care to chime on this subject?
  17. 9to5cynic

    9to5cynic Well-Known Member

    Yeah, an actual 'virus' is extremely rare. I've never seen one. Only heard of a few (and they are quite old - circa 1997).

    Now, rootkits are a different story. Those exist. But they are generally run by a compromised root account - so it's not the same.

    But back to linux virus (and in turn anti-virus)... So there are actually tons of linux anti-virus software out there. Most of the free windows ones offer a linux variant... and in fact, there is the awesome ClamAV for linux too. But fun fact, these are designed to check for windows malware. Yep. Turns out, tons of malware analysis is done collected and analyzed on linux machines.

    But there is a cool new trend ... cross platform 'malware'. A few years ago there was an embedded macro in OpenOffice documents that would execute a different script based on the OS you were using. Cool stuff. :)

    TL;DR
    Linux virus? Yes, but no.
  18. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Yep, I've had quite a few of THOSE 'viruses' myself. :D

    How's this? I started using *nix in 1985. To date, I have never personally experienced a virus nor have I ever known anyone who has. As I always say, a properly administered *nix system is very, very hard to hack, or infect with a virus, or any of the other things window$ users see as normal parts of their computing experience. :rofl:
    Prinny likes this.
  19. Prinny

    Prinny Resident Linux Nutcase Guide

    I think the only real way a user (in my eyes) can get a 'virus' on Linux, is to not know what they're doing. Install a piece of software that they obtain in a questionable way, network not being secure...stuff like that, I suppose.

    Although Wikipedia says there are nearly 1000 pieces of Malware for Linux. And we all know Wikipedia has never failed us ;)
    palmtree5 likes this.
  20. Davdi

    Davdi Well-Known Member Contributor

    There have been a (very) few 'proof of concept' *nix viruses in labs but AFAIK none have made it into the wild. And anyway they depend on privilege escalation to do anything, which often means social engineering to get the user to accept a request/enter root password. The *nix family of O/Ses are designed to make it hard to compromise them.
  21. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    And any user stupid enough to do that shouldn't have root's password in the first place! :rolleyes:

    Exactly, and even if a [normal, non-root privileged] user manages to allow something in, it can't bring down the whole system...unlike window$. :laugh:
  22. argedion

    argedion The TechnoFrog Moderator

    Been running OpenSuse 12.3 KDE and loving it. Its been my main goto here the past month or so. This evening I found something else I like about it I can't say works in other Linux Systems but it actually give me a MTP so I can view files on my Droid Devices. I can access both Internal and External SDCARDS with no problem. What a wonderful find for me. :D (Note this does not appear to work with the Latest Mageia 3 running KDE) I tried it with fedora 17 but not a later version.
  23. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I'm a little confused. :confused: I've been viewing files from my [Linux, of course] computers on all of my Android devices for as long as I've had Android devices. By MTP you're referring to micro$oft's media transfer protocol, yes? But what does that have to do with anything? Like I said, I'm a bit confused by your post. (Lack of sleep could be part of the problem.) How is what you're describing with openSUSE different from my Kubuntu, Fedora, Ubuntu, and Bodhi experience accessing files on my phones?
  24. argedion

    argedion The TechnoFrog Moderator

    When I plug in my android into any of the other systems I have tried I don't get to view my files like i am able to do with OpenSuse now. The others would only show the camera folder and thats it. or at least for me. I guess OpenSuse has MTP built in where as others don't seem to. Mostly I use Airdroid anyway don't like the cables holding me back :) but plugging in my phone to the computer this eve just to charge it a bit and bam found out OpenSuse does this for me. To Me its a great find Ever since ICS I havent' been able to do this. Not that I will use it that much because Airdroid rocks but still nice to know it exist somewhere. Now if your still confused take two of these and call me in the morning :D
    mysticspiral likes this.
  25. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Honey, I've been doing this all along on all of my computers and Android devices. When I access my phones' file systems from any of my computers, I have to navigate to their DCIM directory--it doesn't go there by default and limit me to only that location.

    Funny--I LIKE Airdroid, but I almost never use it...because I don't need to!

    :laugh:
Loading...

Share This Page