The "Linux questions (and other stuff)" thread


Last Updated: 2015-05-17 22:10:01
  1. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    By "FX" are you referring to Firefox? Or something else? :confused:

    If it's Firefox, is the compressed file named firefox-23.0.tar.bz2 (or something similar, depending on version)?

    If so, I just downloaded it and extracted its contents. There's nothing to install. Simply extract its contents where you want Firefox installed--on my computers, that would be /usr/local/firefox, and that's it. Then you can just run the executable file named firefox.

    I didn't actually check, but it's probably the same with Thunderbird.

    For readers in general who may not know this, I'll be a little more specific. You extract the compressed file wherever you want, and if that's not the location you ultimately want the files installed, you can move the entire subdirectory it created to where you want. For example, I download everything into /data/downloads; when I uncompressed the file it created a subdirectory named firefox there, i.e., /data/downloads/firefox. To install it in /usr/local, just move the firefox subdirectory over there, i.e., /usr/local/firefox.

    Fire up Synaptic and 'search' for desktop environment and/or specific names, such as kde, xfce, lxde, etc. Install any or all of them. Be sure to grab additional goodies for whichever you're installing, such as kde-icons-crystal or xfce4-artwork (but you can always come back for more later). Apply your choices, then log out.

    When you're on the login screen, you'll now have choices besides Unity (yay! I don't like Unity at all!) in a drop-down menu...I can't think of how to explain where it is, but you'll find it. :) FIRST make your selection, then log in.

    Try out the different DEs you installed and see which, if any, you like. (I'm KDE all the way, but occasionally log in with others just for the fun it.) You can uninstall anything you don't like.

    Advertisement
    zuben el genub and mikedt like this.
  2. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    There's a table here with the file types and their respective extraction commands
    Dngrsone likes this.
  3. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    zuben said:

    palmtree5 likes this.
  4. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Still a good reference. It does help to read before posting :p
  5. Dngrsone

    Dngrsone Well-Known Member

    I have a "six pack" DVD from Linux magazine which carried the main flavors of *buntu at the time. It was a matter of booting it and picking the distro I wanted to try. This was a couple years ago, don't know if they still do that (or if one could fit several flavors on a DVD anymore).

    It was a convenient way to try out versions without actually installing stuff.
  6. zuben el genub

    zuben el genub Well-Known Member

    Thanks, I'll try that. I like FX ESR. I simply don't like all the crap getting added to browsers to make life easier for the social idiots. (These are the ones that click on ANY popup) I'm tired of editing about:config. ESR only gets security upgrades for its life. 24 should be out in NOV.

    I like a plain jane all grey desktop. No animations, no nothing. I do have some icons I like, but they are in ADW for Android under Ubuntu Icons. Having all those large icons on that bar ---- I prefer text.

    I've also got to get the Iron browser - then I can delete FX18 and Chrome.

    Then get the 300 Epson Perfection working.

    I set it up for auto login. I'm the only one who uses it.
  7. zuben el genub

    zuben el genub Well-Known Member

    Also a big thank you to the person that explained how to get 11.10 to get Grub right.
    I got back into XP. This was back in May or June.
    He said sudo update-grub. I had to find the post but I no longer have 11.10 and that's where the bookmark was.

    I get busy with other projects which usually have a time limit.
  8. MrGlowy

    MrGlowy Well-Known Member

    Hey guys, im REALLY new to ubuntu and linux. Just installed it on my laptop yesterday I just wanted to know if anyone could point me to a guide to set up apkktool or apk multi tool. I'm on 12.04.2 if it matters.Thanks in advance.
  9. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    https://code.google.com/p/android-apktool/

    The instructions are actually on that page
  10. MrGlowy

    MrGlowy Well-Known Member

  11. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    sudo su
  12. MrGlowy

    MrGlowy Well-Known Member

  13. Dngrsone

    Dngrsone Well-Known Member

    Dammit! This thing is proving as difficult as I thought, if not more so.

    I have a Toshiba S55t-A5238 laptop with Windows 8 preinstalled.

    I managed to get Mint 15 on, right now I boot into Windows using Secure Boot or, disabling that, Mint. Grub isn't detecting Win.

    I installed rEFInd, but that isn't working, yet... I suspect Toshiba is pointing to its own folder at /boot/efi/EFI/Toshiba but haven't tried messing with those files yet.

    My biggest problem right now is that Mint is not seeing a wifi module, though I definitely have one in Windows.

    So, now I am going to have to crawl through Windows trying to figure out what wifi hardware I have and try to get it working on the Linux side.


    This is not the first time I have had to trailblaze Linux through new hardware, but I am not nearly as patient as I used to be...
  14. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    What wireless card? Also, it sounds like you are able to boot into Mint but rEFInd isn't working. How are you booting?
  15. Dngrsone

    Dngrsone Well-Known Member

    It's a Realtek RTL8188E. I found a bug-report on it, basically saying it isn't supported by Ubuntu. There is a fix-- Linux kernel 3.10 and up supports it, so I will have to manually upgrade my kernel to the stable 3.10.

    If I disable secure boot then Mint boots up. If it is enabled, then Windows 8 boots.

    I installed rEFUnd, but the laptop UEFI ignores it. If I replace the boot_x86.efi file under /efi/EFI/Boot directory, then secure boot has a conniption (if enabled).

    I am thinking that there is a battle of bootloaders going on here and that Toshiba is rigging the fight. There is a /toshiba folder in there, so I may try putting the rEFInd bootloader in that directory, replacing one or both of the ones in there.
  16. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Out of curiosity, how did you install rEFInd? In my case, it was in my distro's repositories. I don't currently use Mint so I'm not really sure if it's there
  17. Dngrsone

    Dngrsone Well-Known Member

    Mint is a fork of ubuntu which is Debian-based, so I used the Debian installer package.
  18. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Ok, gotcha

    Can you launch an EFI shell at all?

    If you can, give me a rough idea of the output of the following command (run in the EFI shell):

    [HIGH]bcfg boot dump -v[/HIGH]

    As for your wireless card, Realtek seems to have drivers on their website for your card
  19. Dngrsone

    Dngrsone Well-Known Member

    How do I launch an EFI shell?


    I installed kernel 3.10_am64 and got my drivers that way... tried 3.10.6 initially, but ended up breaking things, so I uninstalled and went for 3.10 instead and I am running on wifi now. DHCP (automatic didn't work out too well... setting a manual IP did, and that is fine by me.

    For the record, I went to the repository Index of /~kernel-ppa/mainline, surfed to the folder I wanted, and downloaded to a folder (labeled /kernel 3.10) the following files:

    linux-headers-3.10.0-031000_3.10.0-031000.201306301935_all.deb
    linux-headers-3.10.0-031000-generic_3.10.0-031000.201306301935_amd64.deb
    linux-image-3.10.0-031000-generic_3.10.0-031000.201306301935_amd64.deb

    I then opened a terminal, typed in the following:

    Code (Text):
    1.  
    2. cd Downloads
    3. cd "kernel 3.10"
    4. sudo dpkg -i *.deb
    5. sudo update-grub
    6. sudo reboot
    7.  
    After rebooting, I got a notification telling me wifi was available.
  20. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Put this in the directory you have the EFI system partiton mounted to. Enter your computer setup utility and somewhere there should be an option for "Launch EFI shell from filesystem device" so choose that. That should launch a shell. After that, type the appropriate thing (in my case, it's FS0: ) and press enter. Then do the command I mentioned before
  21. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I'm so out of the loop! All this EFI and rEFInd talk is foreign to me. :)
  22. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    You'll probably learn the next time you buy a new PC...
  23. Joelgp83

    Joelgp83 Well-Known Member

    Err...I think that was me. :D
  24. Joelgp83

    Joelgp83 Well-Known Member

    Ok, calm down. I happen to have experience dealing with both the grub-failing-to-launch-Win8 AND the wireless card not being detected.

    What's happening is grub is detecting the Win8 install, but incorrectly assumes the bootloader code is on the Win8 partition. It is not, Grub needs to chainload to the Win8 entry in the EFI partition (sda2 on my rig).

    The RTL8188E detection fail is indeed a bug with ubuntu, it even occurs in the latest 13.04 updates.

    To solve both issues, you can install the latest Ubuntu 13.10 Pre-Release

    Seriously. The RTL8188E driver support is back, you should now have a 3.11 kernel come stock with it, AND its version of GRUB will correctly find the Win8 bootloader on the EFI partition.

    How to get there from here? Start with installing the 64bit Ubuntu 13.04. Wireless won't be available, so grab an ethernet cable and jack in. Open a terminal and run:

    Code (Text):
    1. sudo update-manager -d
    That will trigger Ubuntu's normal update process, but the -d flag will tell it to probe for pre-release versions to upgrade to. Don't worry if it only finds regular updates, or says it can't find anything. Run those and then run the command again. Eventually, it'll find it and prompt you for the upgrade. Do it. It'll take approximately 30min - 1 hour to install.

    Upon completion, you'll have rebooted into a proper EFI-aware grub and can launch win8. Ubuntu will have proper support for your wireless, and you can probably install gnome-classic or kde or something to replace unity if you so desire. :D
    9to5cynic likes this.
  25. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    He's running Mint...

Share This Page