The "Linux questions (and other stuff)" thread


Last Updated: 2015-05-06 15:09:42
  1. zuben el genub

    zuben el genub Well-Known Member

    You are clear, Ubuntu ain't. I have the files unzipped in downloads. I tried moving both the zipped and unzipped files and I just get told I don't have permission as I'm not the owner. I don't like the idea of SU, but dammit, I do want to install the apps I want. FX is not a questionable app.
    I'm trying to move them to USR/Local. No go. I can't move by dragging, the move command or anything. I might need a root password. "YOU ARE NOT THE OWNER"

    It seems like 12.04 simply doesn't want to hear about FX ESR. It installed on Mint 14. I got ESR going, and uninstalled the regular FX via Software Center. I've had ESR working on 10.10, 11.04, but 12.04LTR won't do it. I got the files from Mozilla itself.

    I've learned about reading only. I've snooped around in Windows computers for a long time.

    So what's the root terminal, then?

    BTW, I did look at the permissions from the FX files, and the owner says ROOT. Everything else greyed out.

    Thanks
  2. Dngrsone

    Dngrsone Well-Known Member

    Hrm... I've seen that kind of problem before, where Ubuntu won't let you do things.

    Wish I could remember exactly what I did to circumvent it.

    You could try sudo chown -R [username] [folder] where the username is you and the folder name is the top folder of the unzipped archive. Then try moving it. Don't forget you will have to change the owner back to root if this method works.

    Oh! I think I cheated-- I booted up the machine into a Live CD (could have been Ubuntu, perhaps even DSL) and then moved the files on the hard disk-- the native Ubuntu root had no say in the matter, then.
  3. EarlyMon

    EarlyMon The PearlyMon Moderator

    How to get a terminal window -

    http://www.psychocats.net/ubuntu/terminal

    For Ubuntu 12.04, I just use control-alt-t for that.

    Then as MoodyBlues said:

    su -

    As for what a root terminal is, sounds like slang for a terminal window with a root login.
  4. jonbanjo

    jonbanjo Well-Known Member

    If you are the admin, try:

    sudo su

    and give your password.
    palmtree5 likes this.
  5. Prinny

    Prinny Resident Linux Nutcase Guide

    Some distros (debian based) you need to do sudo su, enter your password, and be on your merry way.

    Some others i've used (I think it was Arch....Or gentoo...)

    you just enter su, password, and root..

    There IS a root terminal, though. Where you open it, it prompts you for your pw, and you are good to go.
  6. zuben el genub

    zuben el genub Well-Known Member

    I had this problem with 10.04 and 10.10. I'd try to boot into recovery, and it would NOT take my password. Looking back, I think the required password was what Ubuntu itself put in.
    I could install tar.gz files.

    It could have to do with the setup. I have 2 separate HD, a Maxtor and a WD. One runs Linux, the other runs XP. I can still get into the Bios and change the boot order.

    It seems like almost every other dual boot is partitioned. Mine isn't.

    I think I am going to have to get this install to recognize a master password that I can use if I need it. I hope I don't have to.

    I'm going to try this. The libraries should be there as regular FX has them.
    https://support.mozilla.org/en-US/kb/install-firefox-linux

    This is what I was trying to do, and kept getting the DO NOT OWN FILE
    Installing and Maintaining Firefox ESR in Ubuntu / Linux *-*TuxGarage
  7. MrGlowy

    MrGlowy Well-Known Member

    Try sudo nautilus, that's how I get root for the file manager to move things to the usr folder
  8. Dngrsone

    Dngrsone Well-Known Member

    Should that not be gksudo?
  9. zuben el genub

    zuben el genub Well-Known Member

    apt - is there a deb package to install firefox ESR? - Ask Ubuntu

    Played with this. There is no folder called OPT in USR/LOCAL, and I can't make one. Where else can I stick the file?

    I changed the version number, and got as far as put it in OPT via terminal. At least Windows asks if you want to create a directory. So I either need instructions on how to get the OPT directory in USR or find another place to put FX.

    Thanks
  10. Dngrsone

    Dngrsone Well-Known Member

    So sudo mkdir /user/local/opt doesn't work for you?
  11. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    zuben, I'm sorry but you're getting those errors because you're not doing the one thing that would eliminate them. Please go back and review--and then *DO*--the stuff I wrote about using su -.

    In 28 years of using *nix, I have yet to see that fail with the errors you're receiving, Ubuntu or no Ubuntu. (FWIW, all of my current computers are *buntu-based and, trust me, su works.)
  12. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I've been using *buntu since its first release and have yet to come up across ANYTHING it wouldn't let me do. Linux commands are Linux commands. Ubuntu doesn't cripple its versions of Linux commands--they're compliant with the current iteration of Linux commands.

    If you're coming up against something where "Ubuntu won't let you do things," it's not Ubuntu... :eek:

    NONE of this should be necessary, unless you have some quirky copy of *buntu that's different from every one I've ever used. su - at a prompt solves everything--and has in the three decades I've used *nix.
  13. MrGlowy

    MrGlowy Well-Known Member

    Well that's what I type into the terminal.
  14. zuben el genub

    zuben el genub Well-Known Member

    I can get to root, I can use SU. I have no damn clue of what the paths are. I can't find the download folder in Terminal. Until I can figure out the paths, I don't want to do anything. I need to be sure of where I'm going and what I'm doing. I can never find an exact example to figure out.
    I read that Terminal's default is your home directory. It sure doesn't list the folders documents, music, videos, downloads, etc.

    I managed a download of FX 10.0.2 ESR. It immediately updated to 18 something.
    The about Firefox did not tell me I was on the ESR update channel. The 10.0.2 file was a tar.bz2. It extracted and ran from downloads just fine. I deleted it as I want the ESR FX not the regular one.

    ESR says in about "you are on the ESR update channel" Regular FX just gives you the version number.

    I also deleted all social media on Ubuntu first thing. I want to get rid of Amazon links, too. I don't know why this should make a difference if it does.

    So it seems older FX TAR.BZ2 files work, the newer downloads want something else. If that 10.0.02 had said ESR, I would have kept it, updated by the ESR channel, made a shortcut and deleted FX 18 via Software.

    I had to get Skype through terminal, too. That just went where it was supposed to go. It didn't say which folder or anything. I read what's installing.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    Terminal window as yourself.

    cd Down(tab key to auto-complete) (enter)

    To show full path:

    pwd

    Copy/paste into your terminal with root as required.
  16. zuben el genub

    zuben el genub Well-Known Member


    I'm using the plain Gnome desktop. I opened that root terminal and it does start with ROOT then your password. I think it's a shortcut. It was in the other versions of Ubuntu, but I never investigated it.
  17. zuben el genub

    zuben el genub Well-Known Member

    XXXXXX@xxxx $ then you start a command. Got that
    CD what's down, a word or the down key? Then hit tab key to autocomplete?

    PWD? how and where do you enter that? Sounds like a shortcut abbr. for password.


    Sorry to sound so dumb, but I'm one of the people who can read code and see basically what it's doing, but don't understand how to work and write it.

    I used to read through the books for programming the old TI. I was looking for educational programs for the brat. If I found one that worked the way I wanted, I'd type it in.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    Commands are case sensitive.

    Virtually all native commands are lowercase.

    Many environment variables are uppercase.

    Most every *nix tool is a building block and mnemonically named.

    pwd is a command that you enter at the command prompt of a terminal window.

    It stands for - print working directory - iow, display to the standard output the directory that was current when the command was issued.

    You may open multiple terminal windows.

    If it's easy for you to get the "root terminal" then in one of those, you can get to your own environment, which means going to your own home directory with your identity in that window by saying, in the terminal window -

    login

    And then provide your credentials.

    Terminal windows are independent. You can have any user in any state in any one, and not affect others already open.

    Please take care with the caps key, it's harder for me (and probably others) to help. I thought you've been dealing with something else because of those.
  19. EarlyMon

    EarlyMon The PearlyMon Moderator

    If you want to check out an advised command, you can often do that with the online manual pages. For example -

    man pwd

    Will describe that one.

    You can also search the man pages if they're indexed, and see the list of possible commands of interest, using the k flag. For example -

    man -k directory

    It's been forever since I've indexed man pages that I've forgotten how.

    If man -k doesn't work for you, and no one else knows, try:

    man man

    And see if it's mentioned there.
  20. jonbanjo

    jonbanjo Well-Known Member

    OpenSuse offers an option "Use this password for system administrator" when you create the first user in the installation process. I'd guess using this option (which actually is the default but I uncheck it) would give a set up similar to Ubuntu, etc.

    Unchecked, the next step is to provide a password for root.
  21. saptech

    saptech Well-Known Member

    Apps install into /usr/bin, /usr/local/bin, or /opt by default (/bin is only for binaries needed for startup, and any sbin directory is for root-only applications).

    To see where your particular one is installed, run:
    which <command>

    which will return the directory where the binary is located.
  22. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    No one here thinks you sound dumb. Look, we all have to start somewhere. :)

    I think this whole thing has taken on a life of its own--and gotten much more convoluted and complicated than it should be! :eek:

    We can rewind, so to speak, and start all over again if you'd like. How about this? Post a link to the file(s) you're wanting to install. They're Firefox, right? Give us the link. Then we'll move forward, okay?
    EarlyMon likes this.
  23. 9to5cynic

    9to5cynic Well-Known Member

    Not to speak for Early, but I'm pretty sure he meant this:
    $ cd Down{Tab}
    Which will auto complete to:
    $ cd Downloads
    Pressing enter will change your directory (cd) to Downloads. pwd should now show /home/Zub/Downloads.

    So, say you extracted this mysterious file to ~/Downloads (Oh, ~ is a shortcut for the current home directory. Handy!)

    So a listing (ls) would reveal something like this:
    file.tar.bz2
    file

    sudo su
    (password)
    Prompt changes!!
    #
    #pwd
    # /home/Zub/Downloads
    # cp -r file/ /opt/file
    # ls /opt
    > file/

    So, I think that's kinda clear what it does, if not, I'll try to explain it. That has you list the directory, revealing that the file you want to copy exists in the location you are currently at. Next, we change to the root user. This account is greater than anything and everything. From here, we just double check that we are in the right directory (I want to say sometimes it'll put you in the root users home directory, but I'm not sure about that right now...)

    And from there we simply copy the file to the /opt directory and then do a listing to make sure it's there.

    :)
    EarlyMon likes this.
  24. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    If you really want those files set up, here's what I would do:

  25. zuben el genub

    zuben el genub Well-Known Member

    I've typed in cd Downloads. Says no such folder. I'll try it the way you listed it.

    Whatever is causing that is probably the whole problem.

    I simply must have something on my system that makes Ubuntu run weird.

    I either get no such folder, or you don't have permission.

    I don't have the opt folder anywhere and can't create it. I've opened and looked through every folder listed and don't see it. I got the path Sys>users>local from a few answers. OPT ain't in that folder.
    Or how to create the damn folder? Full path please.

    @palmtree - I get as far as using the opt folder, terminal says it doesn't exist (it doesn't) goodbye and stops.

    It's funny - the TAR.BZ2 for the older FX ESR which updated wrong worked.
    I extracted to the downloads, clicked on the FX icon and it ran, albeit the wrong version.

    I got the files for Skype and the Epson Photo V300 to work via terminal. FX ESR worked on Mint and 10.10 just the way you described.

    BTW, what's the number sign mean? Enter? I've used>

Share This Page