The "Linux questions (and other stuff)" thread


Last Updated:

  1. EarlyMon

    EarlyMon The PearlyMon Moderator

    It's been a while and not sure when I'll be back at my desk this month. I thought that I had mounted mine.

    Advertisement
  2. OverByter

    OverByter Resident Slide Rule Guru

    Off topic but I still use and love my D40 after all these years, one of the best pieces of kit that I ever purchased. :D :thumbup:
    OB
  3. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I hear you. :) It was the first Nikon I'd ever bought, and I just loved it. It's not getting much use now, but I wouldn't dream of parting with it.

    And--way off topic!--I still have my Canon T70 that I bought back in the '80s. You know, the kind of camera that actually needs FILM. :eek: (And it still works great, too.)
  4. Dngrsone

    Dngrsone Well-Known Member

    I have a silver-body AE-1 somewhere, still, but no telling what kind of shape it it's in. I know my telephoto lens kind of self-destructed.
  5. saptech

    saptech Well-Known Member

    Device Notifier is picking it up and offer the same three choices, Open with FileManager (which is Dolphin), Download photos with Digikam and Download photos with GwenView. Only Digikam will open with the photos, the others open blank.

    On a side note, when using Gnome3 or KDE4, Nautilus will show the camera and I'm able to view the photos. Shotwell also works.

    I'll look into editing the actions.
  6. saptech

    saptech Well-Known Member

    It never have worked since I got the camera. I'll look into associating it.
    No card reader.

    Nautilus, Shotwell & Digikam seems to be the only apps to work. But it works normal under Gnome 3.

    Thnx.
  7. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Sorry, saptech, I didn't realize this before. I thought Dolphin and Gwenview weren't even appearing as choices. This makes it more perplexing...

    ...as does this. :hmmmm2:
  8. saptech

    saptech Well-Known Member

    It may be a distro bug, but it is odd since Mageia is KDE centric, and Gnome is handling it better. I may also have to file a bug report with KDE. At least I'm able to get the pictures!

    Thnx.
  9. jonbanjo

    jonbanjo Well-Known Member

    My first SLR was a used Pentax ME Super. I would have kept it but I'm afraid it died. First DSLR was a Pentax K-200D. I gave that to my mother when I got the K-50 this year. She's never had a (D)SLR before but she's enjoying it and apart from the relative bulk, I think finding it easier to use than the Fuji FinePix she had before (I think the delay between pressing the button and the shutter operating can be off putting on that one).
  10. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    I'm currently trying to configure wireless printing on my printer through Arch. Problem is, it's not wanting to do this. It's an HP Deskjet 3050 (J610) and has wireless capabilities which clearly require a computer to configure.

    Did I mention the user manual is practically useless as this is obviously an "unsupported setup" (the manual goes for Windows/Mac).

    EDIT: never mind, found the right tool
  11. Dngrsone

    Dngrsone Well-Known Member

    It does not have an http interface for setup?
  12. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    This printer requires it to be connected via usb for wireless configuration

    See my edit, I solved the problem. There was a config wizard I was missing to switch the printer over before using hp-setup

    Well, another problem found: it doesn't work after turning the printer off and then back on again :banghead:

    EDIT: I decided to print the network config info using the printer's control panel and now my computer is seeing the device and I can even access the printer's embedded web server (i.e. its own config page instead of CUPS)
    MoodyBlues likes this.
  13. jonbanjo

    jonbanjo Well-Known Member

    Sometimes you need to find a device's IP address on the network. A method I sometimes use to help is to do a port scan using nmap, eg:

    nmap 192.168.0/24 -p 80

    will list every IP address on my network with port 80 (http) open.
  14. Dngrsone

    Dngrsone Well-Known Member

    I fixed the address of mine, so I always know.
  15. 9to5cynic

    9to5cynic Well-Known Member

    If you just want to find a device, you could just use arping ... it'll 'ping' on layer 2 - so it'll be faster. But if you want to use nmap, a -sn is a ping scan of a network. So nmap -sn 10.0.25.0/24 would work.
    <3 nmap :)
    Moody, maybe I'm reading all this wrong, and I haven't been paying 100% attention to this issue... but I guess I'm not sure what the problem is.

    I think the ~/Dropbox folder is always available locally, and it'll only sync to and from the DB server...?? Again, I could have missed the problem. There's a lot going on in this thread >.> :p :rofl:
  16. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Looks like you missed a little! :)

    Should be:

    nmap 192.168.X.0/24 -p 80

    where X is 0, 1, 2, etc., whatever your network is (mine's 1):

    nmap 192.168.1.0/24 -p 80

    Also, note that you'll get different results with nmap depending on whether you're running it as a regular user or root; the latter yields more info.
    jonbanjo and palmtree5 like this.
  17. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Okay, guys and gals, here's a question--about printing from my Android phone. :eek: I don't want to post this on my phone's board, because, A) it's dead over there, and, B) this has to do with Linux. :)

    This is my Motorola Atrix 2 we're dealing with.

    Settings | Printer settings | Add printers yields four choices:

    Code (Text):
    1.  
    2. [b]Auto Search[/b]
    3. Find printers
    4.  
    5. [b]Advanced Search[/b]
    6. Active directory (work)
    7. Printer shares
    8. Manual
    Selecting Find printers yields a spinning wheel, "Finding printers," and then...nothing: "Cannot find the desired printer. Make sure your device and printer are connected to the same Wi-Fi network and powered on. If you still cannot connect, try a more advanced method."

    Active directory obviously isn't a choice for me.

    Printer shares says: "Browse domain and workgroups for available printers" When I select it, it first brings up some info about sharing printers...on window$. :rolleyes: Pressing 'next' displays my workgroup, cleverly named WORKGROUP. :D After selecting it, I see the other computers on my network. When I select the computer that has the printer attached to it, there's a lot of spinning and then either "No servers available" or "No domains or workgroups found."

    So, trying Manual, it says to enter "IP address or UNC path." Nothing I've tried entering there has worked. The IP address of the computer that has the printer attached is 192.168.1.103. No, doesn't work. I tried "ipp://192.168.1.103:631/printers/Deskjet-F4100-series"--which is this printer's entry in my printer configuration settings on all my computers that access that printer remotely. Nope. That doesn't work either. I've tried variations, such as the computer's name and share name...nothing works. All I get is "Printer not found."

    So, what's the trick?!

    FWIW, I'm using Samba. This is a holdover from before I wiped window$ off my mom's computer and switched her to Linux.
  18. MoodyBlues

    MoodyBlues - Crazy peacock person -

    There most certainly is a lot going on in this thread! :D

    Let me try again--and please, everyone, notice that it's 4:00am (my time) and, well, I'm awake...and have been all night. So, if this is incoherent, well, okay. :laugh:

    The whole thing is that it seems I'm supposed to drag stuff to my ~/Dropbox directory in order for them to sync with my online Dropbox account. BUT, when *I* drag anything there--and I'm talking about when using the DB GUI--it moves it there. So, in other words, if I take my ~/bin directory and drag it to my ~/Dropbox directory, ~/bin is now GONE, and ~/Dropbox/bin now exists. This is most definitely not what I want.

    So then I started experimenting with copying, linking, whatever.

    Copying stuff means having TWO sets on my local drives--and double the disk space used. I don't want that either.

    Linking appears to work, but depending on how I link the behavior is different. If I use the Dropbox right-click menu option of 'make link,' it creates a new entry [wherever I am at the time] called 'Link to [whatever],' e.g., 'Link to bin'; then I have to drag/drop the newly created 'Link to bin' to ~/Dropbox. Again, it MOVES it there. The files definitely do sync with my online account (I verified/tested this by downloading some of the linked, online files on a different computer or phone).

    I can also link via Dolphin's 'link here' choice when dragging/dropping something into ~/Dropbox; in this case, an identically named new item appears in ~/Dropbox, such as 'bin' (as opposed to the DB version 'Link to bin'). Again, the files definitely do sync online. (If I do this the old fashioned way, i.e., at a command line using ln, the results are the same.)

    *************** EDITED
    But linking via DB and linking via OS yield different behavior in the DB directory AND online. If I link via DB's choice, move the link into ~/Dropbox, and then see it appear online, deleting the online and/or ~/Dropbox version does NOT delete the original. Linking via the OS does. In other words, if I use the OS to create a link in ~/Dropbox to some_image_file.jpeg, the original of which is in my ~/images directory, and I delete that file from my online account, the original is GONE. :eek: (After writing this last paragraph I started questioning its accuracy. I'm BLANKING tired. I may revise this part later.)

    EDIT--I cannot reproduce what was happening the other day. I'm too brain dead. I'm not going to delete this [yet] because there REALLY was an issue...I just can't reproduce it right now.
    *************** EDITED

    So it all comes down to: Is DB supposed to work by MOVING the files you want to sync? That doesn't make sense to me. At all. But nothing else about its GUI's choices makes sense either. :confused:
  19. Dngrsone

    Dngrsone Well-Known Member

    That is weird, and I am pretty sure it shouldn't be doing that.

    Unfortunately, I am headed to work this morning and I can't experiment with dropbox right now...
  20. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Update on my dying laptop: I do believe it is now officially toast.

    It's not the hard drive, although the hard drive *IS* the thing that was getting sizzling hot. I took the drive out, stuck it in an external enclosure, and despite all kinds of fsck warnings, missing hard drive warnings, etc., when in the laptop, it's absolutely fine externally.

    So I guess I will bid adieu to my almost 7-year-old HP dv6000. It served me well. I'm not interested [enough] in diagnosing its actual problem(s) and/or fixing them at this point. I'll use its hard drive as an external backup for now on my other [newer] laptop.

    Perhaps that Chromebook I've been thinking about buying is in the near future. Or not. I don't know yet.

    RIP, my trusty dv6000. :bawling:
  21. Dngrsone

    Dngrsone Well-Known Member

    That sounds like a RAM issue, though it could very easily be a chipset problem, which means a bad motherboard.

    Good luck shopping for a new laptop... you're between the back to school sales and the holiday sales.
  22. MoodyBlues

    MoodyBlues - Crazy peacock person -

    At its age, I just don't think it's worth the bother/cost to do anything about it.

    I'm going to see if there are any charities I can donate it to that might be interested in resurrecting it. As long as they put Linux on it, of course, before giving it to a school or whatever. :D

    No, I won't be shopping for a new laptop now. This one [the one that died] was just a spare anyway. Besides, my doctor keeps admonishing me for being on AF at 2, 3, 4 in the morning...but I keep telling him it's only because I CAN'T SLEEP, not the other way around. :rolleyes:
    Dngrsone likes this.
  23. Dngrsone

    Dngrsone Well-Known Member

    Ah, I would have a few things to say to that doctor... ;)

    Man, tapatalk 4 is such a pain... I'm about ready to downgrade.
  24. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Oh, trust me, he's heard some choice words from me, including the F bomb. :eek: But not directed at him. :D He saw me at my absolute worst--post brain surgery, in a physical and emotional state I can't even describe in words. We've been through a lot together!

    I was going to try to reply to this on my phone [using the Android Forums app], but I gave up. I'm just too used to having my fingers whip off whatever BB code I need, or cutting/pasting, etc., and I just couldn't deal with all the hunting and pecking and switching around keyboards. I'm getting very impatient in my old age.
  25. jonbanjo

    jonbanjo Well-Known Member

    Re printing: We have an Epson Photo P50 inkjet and a Xerox 6110N laser. The laser is a network printer but the inkjet is USB. I use an old and discontinued Belkin print server to get the inkjet on the network. Both printers are shared using CUPS. The server is on a PC which performs a number of other tasks (local DNS, IMAP, mythtv master backend, etc) on the network and is always on.

    Android printing via CUPS is performed via an app I wrote based on the open source cups4j Java CUPS client package. The app attempts to parse the printer's ppd file and make all the UI options it contains available to the user so I can (this was a stumbling block when I looked at existing Cups apps) for example print to 4x6 photo paper or (not that I've wanted to except for testing) even to CD on the inkjet.

Share This Page