The "Linux questions (and other stuff)" thread


  1. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    So, I've migrated to Ubuntu and for whatever reason, GParted is refusing to allow me to move partitions around (as in relocate them) even from a live CD. Problem is, my root partition for Ubuntu is literally the LAST partition on the drive. There is nothing after it, not even free space.

    Suggestions? :banghead:

    Oh, here's my current layout:

    Code:
    sda1   8:1    0   512M       0    part    /boot/efi
    sda2   8:2    0   240G       0    part 
    sda4   8:4    0   8G         0    part    [SWAP]
    sda5   8:5    0   400.1G     0    part    /data
    sda6   8:6    0   50G        0    part    /
    
    As you can see, it's a mess
  2. Dngrsone

    Dngrsone Well-Known Member

    Wow... that is pretty ugly.

    Try GNUParted, see if you can do something with that.

    It may be that you need some spare space on the drive to move partitions around; particularly if you don't have a lot of RAM.
  3. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    It's currently moving around, although I had to pull the contents of my home folder out and zap the old root and the new root (I was attempting to use cp -a /path/to/old/* /path/to/new but it didn't work properly). Supposedly gonna be a little over 2 and a half hours till that finishes.

    Then there's the fun and exciting process of reinstalling Ubuntu

    FWIW, I have 8 gigs of RAM
  4. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    I also just realized my script problem from earlier this week may have been fixable by looking at the OP...
  5. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    :D

    I actually thought about that, i.e., simply getting rid of the annoying spaces in file names, but I like what we did better. It was fun, and it was a good collaborative effort--AND, it gave my four remaining functioning brain cells a really good workout. :rofl:
  6. jonbanjo

    jonbanjo Well-Known Member

    I've been setting up a new (OpenSuse) PC to handle my various network tasks. It also needs the XPL hub. I thought I'd try a systemd service file . I've not used one before but I was pleasantly surprised. All I needed was:

    Code:
    [Unit]
    Description=XPL Hub
    After=network.target
    
    [Service]
    Type=forking
    ExecStart=/home/jon/jfhome/xPLLib/examples/xPL_Hub
    [Install]
    WantedBy=multi-user.target
  7. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Yes, systemd service files are very simple
  8. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Is it all worked out now? I have to admit, I was confused last night when I first read your configuration. I wasn't sure what you meant about MOVING the partitions around. Let us know if it's all sorted out and things are running smoothly now, okay?
  9. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Yeah, it's all worked out now. The big issue was the 240 GB of free space was at the beginning of the drive (well, after the EFI System Partition) and the root partition for Ubuntu was the last partition on the drive (and was only 50 GB)
  10. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    But, how did it GET that way? :confused: I mean--and this is my experience I'm basing this on--when I do an install I divide and format the disk per my preferences. So root and all my other partitions are where I put them.
    Dngrsone likes this.
  11. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    It was my one free partition when I went to install Ubuntu earlier this week

    EDIT: I was dual-booting with Arch at the time but I decided to make the jump to Ubuntu
  12. Dngrsone

    Dngrsone Well-Known Member

    Same here. Out of habit, I always put the swap at the very end of the drive, and have separate root and home folders. I think I am rocking 100GB partitions right now on my 2TB drive.
  13. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Same here with swap always going last. Here's my standard partitioning scheme:

    Code:
    /
    /home
    /data
    [swap space]
    
    All of my computers are all Linux, i.e., no dual-booting any...*cough*...other OS. :laugh: But not other Linux distros either, just one hard drive, one OS.

    You're giving me hard drive envy! :D
  14. Dngrsone

    Dngrsone Well-Known Member

    Oh, well I am more or less forced to multiboot-- I need Win for certain programs that don't work well (or at all) on Linux, and every year or so I install a new distro or version to try out.

    That way my main OS is safe and secure from accidents resulting from upgrades or experimental add-ons.

    As for the HDD, I had to pay dearly for that.

    ... for the record, my Data drive sits ahead of my root drive because it is shared between Windows 8 and Mint (NTFS).
  15. Prinny

    Prinny Resident Linux Nutcase Guide

    Hey Moody,

    Question.

    After I return from work today, I'm going to install Linux for a dual boot. The purpose is to just copy files easily since I lack external storage. Can gparted erase the windows partition without any problems with GRUB or anything like that afterwards? I've never tried anything like that before, so I wanted to ask.
  16. nickdalzell

    nickdalzell Well-Known Member

    I have a question:

    I just installed ChrUbuntu (Chromebook Ubuntu, running 12.04 LTS) and from time to time it just freezes up and gets extremely unresponsive. i only have Chrome open during that time. the only way to fix it is to force a logout of the user and log back in. somehow i don't believe 'Linux' and 'Out of Memory' belong in the same sentence. nothing bad appears to run when i do a 'top' in a terminal. does Ubuntu not play well with SSDs?

    Seems i can reproduce the freeze. the magic number is having four or more tabs open in chrome. but why does it happen?
  17. jonbanjo

    jonbanjo Well-Known Member

    Wondering if you got this one sorted.

    One other thing you can try when you are left to guess like that is http:// instead of ipp:// (clients make http POSTs to IPP servers with the mime type application/ipp).
  18. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Sorry for the delay, but I've been out of pocket today for the most part. Hadn't even TOUCHED my laptop until right now! My brother-in-law is visiting, and we've just been busy. I logged in for a little while this afternoon on my phone, and realized I don't normally do that for a reason: I CAN'T SEE!! Even posted a reply. (Now I need to check it for typos. :eek:)

    Anyway...

    It's been a number of years since I did that, as I don't normally have dual-boot machines. In my situation--and ONLY if I remember correctly--I had a window$ partition and a Linux partition, and I wiped the window$ partition using Linux. I'm way too fuzzy right now to say for sure what/how I did this. I probably used gParted, deleted the partition(?), recreated it, formatted it...I'm sorry, I really just cannot recall exactly. I know I was using GRUB, and I know I ended up with an additional partition for Linux, but I do not recall if there were any issues or if there was anything special I had to do when booting up. Can someone else chime in please? :D
    Prinny likes this.
  19. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    No. I gave up! It was purely on a whim that I decided I wanted to be able to print from my phone, so when it didn't work easily I gave up. :laugh:

    I did. I tried http but it didn't work either. :(
  20. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    So, I just attempted to use my laptop's built in SD card reader and it doesn't work. I've been Googling and trying things but to no avail

    Some output follows.

    From lspci -nnk:

    Code:
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5289] (rev 01)
    	Subsystem: ASUSTeK Computer Inc. Device [1043:1457]
    	Kernel driver in use: rtsx_pci
    
    From dmesg:

    Code:
    [  348.037884] mmc0: error -110 whilst initialising SD card
    [  349.336879] mmc0: error -110 whilst initialising SD card
    [  350.639838] mmc0: error -110 whilst initialising SD card
    
  21. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I've never seen this myself, so I let my friend Google step in. :) This page discusses this particular bug, and starting at reply #7 it looks hopeful in terms of fixing the problem. You want to check it out and see if it gets you anywhere--and then, if not, let us know so we can move on with plan B. :D
  22. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    I actually already tried that and it didn't work. FWIW this piece of hardware was working on Arch so possibly upgrading to the mainline kernel (which another reply in that bug report mentioned) could fix it

    EDIT: Gonna roll my own kernel and build it myself

    This should be fun...
  23. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    UPDATE: The particular piece of hardware in question is working on the self-built kernel (3.12.0-rc2). Thus, it's probably a lack of support in the "official" kernel used by Ubuntu

    Out of curiosity, what was plan B?
  24. nickdalzell

    nickdalzell Well-Known Member

    is Linux these days trying to be Windows? i just had to search high and low to disable two annoyances i thought were part of Windows. Ubuntu has this Dr.Watson type utility known as 'apport' that locked my machine solid as a rock because it 'thought' a program crashed (it didn't but since it was acting slow it 'thought' it was and tried closing it). the second is a Windows Update type tool that not only arbritarily pops up at the worst possible moment to try and update things without my permission and once even restarted my machine on its own

    taking lessons from Microsoft, Ubuntu?! listen i tell my computer what i want it to do. i will not tolerate it doing things on its own! the last thing i want is to be in the middle of a movie and BAM! my machine restarts.
  25. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    What version of Ubuntu are you on?

Share This Page