The "Linux questions (and other stuff)" thread


Last Updated:

  1. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I probably can't help you with this; I don't do windows, therefore I've never used wubi or whatever it's called.

    My only thought is perhaps the laptop isn't up to the latest and greatest version of Ubuntu? That's what I ran into when I upgraded my old laptop's Kubuntu version one too many times, and it ran like frozen molasses. :eek:

    Advertisement
    argedion likes this.
  2. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    Makes since. :(
  3. argedion

    argedion The TechnoFrog VIP Member

    I got my pidgin working for google talk now :D
  4. saptech

    saptech Well-Known Member

    Good you have it going. How did you get it working? :smokingsomb:
  5. zuben el genub

    zuben el genub Well-Known Member

    Not for itself,but if you are downloading for offline windows boxes. I have 2 of those.
  6. zuben el genub

    zuben el genub Well-Known Member

    Can you help with dumb questions?
    Like associating a program?
    Linux doesn't use the same extensions.
  7. argedion

    argedion The TechnoFrog VIP Member

    I had to go to the advanced tab and in server put in talk.google.com
    saptech likes this.
  8. argedion

    argedion The TechnoFrog VIP Member

    not sure i can help but put it out there thats what this thread is for
  9. saptech

    saptech Well-Known Member

    Depends on what type of file it is, you can use the file manager. Which distro are you using?
    argedion likes this.
  10. mikedt

    mikedt 你好 Guide

    Sure. :)

    Depending on what file manager you're using, it's similar to Windows. Right click on whatever you want to associate, do properties, and then do open with, and you'll see a list of installed software that can open or view the file. e.g. AVIs might be associated with Mplayer, but you can change it so VLC opens instead.

    Linux uses exactly the same filename extensions for documents and media. However there's no EXEs or DLLs for software. Executables often don't have an extension at all, runtine libraries might be LIB, configuration files could be CONF.

    If you're downloading Linux software from outside of the package/software manager and repositories, e.g. SourceForge, you'll often see extensions like TAR.GZ, TGZ, BZ2, etc, rather than ZIP or RAR.

    There's no central Registry as such, where all applications dump their stuff in an opaque obfuscated manner, and if it gets broken that can often be the end of Windows. Applications generally maintain their own configuration files. in easily fixable clear plain text. If a Linux application is giving trouble, and can't be fixed by changing the configurations. Generally just deleting the associated configuration file will return troublesome software to defaults and fix it. No need to re-install or re-boot either. :) Most Linux updates can be applied without re-booting, unlike ahem....Windows. :rolleyes:
    saptech, 9to5cynic and argedion like this.
  11. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    There are no dumb questions! :)

    Of course, but it depends on where you're talking about. Do you mean in general? Like assigning a default application for opening a specific type of file, or do you mean within a specific application, such as a browser, or what? :confused:

    *nix has never used 'extensions' as in the DOS/windows world. UNIX and its offspring actually determine a file's type based on its contents, NOT on its 'extension.'

    The reason I keep putting 'extension' in quotes is because in *nix there really is no such thing as a file extension. :eek: Back in the DOS 8.3 (file names limited to 8 characters, plus a MANDATORY dot-plus-3-character extension), in UNIX we had no such ridiculous limitations. If I wanted to name something my.file.for.work, so be it. The dots were, and are, nothing but characters, like any other standard character. They didn't, and don't, dictate a file's type. *nix basically evolved over the years to accommodate windows users who thought of files as having extensions to dictate what they were.

    Don't believe me? Do this: Let's say you have a JPEG file that's named your_pretty_sunset.jpg. Rename it simply your_pretty_sunset. Then fire up your preferred file manager (I use Dolphin), and watch it display the file's preview. Do the same on a windows box and what will happen? Nothing. Without the .jpg extension, it won't recognize it as a JPEG file.

    Go to a command prompt where the file is located and type this:

    Code (Text):
    1. file your_pretty_sunset
    The output should look like this:

    Code (Text):
    1. file your_pretty_sunset
    2. your_pretty_sunset: JPEG image data, EXIF standard
    Again, it's actually DETERMINING the file's type, not making assumptions based on its extension...or lack thereof. :)
    argedion, mikedt and saptech like this.
  12. mikedt

    mikedt 你好 Guide

    I have to admit I do like using the CLI.

    Code (Text):
    1.  
    2. michael@michael-Ideapad-S110 ~ $ lunar 2013 1 21
    3. Lunar Version 2.2 (October 28, 2001)
    4.  
    5. Solar : 2013.1.21.0 Monday
    6. Lunar : 2012.12.10.0    ShengXiao: Dragon
    7. GanZhi: Ren2-Chen2.Gui3-Chou3.Ding1-Hai4.Geng1-Zi3
    8.         (GanZhi Order)  9-5.10-2.4-12.7-1
    9.         (JiaZi Cycle)   29.50.24.37
    10.  
    11. BaZi (8-characters) according to 'Four Column Calculation':
    12.         Ren2-Chen2.Gui3-Chou3.Ding1-Hai4.Geng1-Zi3
    13.         (GanZhi Order)  9-5.10-2.4-12.7-1
    14.         (JiaZi Cycle)   29.50.24.37
    15.  
    16. michael@michael-Ideapad-S110 ~ $ lunar --utf8 2013 1 21
    17. Lunar Version 2.2 (October 28, 2001)
    18.  
    19. 阳历: 2013年 1月21日 0时 星期一
    20. 阴历: 2012年12月10日子时 生肖属龙
    21. 干支: 壬辰年 癸丑月 丁亥日 庚子时 
    22. 用四柱神算推算之时辰八字: 壬辰年 癸丑月 丁亥日 庚子时
    23. michael@michael-Ideapad-S110 ~ $
    24.  
    argedion likes this.
  13. nickdalzell

    nickdalzell Well-Known Member Contributor

    i grew to love the CLI in early versions of Linux, starting with my first experience in BasicLinux. it was CLI only unless you installed X. but now i've become so addicted to KDE and the little gadgets that i may blow away Pear Linux on this computer and install 12.10 and KDE the next opportunity i have to get near a faster wifi than i have at home

    i have a problem, though. at least one widget i like and wanted (a Nixie clock widget) wouldn't load at all. it kept giving me a red 'X' icon and something about 'failed to load script' inside the window where the widget would or should be. i installed the widget from software center so i am sure if any dependencies were required it should have installed them with it?
  14. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    I love that you're loving KDE. :D I told you it was amazing!

    It's been a while, but I've seen that happen with widgets in the past, and I honestly can't recall actually SOLVING the problem--instead I just deleted them from my panel. *shrug*
  15. mikedt

    mikedt 你好 Guide

    How fast is your home WiFi and internet? Even if you only have 1megabit, that should be able to download 12.10 Ubuntu or Kubuntu in an hour.

    Now I don't use widgets, well apart from the default clock and calendar, network monitor, volume control, and a couple of launchers. The things are often useless and just get in the way IMO. Can't really comment about the problem, might be a broken dependency or a bug in the widget itself. Have you searched for a solution?
  16. nickdalzell

    nickdalzell Well-Known Member Contributor

    Ubuntu isn't the download i worry about. i only have 128K down and maybe .5K up. it's slow. it was a rather long download on cable at my mom's house. my speed is roughly half that of DSL and 1/3 that of cable. i live in a trailer in the woods, it's a wireless system and i cannot get any faster speed. it's just barely good enough for Netflix, never intended to download large files/games/software with it at the time. Ubuntu is only a 900MB file. the Kubuntu Desktop part was almost 1.2 gigs from the CLI output and took an hour at mom's, which would translate to a day and a half here. it takes four hours to download Ubuntu base

    it installed successfully but refused to run. i tried rebooting, reinstalling, resetting the widget config, etc. it just instantly gives me that error without trying to load. it sadly was the only Nixie clock widget available, and the user comments were in foreign language. i've always thought those were neat but i lack the skills to actually build one of those Nixie clocks. others online in Askubuntu site were saying their widgets which give a similar error start out working. mine did not--it instantly gave the error. the rest work just fine though, including other downloaded widgets.
  17. mikedt

    mikedt 你好 Guide

    Don't you need to have good bandwidth for Netflix? Or does it buffer?

    Netflix movies can be a gigabyte or two can't they?

    Google Translate? :) It's pretty good these days. I use it all the time, as my boss in Dalian doesn't speak any English whatsever, and often my Chinese isn't quite good enough to get what I want to say across to him. We always communicate via IM, e-mail or SMS.

    Maybe someone else has info on that?

    BTW I could probably build a nixie tube clock, given a schematic, parts and tools. I'm sure Chinese military electronics surpluss could precure the necessary tubes and 74xx series TTL logic. :D I used to make quite a few projects. I still dabble with some of the electronics design and simulation applications, like QUCS.
    argedion likes this.
  18. MoodyBlues

    MoodyBlues - Crazy peacock person - Guide

    Me, too! (Of course. :D) One of my all time favorites:

    Code (Text):
    1. $ cal 9 1752
    2.    September 1752    
    3. Su Mo Tu We Th Fr Sa  
    4.        1  2 14 15 16  
    5. 17 18 19 20 21 22 23  
    6. 24 25 26 27 28 29 30
    argedion likes this.
  19. mikedt

    mikedt 你好 Guide

    Here's a little bit of dependency hell, that can occasionally happen when trying to build software.

    Code (Text):
    1.  
    2. ~/Downloads/lunar-applet-2.0 $ ./configure
    3. ...
    4. checking for gconftool-2... /usr/bin/gconftool-2
    5. checking for LIBPANEL_APPLET... no
    6. configure: error: libpanelapplet-2.0 not found.
    7.  
    8. on Debian or Ubuntu, install this please:
    9.     # apt-get install libpanel-applet2-dev
    10.  
    It's wanting libpanelapplet-2.0, which doesn't seem to be in the current Debian or Ubuntu repos. What's in the repos is libpanelapplet-4.0. So it looks like it requires an older version of the library or runtime....and "# apt-get install libpanel-applet2-dev" doesn't work.

    Here's the source code if anyone else wants to give it a try, or has any suggestions.
    lunar-applet-2.0.tar.gz - lunar-applet - lunar-applet-2.0.tar.gz - GNOME Clock applet with added Chinese lunar calendar support - Google Project Hosting

    It's not important, it's only a lunar calendar applet for Gnome. But was something to play with.
  20. saptech

    saptech Well-Known Member

    I love CLI also. I install my programs using it more than GUI. I'll have to check out lunar-applet, mikedt.

    Attached Files:

    mikedt likes this.
  21. argedion

    argedion The TechnoFrog VIP Member

    I yum more than i go to software center. Just my prefered method
  22. zuben el genub

    zuben el genub Well-Known Member

    OK - dumb question #1

    Was asked to associate a program with opening a file. I wanted FX to open it, but FX wasn't in the choice box. What do I use to associate with? In Windows it would be FX.ex- (left the last e off) What's operative in Ubuntu? Still running 11.04, will be changing to Mint, soon.
  23. 9to5cynic

    9to5cynic Well-Known Member

    @zuben was there an option to browse for a program? If so you could type whereis FX in a terminal to find the path and use that with the default application list.
  24. saptech

    saptech Well-Known Member

    What type of file is it? A doc, multimedia, picture, etc? If it's some type of proprietary program that created it, then you're out of luck. Another option would be to run the fx.exe in wine.

    ***Edit***

    Is this the fx.exe you're referring to?

  25. mikedt

    mikedt 你好 Guide

    yeh...hmmmm... I thinking, What the hell is that!?

    "Antisans

Share This Page