The "Linux questions (and other stuff)" thread


Last Updated:

  1. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    sda1 and sda3 are marked as bootable (according to cfdisk anyway) and sda1 is labeled "system reserved"

    Advertisement
  2. Speed Daemon

    Speed Daemon Disabled

    I see. Technically you should only be able to have one partition marked bootable. Assuming that you're using GRUB or something similar as your bootloader, it doesn't matter as long as you don't disturb the partition that contains the needed bootloader files.
    palmtree5 likes this.
  3. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    So, update on my situation, I've repartitioned the drive by I'm having issues formatting the new partitions. It's telling me "no such file or directory"

    EDIT: After doing "ls /dev/sd*" I found out that my new partitions weren't listed. Rebooted and now they are :)
    EDIT2: Noticed that mkswap told me that the partition is misaligned

    All the partitioning is done, I now have a 4GB swap and home is on a separate partition
  4. saptech

    saptech Well-Known Member

    Does anybody use Krusader file manager with KDE? I've just installed it on my non KDE Salix 14 system. I'm using Xfce4 & Openbox on it. I do like the two pane look of it more then other file managers.

    It was a little struggle to get it going, since it needed the kdelibs for a total of 16 files related to KDE and they are very small lib files.

    Just a thought!
  5. MoodyBlues

    MoodyBlues - Crazy peacock person -

    You mean like this?

    [​IMG]

    (That's Dolphin, by the way.)

    I tried Krusader a few years ago after reading about it in Linux Journal, but I prefer Dolphin.
  6. saptech

    saptech Well-Known Member

    Dolphin is okay whenever I use KDE but it pulls in too many KDE files to install it for me.

    Here is Krusader.

    [​IMG]
  7. argedion

    argedion The TechnoFrog Moderator

    thinking of jumping the fence over to BSD
  8. MoodyBlues

    MoodyBlues - Crazy peacock person -

    Why? Clue us in!
  9. argedion

    argedion The TechnoFrog Moderator

    just really been wanting to try it out. I figured I would go with PC-BSD and give it a whirl. Its been like Gentoo to me one of those things I want to do but just never have.
  10. saptech

    saptech Well-Known Member

    I remember running Freebsd some years ago. I had fun with it and learned alot. At the time it wasn't alot of hand holding to get it up & running. This may have been around mid/late '90s and I had a hard time getting my sound card working. I haven't tried it since. I did try PC-BSD and it was a BSD made easy.
    argedion likes this.
  11. Prinny

    Prinny Resident Linux Nutcase

    You know, the only thing that can be annoying is when compiling drivers, it tells you the headers aren't installed. Okay. So sudo apt-get install linux-headers-$(uname -r)

    But no package. :(
  12. Speed Daemon

    Speed Daemon Disabled

    LOL...but apt-get is supposed to be the panacea! You mean the "king" has no clothes? :D

    I've never cared for the snotty / preachy 'tude of the Debian developers and their followers. It's the kind of self-righteous "I'm the only one who's right" crap that divided *BSD and let Linux eat their lunch to begin with! When I go looking for a Linux distribution, I want one that doesn't come with a mandatory political dogma attached. IMO Canonical hasn't helped any in this regard.

    I've been using Linux distros that use RPM packages, and must say that it's been a very long time since I've had to pay the slightest attention to dependencies. It just works. No drama, not politics...only the occasional reminder to "have a lot of fun". I like that. :)
    9to5cynic and Prinny like this.
  13. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I've been using *buntu for eight years and have only rarely had to deal with satisfying dependencies; at this moment, I can't recall the last time. So, for me, it just works! :D
  14. MoodyBlues

    MoodyBlues - Crazy peacock person -

    So what DID happen? :confused: And did you try doing this via Synaptic instead?
  15. Prinny

    Prinny Resident Linux Nutcase

    Fix my bcm4313 drivers for me ;)

    Nah I kid. I just went back to Fedora and I just need to enable a few repos, then install kmod-wl and I'll be set :D
  16. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I don't know what version of *buntu you were using, but the Broadcom 43xx issue was solved a long time ago, at least in Kubuntu. I used to manually do the ndiswrapper thing, but that's been unnecessary for several years now. It just works!

    Way too much work! ;)
  17. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Used to have that issue with my computer but now it's not an issue
  18. nickdalzell

    nickdalzell Well-Known Member Contributor

    i have not had 'dependency hell' since the early days during BasicLinux. keep in mind there were no package managers in those days! :eek:
  19. Prinny

    Prinny Resident Linux Nutcase

    Its not that bad! I click one thing, then yum update then yum install kmod-wl ;)

    It was a debian distro that was giving me heck. Linux 3.2 kernel, based on Debian 6
  20. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    I learned a lesson today. ALWAYS check that you are specifying the correct path when using rm!!!

    Was following a step by step guide and wasn't paying attention.

    This is what I meant to do:
    [HIGH]sudo rm ~/archlive/releng/root-image/etc/{shadow,passwd,group}[/HIGH]

    This is what I actually did:
    [HIGH]sudo rm /etc/{shadow,passwd,group}[/HIGH]

    Luckily I hadn't done the first one yet and had a live USB laying around. Was able to boot into the live USB and copy the files back.

    Back up and running now luckily
  21. Speed Daemon

    Speed Daemon Disabled

    True story: It was my first day on the job as the MIS Director at a private college in Chicago. I was sitting in the closet that served as the school's data center, checking out the box running SCO OpenServer and kept all of the school's student records and other priceless data. The terminal had already been logged in is root (no X on this box), and the plan was to create a user account for myself and go back to my desk. The dialog didn't offer any help about where I should put my user directory, so I dumped out and proceeded to look for where other users' home directories were, starting at the root directory.

    The computer closet was located in the room that is the student lounge / dining room, and lots of curious students were milling about, some asking me questions, others distracting me for *ahem* "other" reasons.

    To this day I still don't know what happened for sure, but when I returned my attention to the computer I was shocked to see "kernel panic, system going down" being repeated on the screen. It looked like I had done `rm -Rf /*' but I hadn't! Within minutes the system was as dead as a doornail.

    I can only guess what happened because the restore (that's another story in itself) blew away all record of what happened during the panic. My best guess is that, because I was using the up arrow to repeat `ls -al' a lot, that I may have inadvertently held down the up arrow a tad too long, and brought up a command like `rm -Rf *' (no doubt left over from when the last MIS Director had removed his personal files), and then hit Enter while my gaze was away from the screen. Not the way you want to start a new job!
  22. argedion

    argedion The TechnoFrog Moderator

    Check out my blog just updated to day.
  23. saptech

    saptech Well-Known Member

    Last night I had an issue with Mageia 3 Beta, which is like using a rolling distro. I was doing some customization on Gnome 3 and renamed a system file by mistake. Thank goodness I had just done a partition backup, using Fsarchiver on Jan. 25. All is well now.

    As the saying goes, backup, backup & backup!!!
    palmtree5 and argedion like this.
  24. argedion

    argedion The TechnoFrog Moderator

    my best one so far was I did a dd on a backup drive. Lost all my backups because it was the wrong drive i was putting a file on. good thing it was backups I didn't really loose anything as I just formatted and rebacked up everything but i certainly learned to triple check when I go and do any kind of dd operation.
  25. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I feel like I'm missing something here. :confused: Why didn't you just rename the file back to what it should've been?

    I've long been in the habit of saving copies of system files before doing anything, such as editing a file, that will lose its original state; I cleverly name these file.orig. :)

    I'm all for that! :D

Share This Page