Root The Nexus Root Toolkit

Discussion in 'Android Devices' started by Atma, Jul 11, 2012.

  1. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    [​IMG]

    Download at WugFresh


    Read NZtechfreak's excellent guide for using the root kit.


     

    Advertisement

    Davdi, mazka, JS_racer and 9 others like this.
  2. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    Time to donate to Wug (again). Paypal
     
    sleezecheeze, VeNoMzRevenge and Atma like this.
  3. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    I was just reading through his site about the root toolkit. Amazing!
     
  4. andoird213

    andoird213 Well-Known Member
    163

    Oct 30, 2011
    1,569
    470
    163
    Male
    Read him tweet it yesterday. Its just as easy to do it manually, but I'd rather get it out of the way quickly so I can get right in to enjoying using the device.
     
  5. Xyro

    Xyro 4 8 15 16 23 42
    Moderator
    1,413

    Dec 1, 2009
    12,798
    9,009
    1,413
    UK
    Updated to version 1.5.1 as the root script was stalling in 1.5, apparently.

    https://plus.google.com/u/0/113329792100896065459/posts/fSPdmP7Nhrh

     
    dunjamon, colchiro and Atma like this.
  6. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    colchiro likes this.
  7. dunjamon

    dunjamon Well-Known Member
    58

    Dec 20, 2009
    351
    16
    58
    If I root with 1.5.1...do I need to re-root with 1.5.2? Might sound like a bit of a stupid question...but I'm a bit of a root-noob.
     
  8. Xyro

    Xyro 4 8 15 16 23 42
    Moderator
    1,413

    Dec 1, 2009
    12,798
    9,009
    1,413
    UK
    If you're rooted, you're rooted. You don't need to do it again.
     
    dunjamon likes this.
  9. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    1.5.1 wasn't up to the task of rooting me. :D

    It also wanted to install Samsung drivers when I had selected my Nexus 7 (Asus).
     
  10. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Did you try these drivers? Others said they worked for them.
     
  11. NZtechfreak

    NZtechfreak Well-Known Member
    213

    Apr 23, 2010
    1,825
    763
    213
    Medical Doctor
    Auckland, New Zealand
    I was one of the ones who alerted WugFresh to the fact that earlier versions were stalling, can confirm new 1.5.2 version working fine (although you will still need to command prompt to enter recovery). Link to full guide with lots of pics in my sig, most here shouldn't need anything that noob-friendly though, the process is very easy even via command prompt exclusively.
     
    Atma and colchiro like this.
  12. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    I installed PDA.net to get them. Also had the SDK installed so those probably would have worked as well. I was rooted within an hour after buying it, but it took several tries. I used this to root my SGN, but had to use the other app to root my N7. 1.5.1 seemed to use the wrong recovery.img file since it would just hang trying to load it.

    Just checked after updating and it still only showed Samsung drivers. If I select the N7, it shouldn't show those drivers.

    I notice each version installs in it's own folder with the version in it's name so you either need to pick that folder again when you install or uninstall the previous version. I just install each version in C:\Wugs_GnexRootToolkit
     
  13. Unforgiven

    Unforgiven -.. --- - / -.. .- ... ....
    Moderator
    4,238

    Jun 23, 2010
    32,446
    30,765
    4,238
    Male
    Douglas, MA
    The toolkit only installs the binaries and superuser on your N7. It is only the tool. Once those are there, they will update on their own.
     
  14. Polarhound

    Polarhound Member
    16

    Jul 16, 2012
    14
    3
    16
    Will the 64bit drivers be distributed as part of the package soon so we don't have to roll the dice on the 32bit ones?

    To be on the safe side, I'm going to root from my Netbook since that has a 32bit OS on it.

    Edit: Tried it on two different systems, both hanging at Checking ADB status in driver config.
    Edit 2: Finally got it to go, looks like the problem was the drivers for my Optimus V that were making things hang.
     
    Atma likes this.
  15. umataro42

    umataro42 Well-Known Member
    53

    Aug 3, 2010
    310
    66
    53
    Male
    San Pedro, CA
    Worked great, and unlocked and rooted my Nexus 7.
     
  16. fatalysis

    fatalysis Active Member
    18

    Oct 18, 2011
    38
    14
    18
    Is it a problem if I unlocked with the Samsung drivers? I followed the walkthrough and didn't mention any others, so that's what I went with. Unlocked with no issues.

    Also, can anyone confirm that you can now watch movies from the Play store if you're rooted? I'm holding off on rooting until this has been fixed.
     
  17. rootbrain

    rootbrain Well-Known Member
    53

    Dec 7, 2011
    354
    50
    53
    Colorado, USA
    Also, I was updated to JR003D and that is not listed, only the original and the JR003C (1st update), going with the C version anyway.

    Status to follow:
    EDIT: Had problems with this, didn't seem to work and hung up. Started over with the manual root process rather than use this tool. I think it might be because of the JR003D, which is the latest update from Google. The JR003C selection and it was no go.

    Unlocked and rooted, using the stock recovery so I won't have to mess with it when updates are available. cwm is good, just don't want to have to keep undoing it to get the updates.
     
    VeNoMzRevenge likes this.
  18. VeNoMzRevenge

    VeNoMzRevenge Well-Known Member
    43

    May 31, 2012
    213
    29
    43
    Brooklyn, NY
    i have JRO03D on my Nexus. Hope this works.
     
  19. rootbrain

    rootbrain Well-Known Member
    53

    Dec 7, 2011
    354
    50
    53
    Colorado, USA
    Bump so people can see it's updated. See my edits, Venom.
     
    VeNoMzRevenge likes this.
  20. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    If it worked, I wouldn't sweat it. You may have already installed drivers thru other means or maybe the Samsung drivers also work on this.
     
    fatalysis likes this.
  21. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Took me an extra day but I'm rooted, updated and ready to rock. :D
     
  22. bjtcars

    bjtcars Well-Known Member
    43

    Mar 22, 2010
    130
    29
    43
    Mass.
    I was going to root manually especially where I had the JRO03D build number as well but I figured what the heck give it a shot and it worked great. I used the JRO03C build on the toolkit.
     
  23. binary visions

    binary visions Well-Known Member
    313

    May 14, 2010
    3,334
    1,443
    313
    I've loaded the root kit on two different PCs now, and it hasn't worked properly on either one.

    The automatic driver installation failed both times, so I did the manual driver installation - which worked, but all of the sanity checks ("list adb devices", "boot into boot loader") failed. Even though ADB works perfectly on both PCs when I run it from the command line, the root kit doesn't seem to show anything.

    Doesn't matter, I suppose. I've rooted and unlocked all previous devices through the command line, and it took less time than fiddling with the root toolkit. Just thought I'd try a new tool - I guess that's what I get for doing something different :D
     
  24. Atma

    Atma Well-Known Member
    533

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    IF THE PROGRAM IS STALLING ON YOU (FOR ADB CHECK):

    1. Restart the toolkit
    2. On the main interface hit the "Launch" button to open Advanced utilities
    3. In the advanced utilities interface; hit the "Launch CMD Prompt" button
    4. Type the following cmd Code:
      adb start-server
    5. Now you should be able to use any of the utilities in the toolkit without it stalling.
    This extra step is just a temporary solution, until I release v1.5.3; then this won't be necessary.

    From WugFresh

    I also read there is an officlal release of CWM out now he will be adding in the next version.
     
  25. Droid_Genius

    Droid_Genius Well-Known Member
    58

    Jun 1, 2010
    390
    18
    58
    Male
    Houston, TX
    This tool good for 4.1.1?
     

Share This Page

Loading...