The Nexus Root Toolkit


Last Updated:

  1. Atma

    Atma Well-Known Member This Topic's Starter

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,899
    Yes, under model type choose JRO03C. It will still work even if you have D.
     

    Advertisement
  2. shaneydroid

    shaneydroid Well-Known Member

    Joined:
    Oct 12, 2011
    Messages:
    225
    Likes Received:
    10
    I normally go the command line route for such things but gave this a try and it was just too easy :)

    Didn't bother with guides, just read the site, downloaded and did the deed.

    Rooted, returned to stock and rooted again without issues.
     
  3. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
    Nothing wrong with easy.

    Save your brain for something challenging, like what'd I do with my car keys. :D
     
  4. shaneydroid

    shaneydroid Well-Known Member

    Joined:
    Oct 12, 2011
    Messages:
    225
    Likes Received:
    10
    Exactly :) Takes away the stress after mis-typing the same command 3 times in a row etc :)

    I will be doing all future business with the N7 through this brilliant tool.
     
  5. GandalfTehGray

    GandalfTehGray Well-Known Member

    Joined:
    Dec 19, 2010
    Messages:
    846
    Likes Received:
    84
    Hmmm can i root it first, backup everything with TB, then unlock?
     
  6. dautley

    dautley VIP Member VIP Member

    Joined:
    Jul 23, 2010
    Messages:
    1,823
    Likes Received:
    502
    TB won't run without root, you should first use the Root Kit option to back everything up, unlock it, root it, then restore your backup.
     
  7. jova33

    jova33 Well-Known Member

    Joined:
    Oct 19, 2011
    Messages:
    1,568
    Likes Received:
    180
    You can root without unlocking. There's a guide in the galaxy nexus all things root section. Should apply I would think.....
     
  8. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
    But unlocking erases your sdcard so you'd have to back that up too.

    Easier just to let WUG's do all the work for you. :D
     
  9. dautley

    dautley VIP Member VIP Member

    Joined:
    Jul 23, 2010
    Messages:
    1,823
    Likes Received:
    502
    Okay, I'm new to Nexus but I read on here somewhere that you had to unlock to root, I never had saw that before but each android device is different and this is my first Nexus device.
    So do you or don't you have to unlock to root?
    When they say locked and unlocked I assume they're talking about the boot loader? If so why even put a locked boot loader on a device that can be unlocked?:confused:
     
  10. jova33

    jova33 Well-Known Member

    Joined:
    Oct 19, 2011
    Messages:
    1,568
    Likes Received:
    180
    So the people who don't know what they're doing don't break stuff lol

    But yeah, rooting without unlocking seems difficult, and I can't find the post on how to do it.
     
  11. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,736
    Likes Received:
    8,811
    I read that the backup and restore option can be used without root with the galaxy nexus. I can find the link later today.

    But it looked promising. Assuming it worked on the n7 too, you could use it to keep your stuff safe whilst you root and wipe.
     
  12. shaneydroid

    shaneydroid Well-Known Member

    Joined:
    Oct 12, 2011
    Messages:
    225
    Likes Received:
    10
    I don't know about a nandroid backup but I did the regular backup (user apps and system apps) before rooting.
     
  13. sleezecheeze

    sleezecheeze Well-Known Member

    Joined:
    Jul 20, 2012
    Messages:
    143
    Likes Received:
    14
    Where you select the model and droid version, there is an option for

    Nexus 7 4.1.1 JRO03C

    Well I have;

    Nexus 7 4.1.1 JRO03D

    Should I just use the 'C' option and hope for the best or will this effect the unlocking and rooting process?
     
  14. Atma

    Atma Well-Known Member This Topic's Starter

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,899
    Yes, C will work fine. He is adding D in the next update.
     
    sleezecheeze likes this.
  15. Groid

    Groid Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    358
    Likes Received:
    88
    So, installing the drivers installed pda.net on my computer and N7. Can I uninstall pda.net without affecting the drivers it installed? Can I still use the root toolkit program if I uninstall pda.net?
     
  16. Atma

    Atma Well-Known Member This Topic's Starter

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,899
    I think I read you can uninstall pda.net and still have the drivers but I haven't tried it.

    I just bought another one after sending my last one back for refund about 10 days ago, but I remember often having to reinstall the drivers when I wanted to do something with the Toolkit. I had a problem with ADB finding it unless I did that.

    As soon as my new one charges up I'll be doing it again. :D
     
  17. VeNoMzRevenge

    VeNoMzRevenge Well-Known Member

    Joined:
    May 31, 2012
    Messages:
    213
    Likes Received:
    29
    This toolkit is the most awesome thing i have ever used when rooting. Already saved my butt from my stupid experiments. Its just too easy.

    I can't throw my money at this dev fast enough.
     
  18. boofer

    boofer Well-Known Member

    Joined:
    Jul 1, 2011
    Messages:
    95
    Likes Received:
    44
    nevermind!
     
  19. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,736
    Likes Received:
    8,811
    I had the same problem. I'd recommend uninstalling all of the drivers, using that tool the root kit links you to, and then installing the windows component of pdanet (a tethering app).

    I'd heard it was a pretty reliable way to get adb drivers working, and it did work for me first time.
     
  20. boofer

    boofer Well-Known Member

    Joined:
    Jul 1, 2011
    Messages:
    95
    Likes Received:
    44
    nevermind!
     
  21. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,736
    Likes Received:
    8,811
    Yeah, that was the tool I used to remove all of the USB drivers. I uninstalled anything to do with android, Asus or Google.

    I'm not sure about that error though. I don't even think I had my tablet plugged in until after pdanet finished installing, so it wouldn't need to connect.
     
  22. boofer

    boofer Well-Known Member

    Joined:
    Jul 1, 2011
    Messages:
    95
    Likes Received:
    44
    nevermind. changed the USB port and it worked.
     
    Xyro likes this.
  23. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784
  24. gra2316

    gra2316 Well-Known Member

    Joined:
    Feb 19, 2012
    Messages:
    55
    Likes Received:
    2
  25. colchiro

    colchiro Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    8,886
    Likes Received:
    1,784

Share This Page

Loading...