The Official One-Click Rooting Solution for Droid Thread!!! :D :D LATEST: V2.0.4


  1. Rota

    Rota Well-Known Member

    Uninstall Norton. Download and install Avast, a totally free anti-virus program. Never use Norton again because it's as bad as the viruses it supposedly "prevents".
  2. dmartin1972

    dmartin1972 New Member

    ok. I am running windows 7. I moved the exe file to my c drive root and it opened and began working. But when you get to the part where the $ is supposed to change to a # is doesn't change and everything after that fails.
    Still trying. thanks
  3. RDKamikaze

    RDKamikaze Well-Known Member

    @Britney - My program doesn't have any viruses, Norton is crap.

    @dmartin - PM me and type out all the steps you are taking starting from the very beginning (installing Moto Drivers).
  4. Britney

    Britney Well-Known Member

    I did everything as described and the command window says you are now rooted. I reboot and nothing happens. No super user in my app tray. I d/l it and it says I am not rooted that I have to reboot and flash su.
    Help.
  5. RDKamikaze

    RDKamikaze Well-Known Member

    Try it again Britney. Some people have reported (not many, but a few) that it doesn't work the first time but the second to fourth? time you do it that should work :)
  6. hurtsellers

    hurtsellers New Member

    First of all I've loved following this, and really am amazed at your efforts, but it just won't work for me for some reason. I've followed all the steps as carefully as I can, but I end up with my command window staying open for about a minute and then closing and nothing happening.

    Any idea's where I might be going wrong? I've tried it like a dozen times.

    No matter what, I think what your trying to do is amazing!!

    BTW: I really like the music by Mika in your video, very cool.
  7. hurtsellers

    hurtsellers New Member

    Thanks. I've downloaded the drivers, plugged the phone in and made sure usb debugging was enables. I've run the .exe, but it starts and then in about a minute the command window simply closes. (nothing says "your phone is rooted" and the command window closes without any chance to type in "exit". I do try and reboot my phone but nothing changes and no Super User app.

    thanks if you can think of anything

    I'm pretty close to giving up.... I'm wondering if rooting really offers anything worth this trouble? Again thanks to everyone anyway.
  8. idahoscuba

    idahoscuba New Member

    Awesome solution. I have been reading many many solutions , since the ota that killed my last root. Your solution worked like a charm . Thanks. I will be donating!!!! Now I have my wifi tether back !!!! Whooo Hooo. Thanks again RDK.
  9. cracc120

    cracc120 Member

    when I install the drivers I keep getting moto ADB compostion interface is disabled or blocced and I can't install my phone with my laptop.. help me plz I'm running vista
  10. Tenzen

    Tenzen Well-Known Member

    Is there an apk in the near future. I really want to root. But don't have a pc for the manual way. Or the time to use someone elses for that matter. Thanx for all the efforts guys.
  11. twodmax

    twodmax New Member

    Ok so i finally got a droid.. the original about a month ago, it had the frg22d build . I love it, i had started researching droids before dx came into view.
    So here it is last weekend i finally took the plunge and rooted using RSD lite, i installed the motorola drivers, downloaded SPRecovery and clockwork mod. and all the frilly goodies that i was told i needed. ROM Manager, Titanium Backup.....etc. Ok It took me a few tries (only cuz soomeone left out a step in the instructions) I found them in another forum while fretting and sweating....Ok so i get the last piece of the puzzel and voila' I am now rooted. ok so i played around this last week and finally found some roms i liked. So i went to youtube and searched for how to install roms. lots of info there seemed pretty easy. So I downloaded UD8, Succulent Desire v7.0 AB and Shine.
    OK next I extracted them from zips to the correct folder "nandroid" on sd card, i had to add this folder. i made sure i did a back up with rom manager first, then i backed up with titanium my apps and settings and such. ok then i rebooted into recovery mode " 'X' and power button. things were looking good but theres the finicky thing i tried advanced, i tried nandroid, i tried everything i could but it only showed me the backups from SPRecovery, i could not find the others i had downloaded.
    So i guess this uberNoob could use some help here guys and gals. what have i done wrong or not done should i have wiped cache, did factory reset or what. I am lost and i am usually a compu geek. (background on me ... i was around when you only had basic, cobalt, pascal, and fortran to work with as i was in highschool at the time. and you still had to set key locations/addresses when building your computer. This was the hey day of the radioshack trs80 (trash80) and model 100 laptop with standard taperecorder to save your work on. ... so any help out there for a newly rooted noob????
  12. kratos

    kratos Back on my throne!!! VIP Member

    This goes to everyone, but I am addressing your stated question:

    I, having just rooted a few days ago myself, and many others can attest to rooting being "worth the trouble". You have greater control over your phone, unlimited customization options, wifi tether, ability to backup user data and private apps, overclocking, ability to take screenshots in a very easy manner, ability to block ads in apps, etc, etc, etc.

    If you are having trouble using this method, there are other methods that you can try.

    One is this method, but not in a simple double-click-and-be-done fashion: http://androidforums.com/droid-all-...oid-without-rsd-lite-up-including-frg22d.html

    This one is the most tried and true technique. It is a little more intense, but has been used by more people than I could even imagine: http://androidforums.com/droid-all-things-root/141116-guide-rooting-2-2-windows-linux.html

    Your best bet would be to root using ADB the manual way. It is easier and less intense. I used the manual method, mainly because I already had ADB installed for development.

    NOTE: Any time you are learning something new, I highly, HIGHLY suggest reading the instructions at least 2-3 times and then reading them another 2-3 times. It is very important to know exactly what you are doing when rooting and flashing anything. Do your research and always backup as many times as you can.

    Keep in mind that rooting and flashing has become so easy (with third party tools) that most people just jump in and don't actually understand what is going on in the background. If something goes wrong, they have no idea how to go about trying to fix it. This thread will give you all the info you need to get started and to understand what it is your are doing: http://androidforums.com/droid-all-things-root/136508-guide-all-things-root-related.html

    This sticky will give you all the info you need to know about everything else (where to find ROMs, kernels, basebands, how to stop the OTA notification, etc): http://androidforums.com/droid-all-...e-updated-september-18th-2010-9-38pm-cst.html

    If you have any questions or issues, there are many people who are willing to help.

    Kratos
    joyous007 and hurtsellers like this.
  13. Britney

    Britney Well-Known Member

    Got it!!

    Thanks very much RDK.
    :)

  14. RDKamikaze

    RDKamikaze Well-Known Member

    I'm so glad you guys are having much success!! I'm still working on updating this code so the cmd doesn't have to be on top (which will solve pretty much all your problems if you aren't having success the first time) and I'm still waiting for someone who could tell me the commands I would have to do Droid-side!

    Here are my responses to everyone who has posted after my last comment:

    @hurtsellers - Did you watch my video? There are TWO command prompt windows that open up! One does its thing to delete the old Soup or Root directories from the past and the other does the actual rooting. Watch my video two more times and see if you can figure it out. PM me with all the steps you are taking and try it again.

    @idahoscuba - Thanks for letting me know you love the program!! Your donation would be HIGHLY appreciated!!!!!

    @cracc120 - Are you an administrator account on your computer? I hate Vista, they have so many restrictions. Try running the program with Administrator Privileges.

    @Tenzen - I'm really really really really hoping so, I just need someone who knows what codes I would have to do Droid-side to tell me and I will do the programming to make it so!!

    @twodmax - Welcome to the rooted Droid life (almost)!! Trust me (and the poster below you), it's worth it!! That's why I made this program, to make Droid rooting easier and more awesome!! Post a new thread with your question, more people will be willing to help you (and see your post).

    @kratos - You rock!!! Thanks for putting my tutorial on your list, I really really appreciate it!!

    @Britney - Glad I could help!! Enjoy being rooted!!

    If any of you have felt I have done something beneficial for you, please feel free to hit the Thanks! button on the original post!! :D
    twodmax likes this.
  15. thebarbrr

    thebarbrr Well-Known Member

    RDKamikaze - is there going to be an unroot option in the future?
  16. stupalmer36

    stupalmer36 Active Member

  17. RDKamikaze

    RDKamikaze Well-Known Member

    I would love tto know what problems you guys are encountering (are there errors given?) so I can make this flawless :) All in all, I think it's just timing the delays properly for everyone and making sure those darned cmd windows don't lose focus!!

    I can't wait until my research and questions on coding forums get answered so I can move on with this program's efficiency :)

    Side note: Me and my friends have all rooted our droids (multiple times even on different computers) over the last couple days counting over 10 roots from scratch on over 5 computers (which never ran the program before) flawlessly (XP, Vista ick, and Win7) so I'm unsure what problems some people are having that makes them have to run multiple times.

    As a temporary solution, I will probably change delays to being dependent on the current condition with looping (coding terms, don't feel bad if you don't understand it) so this is pretty much thinking out loud for my own records :p
  18. lilbballer27

    lilbballer27 Well-Known Member

    Why is verison 1.8 22mbs and 1.8rA is only 2mbs? Am I going to miss something with the 1.8rA opposed to 1.8?

    Thanks
  19. lilbballer27

    lilbballer27 Well-Known Member

    Ran 1.8rA said my phone was sucessfuly rooted. SO I rebooted my phone download rom manager and it said that I must root my phone to use rom manager. So what did I do wrong?
  20. Chanceman

    Chanceman New Member

    Can anyone help me with the 1.8 Soup or Root link?? When I try to download it, the status bar does not move and it does not download. PLEASE HELP! I really want to try this out and donate if it works on my phone!!
  21. danarchy

    danarchy Well-Known Member

    Great job, process only took a few minutes, didn't have a single problem.

    Have you considered using AutoIt to automate this process? It would solve your focus problems, and even add a nice GUI.

    Thanks to OMJ as well, who made it very easy to understand this process!
    RDKamikaze likes this.
  22. npro1464

    npro1464 Well-Known Member

    Hey I'm a noob at all this. It says I have 2.2, but I'm guessing this works on that? Also, does anyone know if I will be able to use Windows XP, and if so how old can it be? I'm a MAC user and I might have access to a Windows comp, but not sure if this persons comp is too buggy/old. I might be able to use a Vista comp, would that work? Thanks.
  23. RDKamikaze

    RDKamikaze Well-Known Member

    @lilbballer27 - The versions are extremely different sized because I found out I don't need the whole windows android adk attached, just the couple files that it actually refers to. This cut the size dramatically. Also, PM me exactly what you do from the beginning (installing moto drivers) and try again.

    @chanceman - PM me your email and I'll send you the file directly. :)

    @npro1464 - I have heard the best success on Win7 or XP, vista has some stupid issues making you have to do the root about 4 times (still looking into it).

    @danarchy - AH YES!!!! AutoIT, that's what it's called!!! I totally forgot about that, I'll start researching how to program in it immediately!! Thanks!! :D :D :D
  24. Chanceman

    Chanceman New Member

    I am starting to feel like a moron over here! I cannot get it to work on my Moto Droid. I am on my work computer which has XP. I downloaded the drivers and Soup or Root 1.8rA from the OP. I also made sure I had debugging enabled on my phone. I plug the phone in, and start the program and it gives me all that mount: Operation not permitted
    failed to copy 'c:\droidroot\Superuser.apk' to '/system/app/Superuser.apk': Read
    -only file system ect...stuff. At the end, it tells me my phone should be rooted and I need to reboot my phone. I do that and find that there is no root. I try the process again, but this time, when I go to open up Soup or Root on my desktop, I get this error message: "Some Files cannot be created. Please close all applications, reboot windows, and restart this installation." That is followed by the attached image. I have done this 5 times already and the same thing keeps happening.

    Can someone help me with this?

    Thanks!
    http://i27.photobucket.com/albums/c159/Chanceman512/rooterror.jpg
  25. Hercules

    Hercules Well-Known Member

    Does this install the recovery partition or is that done separately after? Sorry for the noob question but I am a noob the the droid 1 crowd. I gave my rooted Eris to the wife and rooting the droid is a little different. I have read about ROM manager for installing recovery. Is this the best way to do it? Will ROM manager install SPRecovery or just Clockwork. Any imput suggested. Looking to root the Droid with this soon.

Share This Page