The Official One-Click Rooting Solution for Droid Thread!!! :D :D LATEST: V2.0.4


  1. AltairKyle42

    AltairKyle42 New Member

    RDKamikaze you are awesome!!!
    Thank you so much for the work you have done. first time root, just ran your program and i have the superuser thing now so i assume i succeeded? now my question is where do i go from here? what should i do now that i am rooted and what backups/programs should i run?

    also...you have no idea how much i would love to support you and donate, but i just purchased a new jeep a couple days ago and financially i just can't manage right now, but when i get back to being financially comfortable i will not forget to come "pay" my respects.
  2. RDKamikaze

    RDKamikaze Well-Known Member

    Thanks for the great remarks!! I'm sooooooo happy that this is working for people on a consistant basis now, I may just leave it the way it is and update as ADB and newer versions come along.

    Keep the comments coming guys!!
  3. ourgangmn

    ourgangmn New Member

    Download link does not appear to be working, I do get the opportunity to browse real estate adds, "free" screensavers, etc, but no download.
  4. mrcizzo

    mrcizzo New Member

    I don't have the superuser icon in my tray. I went back to stock 2.2 via RSDLite and then I used the 2.0 beta installer. It didn't give me any errors or anything like that but after restarting the phone, there was no super user icon.
  5. zaroba

    zaroba New Member

    Phone Make/Model:Motorola Droid
    Firmware Version: FRG22D
    ROM Version (ex. FRG22D):
    Windows Version: Windows 7 x64
    Do you have admin privileges? Yes
    Is your phone on USB Debugging? Yes
    Have you turned on USB Storage (that's a no no)? No
    What cable are you using? One that came with the dock that it is in
    What port on your computer is it? one of the many USB ports (is this important?)

    I have run this a couple of times. It looks like it is successful. What should I see on the handset? Is there a new icon? Can someone post a screen shot of what it should look like?

    I am using Soup or Root v2.01 Beta.
  6. mihalich

    mihalich Well-Known Member

    Just curious, but ROM Manager will root you with one step the first time you run it on a non rooted rom.

    Does ROM Manager's root process not work for the latest stock roms?

    Just asking in case I ever have to do this again, so I know whether to use ROM Manager or this app.

    Thanks,
    Joe
  7. zaroba

    zaroba New Member


    Just found an icon in the apps called Super User. I guess it worked.

    Thanks for your efforts in this.
  8. RDKamikaze

    RDKamikaze Well-Known Member

    @ourgangmn - Try it again, it should be fine (I tried it again and it worked fine). If it still doesn't work for you, PM me your email and I'll send it to you (if you can accept 10MB files).

    @mrcizzo - Try 2.01 Beta, that one is a LOT more stable.

    @zaroba - Yeah, look for superuser as it states when the rooting finishes when the popup box comes up ;) Glad to hear you're rooted my friend, enjoy the real Droid experience!! :D

    @mihalich - ROM Manager WILL NOT root your Droid. This isn't for flashing clockworkrecovery mod (which is strictly a recovery option for rooted users), this actually roots your Droid and gives it the privileges to do anything requiring root access. ROM Manager only flashes ROMs and flashes clockworkrecovery mod, it does not root your Droid.
  9. Mrdroid921

    Mrdroid921 Well-Known Member

    Is unrooting as easy as a few clicks, or will it be hard??
    I don't plan to use any roms, just the stock overclocked.
  10. RDKamikaze

    RDKamikaze Well-Known Member

    Unrooting is a matter of going into RSD Lite and flashing the stock ROM to your Droid. Likewise, you should be able to go into ROM Manager and I think they have a stock ROM there that you can use to reflash your Droid to stock. Be advised though, flashing your Droid to stock will wipe all your cache and data, so it will be brand new again and NOT have any of your apps (you have to re-download them). The provider cannot trace it :)
  11. Mrdroid921

    Mrdroid921 Well-Known Member


    Well, I think I may just give it a go then. Where does one find these
    programs "Rom manager" and "Rsdlite" Thank you for your help.
  12. RDKamikaze

    RDKamikaze Well-Known Member

    Just remembered about my old Dropbox account and decided to upload there instead. Woot!! OP link fixed as well :)

    http://db.tt/s6Z8LKe

    EDIT:
    @Mrhorology - You can find ROM Manager in the Marketplace on your Droid, the free version works just fine :) RSD Lite is out there, do a search on these forums and you'll get links and all that jazz (or if you're lazy,Click Here). Enjoy being rooted!!
    Mrdroid921 and ourgangmn like this.
  13. ourgangmn

    ourgangmn New Member

    RDKamikaze, thanks for the link provided above...I am now rooted. :) Previous solutions like Easy Root didn't actually work, but your app did.
  14. RDKamikaze

    RDKamikaze Well-Known Member

    Awesome!!! I'm glad to hear that you are now successfully rooted :) :)

    You guys are going to LOVE my next release that's already a work in progress (well, you won't but many others will)!!!
  15. TheNewZackMorris

    TheNewZackMorris Active Member

    Thanks for this great tool RDKamikaze. I just used 2.01b and it worked the first time through. All your work is greatly appreciated!
  16. RDKamikaze

    RDKamikaze Well-Known Member

    Soup or Root 2.02 Beta released!!! It now features the sending of dumps to my email so I can figure out the patterns of some peoples' problems quicker!! :D

    Thanks guys for all the support and those of you who were awesome enough to donate!! You keep me going :D :D :D

    http://db.tt/XmMuCB7
  17. RDKamikaze

    RDKamikaze Well-Known Member

    Wow, I'm getting great information already!! Thank you guys sooo much for your help, keep trying out 2.02 Beta!!! Here are the questions I have so far:

    @AbandonShip - What version of Windows are you running? I'm not getting the attached debug information from you at all :(

    @xetestem - What version of Windows are you running? I'm not getting the attached debug information from you at all :(

    To the following users, are you properly rooted?
    Guit4rG0d
    ex. RDKamikaze (who isn't filling out the username section, eh? There are up to two of you!)
  18. Mrdroid921

    Mrdroid921 Well-Known Member

    RDK, I just wanted to say thanks again for your hard work.
    I am rooted and running stock with ChevyNo1's Froyo over
    clocking kernel at 1.1Ghz. I just got a 1524 benchmark.
  19. RDKamikaze

    RDKamikaze Well-Known Member

    Okay, thanks to debugging I was able to get a new release out already!! This one has longer delays on it (not much, but just enough) and totals to over a minute of rooting time (just on delays). I'm sorry if it takes a while, I just can't cut corners on timing delays anymore as I see it's giving some people problems :( If this one doesn't work, I'm going extreme and doing at least 1 and 5 second delays on everything, giving it almost no room for error (and letting me know if it's truly timing issues or not).

    Anyway, Download Soup or Root 2.03 Beta Now!!!

    EDIT: I made a mistake in 2.03 Beta so I fixed it and re-released it just now. All 2.03 Beta links have been updated :) Please re-download it if you downloaded it before 12:35AM mountain time.
  20. npro1464

    npro1464 Well-Known Member

    Hey I finally have access to an XP comp and it's not working! I can't even run the program, it keeps asking me if I want to reinstall it (did this like 4 times). I'm using 2.03.

    Side ?: Should I have USB storage turned on or off? I've tried it both ways, but the program doesn't open. Thanks!
  21. npro1464

    npro1464 Well-Known Member

    Now it is saying I have a "Damaged SD Card." Need help! Thanks!!
  22. RDKamikaze

    RDKamikaze Well-Known Member

    For the program not working problem: Does your computer have administrator privileges? Does it have anti-virus software installed? I know one user reported AVG saying it's a virus, but I assure you it's not (they say it is because it has code that types keys automatically for you, FYI). If you do, try turning off your anti-virus and running the program again.

    For the damaged SD card issue: take out your battery and your MicroSD card, give it a few minutes (even press the power button to clear electrostatic energy) and then place your SD card back in then your battery then turn on the phone.

    If you know how to make a desktop recording (ex. CamStudio) please make one so I can see what happens and PM that to me. We'll talk there :)
  23. RDKamikaze

    RDKamikaze Well-Known Member

    Okay, looking at debugs I noticed a few things right off:

    1. GIVE ME YOUR USERNAME AT THE END OR SOME DEFINITIVE NAME SO I KNOW WHO TO TALK TO!!!
    2. You MUST have a C: drive (one guy's been trying over and over all day with an E: drive, he doesn't listen to #1 so I can't tell him that though)
    3. I'm going to see if I can get more stable use out by running the cleansing batinside AutoIt instead of before running (mybad, seems to cause issues).
    4. Please makeure your Droid (Droid one only, no X or HTC or whatever!) is plugged in before using :facepalm:
    5. Before you retry, unplug your Droid, reboot it, and plug it back in!! Then retry.
    6. One-click rooting is hard to make (period) because there is a lot benching on the user (like plugging in the phone and turning on USB Debugging) that cannot be coded.

    When I have more time over the week, I'll work on a new release. I don't know why this isn't working for you guys, I've tested it tried and true many times on mine, my griflriend's, and 5+ other friends on different computers and have had zero issues. I'm starting to think some of this is user error (or some crappy anti-virus claims "virus" and blocks certain things) as it doesn't go away in any of my fixes.

    New plan: If you know how to make screen recordings of your computer (google it) then please do so, upload to youtube (or somewhere) and give me the link. I was to see what you are doing.

    Next release note: I'm going to up the delays ridiculously to verify that isn't the problem. This being said, it will take about 5 minutes to root your Droid so hang tight while it does its thing.
  24. TheNewZackMorris

    TheNewZackMorris Active Member

    I have a quick question. I'm looking into installing a custom rom through rom manager. However, I read a post of someone who rooted with you app and then tried installing a rom this way, but it wouldn't work right. They had to flash SPRecovery and flash ClockworkMod recovery again. Has anyone had success installing a custom rom after rooting with this method?
  25. msprygada

    msprygada Member

    I was not able to root. Tried both ways. You should have 2 install messages regarding it with the 2.0 beta.

    EDIT: OK, I did it with the older file and I am now rooted. Not sure where to go now but just bought ROM Manager and going to install Ultimate Droid and see what happens. Wish me luck.

Share This Page