The process com.google.process.gapps has stopped unexpectedly


Last Updated: 2014-08-15 18:50:31
  1. buttercup2003

    buttercup2003 Member

    *SIGH*… I finally was able to get my phone rooted. I downloaded the “Tatinium Back Up” app, deleted a few apps, and without noticing :eek: I deleted the contacts app that comes with the phone, so now I’m getting a message that says “The process com.google.process.gapps has stopped unexpectedly. Please try again”.:confused:... I try rebooting the phone and its still not working :(. Every time I tried to synch my Gmail contacts it says “failed”

    UGH… Can someone please help me… Is there a way to revert this?
    Thank you!

    Advertisement
  2. db2

    db2 Well-Known Member

    http://www.sendspace.com/file/5i1m5f

    Use a root file browser or adb to put the files from the zip in to /system/app and you should be okay, if that's all that's wrong.

    Note: Only for 4.0.4 stock which as of this reply is the only Android version available for the Rise. It should work fine on your Hydro though.

    Can't guarantee that the link will work for long, most "free" file hosts are junk.
    buttercup2003 likes this.
  3. buttercup2003

    buttercup2003 Member

    Thank you sooo much for the help...

    Still not working...not sure what I'm doing wrong...downloaded the file, it saved to my sd card i extracted the file hit install and got a message saying "cant install".... Try moving the whole zip file to the system/app folder, says app file-read only cant move. Try unzipping the file and moving the apk app to system/app getting the same message. Extracted the file one more time try moving the actual app to system/app folder, still getting same message....

    Sorry for bugging sooo much. I really hope i can get my phone back to normal. I'm super frustrated... :(
  4. db2

    db2 Well-Known Member

    Both the .apk and .odex file need to be moved to /system/app for it to work. Then reboot.
  5. buttercup2003

    buttercup2003 Member

    :confused::confused::confused:
    OK i was able to move both files to the system/app folder, hit install and now i'm getting "cant install" message...

    Is there a way to revert the rooting, and maybe get the phone back to stock?
    Screenshot_2013-01-17-10-15-23.png
  6. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    If you successfully copied them to /system/app/ then there is no need to install them by selecting them. The act of copying them to that folder and setting the proper permissions it the installation process. ( Permissions should be rw-r--r-- )
    buttercup2003 likes this.
  7. buttercup2003

    buttercup2003 Member



    Thank you Lordvincent 90
  8. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Which file explorer are you using?
    You actually have to set the permissions.
    I use es file explorer as my preferred root explorer. To set the permissions with it you have to long press the file and the select properties
    [​IMG]
    Then select the change option
    [​IMG]
    Then set the permissions like this
    [​IMG]

    And then when you reboot you should be all set :)

    (I'm not sure about any of the other root explorers... but if you do try with es, you have go to the settings and then the root settings and check all the boxes to allow it proper root access)
  9. buttercup2003

    buttercup2003 Member

    Still nothing:argh:... I guess the issue is bigger than I thought...

    Thank you guys for all of your help. :D
  10. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Well, it may be that those files came from the rise... If someone had the ones from the hydro (I'm out of town, and my roommate is the one who owns this phone) it could make a difference
    buttercup2003 likes this.
  11. db2

    db2 Well-Known Member

    Delete all the files in /data/dalvik-cache - not the directory just the files in it. Then reboot. Your Dalvik cache will be rebuilt and I bet Contacts starts working again.

    It'll take a few minutes for that process, run around the block or something in the meantime. ;)
    buttercup2003 likes this.
  12. buttercup2003

    buttercup2003 Member


    Nope
  13. Hadron

    Hadron Well-Known Member Contributor

    It's probably best if I move this to the Hydro All Things Root forum - might get more views from people who can help.

    Don't know this phone myself. At this point I'd generally recommend flashing a new ROM, but from looking in the root forum it seems there aren't any. Maybe if someone with the Hydro can provide the necessary files you'll have more luck.

    Did you delete anything else?
    buttercup2003 likes this.
  14. imotasam

    imotasam Member

    Word of the wise is to make a complete backup of your phone with tibu(titanium backup) and copy tibu folder to your computer. Freezing is also better than deleting, so you would know what would mess up if you deleted an app.

    Im running this phone pretty barebones as I got rid of most system apps that I didn't need. All I wanted to do was listen to music, so that's what it does. I removed system apps one by one and Im pretty positive that removing the contacts apk is what is causing the problem. "Gapps"= "google apps" so you may have deleted like "google +" or something tied to the framework. Also factory data wipe in the recovery menu doesn't restore apps that you have deleted.


    I have a backup of all system apps on titanium backup that you could use to restore the contacts apk and any other files you deleted.

    You would first extract my zip. Make sure the folder name is TitaniumBackup. You can copy all the contents from the folder to the one you already have or just replace it all.. Then go into preferences then select backup folder location (make sure you see all the contents of the tibu backup there) Then you should be able to restore your apps.

    TitaniumBackup.zip - 80.28 MB
    buttercup2003 likes this.
  15. buttercup2003

    buttercup2003 Member

    You are totally right, I should had back up all of my files before deleting any apps
    imotasam likes this.
  16. imotasam

    imotasam Member

    Hah its okay, this is my second phone. I thought I would be clever and remove the boost boot animation....made the phone bootloop and I forgot to set usb debugging on so I was out of luck :p




    I also have a Galaxy SII and if I mess something up I can just flash a rom or something...so much easier than this phone haha!
    buttercup2003 likes this.
  17. buttercup2003

    buttercup2003 Member

    Hey guys... im back.

    Ok, so i was able to get my missing apps back. Thank you, imotasam for the zip file and for helping me recover the missing apps, i was able to get titanium back up pro, i tried freezing some of the google apps but im still getting that stupid pop up message. (The process com.google.process.gapps has stopped)

    I cant synch my contacts, or add my gmail account. I freeze all the google apps and i wont get that annoying pop up message, but then i can access any of the G apps.... ugh :mad:.... 5 days of this crap....

    Is there anything else i can do to get my phone back to normal?

    Again, thank you soooo much for all the help!!! :(
  18. Tattooedgod

    Tattooedgod Well-Known Member

    Only thing I can say from reading around turn off automatic sync then manually update your apps
    buttercup2003 likes this.
  19. qhensler

    qhensler New Member

    No one ever seems to finish. Did anyone find a solution.? I deleted framework and Google services all the cricket apps and the nothing Google works CORRECTLY. I can sign in I can sync somewhat. I can get online I can make calls etc. I can't open play store I can't download anything from anywhere. My sound profiles are gone and my camera works whenit wants. All my apps were backed up TB. phone worked great. Until TB said back up complete. My phone re booted and then boom no Google play connection system files and apps gon e and sound and download issues. Also its only ringtones my music sound and phone sound work fine. One more thing my wifi and data both work except they never turn blue no matter how hood connection is.. please I've reset every way I've signed in out with ten diffent accounts everything. I even have all my back ups on my Phone and sdcard but when I debug threw USB and re ad apps n files they will not load to phone. I was able to load 1 song but no files or apps or anything
  20. Belzabub

    Belzabub Member

    process gapps, had a problem with this myself. Then phone would force a reformat. Turns out my sandisk class 10 speed microsd card didn't work with stock firmware, and for some reason my rooted phone won't update to the newest firmware. Anyway, replaced the sd card with a class 4 and no more gapps problems. I think it would have went away too with the new firmware but I can't confirm.
  21. Qb420

    Qb420 Member

    Can i have a copy of the file. did the same as buttercup2003
  22. susaqazi

    susaqazi Member

    I need a coopy of the Titanium Backup too. I too am having some problems with the .com.google.process.

Share This Page