The PRS Complete Rooting Guide


  1. prerunnerseth

    prerunnerseth Well-Known Member

    I DID NOT MAKE THE ROOT PROCEDURE ALL PROPS GO TO THE TEAM AT
    UNREVOKED. I just tacked on the perm procedure and regurgitated it in my own words. \

    ************DISCLAIMER**********
    I nor anyone else is responsible if you break your phone. try this at your own risk!!
    ***********END DISCLAIMER**************

    Original procedure here:
    http://www.unrevoked.com/rootwiki/doku.php?id=public:adb_in_recovery

    donate here:
    https://secure.eff.org/site/Donatio...OXY_ID=1570&PROXY_TYPE=22&1840.donation=form1

    I am just compiling the Current procedure here.

    Install the android SDK
    Android SDK | Android Developers


    Download these Five files and place them into your android sdk/tools folder (wherever you installed it)
    http://www.unrevoked.com/incredible/payload-update.zip
    http://www.unrevoked.com/incredible/ota.zip
    http://www.unrevoked.com/incredible/busybox
    http://www.mediafire.com/?nwzozqltm0i
    http://www.mediafire.com/?udotmjdniyn



    Click on start
    then on box at the bottom of your start menu
    type cmd

    a command window will pop up

    navigate to the android SDk Tools directory

    type edit loop.bat

    in edit enter the following

    Code:
    @echo off
    :TOP
    adb shell
    GOTO TOP
    
    press alt-f then x

    hit enter for yes


    ***********ADDED BOTH METHODS for shell in recovery*****************

    credit to you_eeeeeediot @ XDA for the new procedure

    type loop in the command window and press enter

    the screen should fill up with "Error - Device not found"

    Unplug the USB

    Press and hold the optical Trackball and press power

    Once in the menu press power again

    Wait 20 seconds for it to do its bit

    Plug USB in and wait another 10 seconds for your computer to detect the phone

    press menu down to highlight "recovery"

    Press power

    wait 20 seconds

    the screen should change from "error: device not found" to "exec '/system/bin/sh' failed: No such file or directory (2) -"


    If you do not get this message within 10-30 seconds pull the battery and do it over again.

    Once you get the above message then click on the cmd window and press ctrl-C to stop the batch file.

    If It works skip the method 2 and 3 part.

    If this doesnt work ... try method 2

    *****************Method 2*************************

    Shut the phone off

    plug the phone into USB

    in the command window and type loop

    the screen should fill up with "Error - Device not found"

    Press the and hold the volume down button then press and hold power

    once in the menu press volume down to highlight "recovery"

    Press the power button

    the screen should change from "error: device not found" to "error: device not found" to "exec '/system/bin/sh' failed: No such file or directory (2) -"


    If you do not get this message within 10-30 seconds pull the battery and do it over again.

    If It works skip the method 3 part.

    If this doesnt work ... try method 3



    *****************End Method 2**********************

    *****************Method 3**************************
    Thanks Centsy

    1. With your phone booted up and plugged in via USB, type adb reboot recovery.
    2. Start your adb shell loop (using the while loop or bat file).
    3. Click in and out your SD card repeatedly while the phone is booting into recovery (apparently every 0.5 sec will do).
    4. Watch for "- exec '/system/bin/sh' failed: No such file or directory (2) -" to appear in your terminal
    ******************End Method 3**********************

    *****************There are a lot of other methods floating around. I will not add anymore methods to this thread until we have a confirmed %100 working method. So if you are not able to get adb in recovery from the above 3 methods, then look around there are a lot of other methods to try posted here. I will be watching the other threads and will update as soon as I see a method that has a very high rate of success responses. *********************


    now you should still be in the triangle with the ! screen. press vol up and power to go back to the menu. DO NOT REBOOT.

    Press vol down to highlight "apply: update.zip" and press the power button

    It will fail at this.

    Go back to the CMD window and type the following commands.

    Code:
    adb push busybox /sdcard/busybox
    adb push ota.zip /sdcard/update.zip
    adb push Superuser.apk /sdcard/Superuser.apk
    
    
    
    Now type the next command but DO NOT PRESS ENTER YET

    Code:
    adb push payload-update.zip /sdcard/update.zip
    
    Now press the power button on Apply: update.zip within 1-2 seconds press enter on the command window to execute the above command.

    If successful you should see

    “unrEVOked for Incredible” with some other stuff

    Now type the following commands to make it persistent through reboot

    Code:
    adb shell
    su
    
    
    export PATH=$PATH:/system/bin
    cd /system/app
    cat /sdcard/Superuser.apk > Superuser.apk
    cd /system/bin
    cat /sdcard/su > su
    ln -s /system/bin/su /system/xbin/su  /* IF YOU GET AN ERROR HERE DO rm /system/xbin/su THEN REDO */
    chmod 06755 su
    
    
    
    to get rid unwanted apps do this

    Do not type the /* TITLE */ Part... just whats underneath it to remove that particular app

    ***********Disclaimer**************
    I have not personally removed all these apps - Remove at your own risk
    ********************************

    Code:
    /* City ID */
    /system/bin/rm /system/app/CityID.apk
    
    /* Friend Stream & Widget */
    /system/bin/rm /system/app/com.htc.FriendSteamWidget.apk
    /system/bin/rm /system/app/FriendStream.apk
    
    /* HTC Facebook */  <------------*****REPORTED TO CAUSE FC's if removed******
    /system/bin/rm /system/app/HtcFacebook.apk
    
    /* HTC Twitter & Widget*/
    /system/bin/rm /system/app/HtcTwitter.apk
    /system/bin/rm /system/app/com.htc.TwitterWidget.apk
    
    /* Teeter */
    /system/bin/rm /system/app/teeter.apk
    
    /* Stock Facebook */
    /system/bin/rm /system/app/Facebook.apk
    
    /* Verizon Visual Voice Mail */
    /system/bin/rm /system/app/VVM.apk
    
    
    /* HTC Footprints and widget */
    /system/bin/rm /system/app/HtcFootprintsWidget.apk 
    /system/bin/rm /system/app/HtcFootprints.apk
    
    
    
    choose reboot from the menu and Your phone will now reboot and you will have root

    **************WIFI TETHER INSTALL PROCEDURE******************


    CREDIT TO ANDREW500 XDA



    Download the fw_bcm4329.bin file here
    http://www.mediafire.com/?undhjydn0oy

    connect the USB and mount your sd card

    in the SD Card main directory create a folder named android.tether

    copy the fw_bcm4329.bin file to the android.tether folder

    disconnect the USB

    Install "Wireless Tether for Root Users" from the android marketplace.

    [​IMG]

    ENJOY WIFI TETHER!

    Advertisement
  2. yourfriendwayned

    yourfriendwayned Well-Known Member

    where can I get loop.bat @ - obviously it isnt in my tools folder to edit?
  3. prerunnerseth

    prerunnerseth Well-Known Member

    edit is a standard dos program that is included in windows. it will create the loop.bat when you hit save in the edit program.
  4. intersys

    intersys Member


    You need to create it by doing an edit or use notepad.
  5. yourfriendwayned

    yourfriendwayned Well-Known Member

    odd gave me that and still made it lol it is in there though...
  6. yourfriendwayned

    yourfriendwayned Well-Known Member

    so far no luck - got me and a buddy doing it and he is using a 16gb hc class 2 and I took that one out and I am using a 2gb one from verizon fyi -
  7. prerunnerseth

    prerunnerseth Well-Known Member

    It can take a few tries...
  8. yourfriendwayned

    yourfriendwayned Well-Known Member

    yeah I tried last night while i was in irc room - i was doing manual and this loop.bat script is a savior from typing it - well heres trial over 50 haha
  9. yourfriendwayned

    yourfriendwayned Well-Known Member

    is there a way I need to hold the device - trying upside down brb! lol

    ya know there has to be more variables - like diff cables - sd cards - something you guys all have - or just better patience lol
  10. leoskullz

    leoskullz Active Member

    Probably a dumb question but can this be done on a Mac?
  11. yourfriendwayned

    yourfriendwayned Well-Known Member

    yes it can - as I have seen shots with a mac involved
  12. prerunnerseth

    prerunnerseth Well-Known Member

    I've been able to get it within 3-5 tries. have done it 6-7 times.

    Some guy said something about when you get into the recovery screen... try unplugging and plugging in the USB several times... but i havnt tried this.

    ***** TRied this and it didn't work... just good ol reboot and try again.
  13. yourfriendwayned

    yourfriendwayned Well-Known Member

    I sir, hate your face lmao
  14. kyle1745

    kyle1745 Well-Known Member

    Im on try 10 and no luck I never get the: "exec '/system/bin/sh' failed: No such file or directory (2) -"

    Should this message show before the screen with the red "!"?
  15. yourfriendwayned

    yourfriendwayned Well-Known Member

    it should show while the /!\ is showing it should change
  16. drtrmiller

    drtrmiller Active Member

    Upon booting into recovery mode, Windows asks me to install a driver.

    Do I need a driver installed before the command prompts will find the device while in loop?
  17. john7760

    john7760 Member

    I am up to 30 tries and 0. I believe you may have one of those magic phones from that beanstalk kid.
  18. prerunnerseth

    prerunnerseth Well-Known Member

    it takes a few seconds after the /!\ shows up.... so be patient. My PDAnet pops up when it happens too.. maybe that the key.
  19. kyle1745

    kyle1745 Well-Known Member

    Anyone using windows 7 64bit had any success?
  20. yourfriendwayned

    yourfriendwayned Well-Known Member

    maybe having pdanet helps establish connection?
  21. yourfriendwayned

    yourfriendwayned Well-Known Member

    One of the users just said " I've been successful now accessing using Win7 32 and 64 bit, WinXPPro. Even my netbook was able to do it. Sdcard is a class 6 16gb"

    yet i also saw class 2 cards working...
  22. kyle1745

    kyle1745 Well-Known Member

    Is there a way to try again without waiting for a full reboot then shutdown?
  23. yourfriendwayned

    yourfriendwayned Well-Known Member

    not the best way but battery pull in recovery then hold Vol - and hit power - rinse and repeat
  24. RootDaDuck

    RootDaDuck Active Member

    Dont see the point in doing this yet...
  25. yourfriendwayned

    yourfriendwayned Well-Known Member

    then dont do it? point is you can use apps that you need su - like drocap etc

Share This Page