the qustion THAT NO ONE ANSWERS ?!?!?!?!?!?!?!?


  1. warzar

    warzar Active Member

    hey guys i searched and searched in the internet and i still haven't found the answer ........WHY THE VOICE TALK /COMMAND WON'T WORK ON Wifi BUT WORKS ON DATA CONNECTION ???????even these forums don't have an answer PLEAS SOMEONE HELP:mad:

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Could you be a little more specific about what you are trying to do and what isn't working? My SGS2's voice commands work on both Wifi and mobile data ... at least the one's I've tried.
    warzar likes this.
  3. warzar

    warzar Active Member

    the problem is like this ......when i try to use voice talk/command on Wifi the phone reply "what you like to do?'" then even i talked or not it say's "sorry not able to connect to server pleas try again"and this go on and on but i tried it once on the (data connection)and it works P.S the Wifi works just fine ...streaming,downloading ,etc so what's the problem ??:p
  4. Slug

    Slug Check six! Moderator

    The problem sounds as if it's with the server, if you get the "not able to connect to server" message but internet access via wifi is otherwise working.
    warzar likes this.
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I would suspect your firewall is the culprit. Many Google services connect to the internet through non-standard ports. Try using a free wifi connection like a library or coffee shop to see if it will work on public wifi.
    warzar and Slug like this.
  6. warzar

    warzar Active Member

    so there is nothing that i can do with my phone setting or my Wifi setting???
  7. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I would first try to use voice commands on a public wifi network. If it works, then we know the problem is not the phone and can look for a viable solution for you. If the problem is not on the phone, no amount of settings or configurations to your phone will remedy your situation.
    Frisco and warzar like this.
  8. warzar

    warzar Active Member

    THX guys and i'am srry for any inconvenience:p
  9. warzar

    warzar Active Member

    one more thing say it work on public Wifi then what ???;)
  10. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Then we know it's not your phone, but most likely your firewall blocking something. Consumer level wifi routers generally work in one of two ways with their firewalls. The either block all incoming traffic and permit all outgoing traffic, or the block all incoming traffic and open only commonly used ports (like 25, 80, 110, etc.) for outgoing traffic.

    The android market, for instance, communicates on port 5228 and if your router is of the second type, your internet and email will work as those ports are open, but the market will be unable to communicate with the server. It can be quite frustrating if you don't have an IT background.

    Let's take it one step at a time and tell us how you make out.
  11. warzar

    warzar Active Member

    yah...............idon't have an IT background ((thats if accounting isn't IT)) so THX for every thing and i will inform of any new situation :p
  12. warzar

    warzar Active Member

    hello guys i tested the phone on a puplic Wifi and it WORKS:p
    and now what should i do????? pleas don't forget about me lol
  13. greggebhardt

    greggebhardt Well-Known Member

    You know (or should know) that it has GOT to be your WiFi set up. The number of brands and different configurations vary wildly.
  14. warzar

    warzar Active Member

    Yah i figer it out but what should i do give me even a hint :p
  15. lunatic59

    lunatic59 Moderati ergo sum Moderator

    If you could list you brand and model of router it would help.
  16. warzar

    warzar Active Member

    the router brand is Siemens SL2-141 and that's it ((or it's all i know )):p;):p
  17. lunatic59

    lunatic59 Moderati ergo sum Moderator

    What I would do first is to log into your router and disable the firewall temporarily. Once the firewall is disabled, the try using voice commands over wifi. If it works, then we know it's a firewall rule, most likely a blocked port for outgoing traffic.

    Here is the manual for your router. It will tell you how to turn off the firewall. Please understand that this is basic troubleshooting and I in no way advocate leaving the firewall off. Doing so puts your network security at great risk for malware intrusions.
  18. warzar

    warzar Active Member

    ok THX but is there another way for this problem like making some exception in firewall settings or something like that :confused:?????
  19. greggebhardt

    greggebhardt Well-Known Member

    You need to FIRST try disabling the Firewall to see if that is the problem. THEN you can go from there.
  20. lunatic59

    lunatic59 Moderati ergo sum Moderator

    We're getting to that, but as greggebhardt says, you must try it with the firewall off to determine if it is the firewall. If it doesn't work with the firewall off, then we will need to look at other options like using different DNS settings.
  21. Sword Fish

    Sword Fish Well-Known Member

    I looked up your router and it is 6 years old. It may need a firmware upgrade in order to pass the type of traffic required for Google Talk. (Or you might think it is time to upgrade to a newer model) You can use port forwarding (which your router supports) if you can find out what port Google Talk requires. I have had many routers over the years but have never had to do anything to get this stuff working but I am unfamiliar with your router model. Do you have any computers plugged directly into the router? If you don't, do you use the wireless for you PC? You can still have your firewall enabled on the PC while disabling it on the router.
  22. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I am moving this to the Computers-IT forum. It's a better place to have this discussion.
    johnlgalt likes this.
  23. warzar

    warzar Active Member

    srry guys for any inconvenient but i turned Firewall of and no use the same problem and yes i 'am connected Via wireless only :p
  24. warzar

    warzar Active Member

    so should i update my router firmware .....and if i update it my current provider setting will be deleted ?????:confused:
  25. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Okay, with the firewall off and you still have the same problem, then I would guess that the problem lies either with your router's inability to pass the data correctly to Google or your provider is not permitting the traffic from your connection. It could also be a missing record from their default DNS server.

    Updating the router's firmware might help if that is one of the issues the update addresses. Unless the release notes (and don't forget to read all versions back to yours, because it might not be listed in the latest but addressed in a previous version) specifically state this was an issue, then I'd recommend against flashing the firmware. It's always a little tricky and it could potentially render your router inoperative. It's also hard to tell if it will clear your settings. Sometimes they do, but not always. In any case you should write down all the settings in case you need to reconfigure it.

    You can try changing the primary DNS to Google's free DNS. Use the IP 8.8.8.8 and see if that changes anything. The secondary DNS for Google is 8.8.4.4 If you are having your IP assigned by the router, then you'll need to change the Router's primary DNS to Google's.

    If the problem persists, you should talk to your internet provider and tell them all the steps you've taken. It could be that you'll simply have to replace the router.

Share This Page