Time Keeps Changing Despite SettingsSupport


  1. schroederrt

    schroederrt New Member

    Hello all, and thank you in advance for your help. I, like a significant number of others am having some issues with the clock/time on my android phone. I have been searching for a couple weeks and have not found anythign else that really addresses the problem I am having.

    The phone is a Samsung Galaxy Centura from Straight Talk, connecting through Verizon towers.

    For whatever reason, the clock on my phone is occasionally being set to a time exactly 5 hour earlier than the correct time for my time zone (currently eastern daylight time). In fact, this is what the phone displayed when it was first activated in late June. I manually changed the time, and ever since, it seems to want to go back to that incorrect time, 5 hour early.

    As of yet, I cannot tie the time change to any specific time or to any action I am taking. Sometime it will go several days without doing it, and other times it will do it multiple times in one day. I have tried every combination of settings for "Automatic date & time" and "Automatic time zone," but none of those setting being on or off seem to prevent this issue from happening.

    At one point, while researching this issue, I recall reading that Android primarly uses GPS sattelites to synchronize its time. I disabled the GPS services, and that seemed to keep the time correct for a longer period of time, but it did eventually reset itself to the incorrect time. I do use the GPS functionality, and would prefer to keep it on, especially if this is not really a fix for the problem.

    I also though for a time that it was a tower issue, that I was getting the wrong time from the tower it was connected to. However, I find that unlikely as my wife has the exact same phone. She has actually experienced this issue once, but only once, not the numerous times that I have. I also have a Blackberry through work that I would assume is connected on the same tower, and I have never had such a problem on that device.

    I have also considered that it might be some app causing the problem, but my understanding is that root access is required to change the time, and I have not rooted my phone. In any case I have installed watchdog in case a rogue app is causing this, and it has not reported anything.

    Additional deails:

    • The time zone setting has never changed. Even when time is 5 hour early, the phone still shows that it is on Eastern time.
    • Turning the phone off then back on corrects the time
    • Turning airplane mode on then off does not correct the time.
    • Android version: 4.0.4
    • Model Number: SCH-S738C
    • Kernel version: 3.0.8-1207620

    Advertisement
    :
  2. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Hmm i dont know what could be causing that. i use an app called ClockSync to automaticly set the clock based on the official atomic clock but im guessing it needs root to do that.
    Did you maybe enter the wrong country when u first activated the phone?
  3. chanchan05

    chanchan05 The Doctor Guide

    How about Daylight saving? Active?
  4. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Welcome to the forums, schroederrt.

    Try shutting the device down, removing the battery and sd card and the SIM card. Wait a minute or two and then put it all back in and power back up.

    If that does not help, a factory data reset probably will as you re-activate the device using your Google/Gmail account:


    1. select Apps from home screen
    2. select System Settings
    3. select Backup & Reset
    4. select Factory data reset
    5. select Reset phone
    6. select Erase everything.
    I've placed your thread in the Centura sub-forum here at AF for viewing by other users of that device. :)
  5. schroederrt

    schroederrt New Member

    Thank you, I noticed the sub-forum after starting mine...my apologies for any inconvenience.

    I've tried the battery pull before too, but maybe didn't wait long enough, trying it again. Not sure how to remove SIM card though.
  6. SteveCampsOut

    SteveCampsOut Well-Known Member

    I've experienced the same issue with all of the "Automatic" settings turned on so I've turned off all auto settings and just set it manually.
  7. jefboyardee

    jefboyardee Well-Known Member

    Calendar uses time too. I wonder if it can tamper with the time universe like I know it does with dates, forcing me to clear data on Calendar Storage... can’t hurt to try.
  8. Mattswad

    Mattswad Member

    I have the same problem and I'm pretty sure it has something to do with the crappy GPS antenna. I've noticed that whenever it is off on the time it is also "searching for GPS signal." Whenever it is "lost" (or can't sync in with GPS satelites) it places itself on the international date line or +/- 0:00 Greenwich Meridian Time.
    SteveCampsOut likes this.
  9. schroederrt

    schroederrt New Member

    Interesting....how do you now it is searching for GPS signal? I haven't noticed anything, but as I originally noted it does seem to do this much less frequently with the GPS locaiton services off.
  10. SteveCampsOut

    SteveCampsOut Well-Known Member

    If it's searching for GPS you should see the GPS icon on the Notification bar at the top. EDIT: This isn't true> {If you just turn off automatic adjustments in the time settings it won't reset your clock to the wrong time at all.}

    In the past 24 hours my clock has lost 5 hours at least twice so I guess turning off automatics doesn't work either. <sigh>
  11. tonto18

    tonto18 New Member

    I had this problem yesterday after using the device for about three weeks. It started after I installed Words with Friends. Power off/on would reset but it would mess up again. I uninstalled Words with Friends and all seems to be normal again.

    UPDATE: This didn't fix my problem. It happened again last night. I'm in US on Central Time. It seems to lose 6 hours each time it happens. Could be resetting to Greenwich Mean Time...I don't know
  12. tjdoren

    tjdoren Member

    Add me to the list of Galaxy Centura owners with this problem. Mine did it a few days ago, so I turned off the "automatic time zone" and "automatic date and time" settings. But then last night it did it again, even though I had turned off those settings. I think mine is jumping back 6 hours. I'm in U.S. Central Time, so I wonder if tonto18 is onto something...or maybe it is just a coincidence. Most of the other threads I've seen on this topic report either a 5 hour or a 6 hour jump.
  13. tjdoren

    tjdoren Member

    Is there a way to see a detailed log of phone activity to see what apps may have had a process running when the time changed? Last couple times my time changed, I knew it had been in the last hour, so if there was a log, I could have looked back over the last hour and narrow down the possible causes. A simple list of "running processes" isn't enough...I'm looking for something with timestamps on every event that occurs on the phone.
  14. tjdoren

    tjdoren Member

    Wow, what a stroke of luck! Less than 1 hour after my previous post, my time jumped back by 6 hours again. I did a search for log viewers, and downloaded an app called CatLog. I found this group of log events right at the moment when the time switched on me. I don't know how to make sense of them yet...hopefully someone smarter than myself is reading this forum. Perhaps some of you others could download CatLog and check it next time your time gets messed up. If you see similar log events, maybe we'll be able to zoom in on the root cause. Here is what I saw...seems to be related to my wireless internet connection, I'm guessing:

    Date Time Type Description
    08-10 10:37:39.993 I wpa_supplicant(3861): Associated with 14.EC.0C
    08-10 10:37:40.023 I wpa_supplicant(3861): WPA: Key negotiation completed with 14.EC.0C [PTK=CCMP GTK=CCMP]
    08-10 10:37:40.023 I wpa_supplicant(3861): CTRL-EVENT-CONNECTED - Connection to 14.EC.0C completed (reauth) [id=0 id_str=]
    08-10 04:37:43.770 I wpa_supplicant(3861): Associated with 14.EC.0C
    08-10 04:37:43.810 I wpa_supplicant(3861): WPA: Key negotiation completed with 14.EC.0C [PTK=CCMP GTK=CCMP]
    08-10 04:37:43.810 I wpa_supplicant(3861): CTRL-EVENT-CONNECTED - Connection to 14.EC.0C completed (reauth) [id=0 id_str=]
  15. SteveCampsOut

    SteveCampsOut Well-Known Member

    All I see are two separate connections to the wifi.
  16. tjdoren

    tjdoren Member

    Yes, but do you see the timestamps? The first one is 10:37:40.023 and the second is 04:37:43.770. These two events happened exactly when the 6-hour time change occurred. I searched the entire log for a 100-minute timeframe, and this type of connection event never occurred at any other time. Could be a coincidence, but I think it is worth investigating.
  17. Having the same problem off and on with my two phones. Bought one for myself and one for my wife after leaving Verizon. Not sure why this continues to plague us after shutting off the automatic updates. Is this only for people in Central time zone? Our's keeps trying to put us in Mountain time even though we are securely in Iowa...in the middle of CST/CDT town. WTF? Ditto on the 6-hour difference also. Although I think I've seen mine actually jump a back further than that also. Tried everything short of a factory reset. Taking off the cover and the back of the phone is such a PITA!!! Sent Straight Talk and Samsung both emails. ST replied asking me to call their help desk. Ugh!
  18. Corpsecrank

    Corpsecrank Member

    I had this problem also and the way I fixed it was to turn off all the time sync stuff and just manually set the time and date. Once you turn all the auto settings it should be fine.

    I have 2 of these phones one had this problem the other did not it's kind of weird like that.
  19. If only it was that easy! Mine just lost 6 hours twice today after being good for about a week on manual settings. Might return it to see if I can get a new one that actually f'ing works!
  20. chieffangrande

    chieffangrande New Member

    I found that my global clock settings in my calander app were set to a time zone in Australia. I corrected that setting in the calander app and so far so good the clock is keeping the correct time. I will reply back and update this thread if this "fix" fails to solve the problem.
    jama347 likes this.
  21. SteveCampsOut

    SteveCampsOut Well-Known Member

    There's a fix I found in this thread. This app from Google Play will fix the lost time issues with the Centura. ClockSync
  22. The problem with that "fix" is that you have to root the phone to get it to work automatically. This will void all warranties on the phone. There is an app that shows you what the time should be, but you have to manually correct it yourself. What a pain for such a standard feature that even the most basic phones easily handle.

    As a side note, I now have gibberish appearing on my locked main screen. In the area where it shows the % charging when plugged in, it says "llllplllmlmmllml" when not plugged in. I pulled the battery and it still remains. Makes no sense!
  23. tjdoren

    tjdoren Member

    My earlier post with a CatLog discovery proved to be fruitless. I captured about 5 more time change events on CatLog, and none of them showed any consistent pattern of anything related to the time change. I started working with StraightTalk's customer service on their online forum, and they weren't helpful at all. Eventually, I called the StraightTalk customer service hotline, and they insisted I attempt a factory reset before they would exchange my phone. So I reluctantly did the reset, and I left my phone in nearly factory condition for a day, without installing my apps. Sure enough, my time changed again later that same day. So I think this rules out any interaction with apps.
    After all that, they agreed to exchange my phone. But the frustrating thing is that I had to mail it in, and they won't send the replacement until they receive my old phone. So I am phone-less for a few days...Grrrrrr! Hopefully my next phone is better.
    My advice to everyone fighting this issue....bite the bullet and push on StraightTalk for an exchange. If they start getting a few of these back, maybe they'll try harder to come up with a solution.
  24. acasinofriend

    acasinofriend New Member

    Awesome... I hope this resolves the problem. I even called tech support and they reset my phone, but eventually the clock messed up again.
  25. acasinofriend

    acasinofriend New Member

    Nope, my clock jumped back six hours even with the calendar trick...
Loading...

Share This Page