1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Time without signalSupport


  1. Kmfiremedic111

    Kmfiremedic111 Well-Known Member

    Hello. In my area I usually have great signal. Full bars etc. Never an issue. However on my phone it says Time Without Signal is 50%!! I update my PRL every few weeks. I don't understand? Anyone else having this problem?

    Advertisement
  2. uniquenameEVO

    uniquenameEVO Well-Known Member

    My evo is like that too. Total battery killer. The culprit was my office.

    I put in a booster and all is good.
  3. SandersJC64

    SandersJC64 Well-Known Member

    It's a Froyo bug. The phone is misreading the time on. Next time you charge your phone, turn Airplane mode on then back off. When you unplug the phone after charging it should read the correct time on value. You'll need to do that each time you power your phone off/on.

    *This isn't my solution, but one that I found on some thread somewhere, but I can't remember where so that I can give credit.*
    vrvallejo and Ma}{imus like this.
  4. apinkel

    apinkel Well-Known Member

    Is the fix to turn on/off airplane mode before putting on the charger or after taking it off the charger? I want to automate this with tasker and I'd like to get a handle on the fix before I do.
  5. SandersJC64

    SandersJC64 Well-Known Member

    I do it before taking it off the charger. Oh and you only have to do it if you power cycle the phone.
  6. apinkel

    apinkel Well-Known Member

    I think I understand... I just need to setup a task that turns airplane mode on then off every time the phone boots up.
  7. feigndeaf

    feigndeaf Active Member

    This fix works AMAZINGLY. I got a 50% battery life boost. I went from 99% without signal to now 6-10%. Where my phone would normally be almost dead, at the end of the day yesterday I had 67% LEFT!!!
  8. Ma}{imus

    Ma}{imus Well-Known Member

    I'm going to give this fix a try. Will report back my results.
  9. Ma}{imus

    Ma}{imus Well-Known Member

    @SandersJC64 so far I have 0% time without signal after applying this fix. Already seeing improved battery performance.

    I'm going to bring this up with the devs of ThundeROM and see if they can incorporate this fix into their next version somehow.
  10. Hot Sauce

    Hot Sauce Active Member

    How do I look up "Time without signal"? Is it an app? I looked through the phone's settings and didn't see it
  11. jtcady

    jtcady Well-Known Member

    Settings>About Phone>Battery Use>Click Cell Standby

    its not an app
    Hot Sauce likes this.
  12. Hot Sauce

    Hot Sauce Active Member

    ^Thanks, guess I didn't look hard enough lol
  13. Ma}{imus

    Ma}{imus Well-Known Member

    You can also install an app such as Battery Watcher that shortcuts straight to the info from a home screen widget.
  14. mcwong

    mcwong Member

    what works for me every time to to set airplane mode on then switch off the phone. reboot while still in airplane mode and wait a few minutes (try 5 min) for the os to boot up and services running. after 5 min set airplane mode off. It doesn't matter whether it's done after charging as it can be done any time. I'm on GSM service and sometimes the TWS goes up to 60-70%. since I started using this fix, I normally get tws=0% and at most 4%. Today it went up to 26% and I just perform the reset in airplane mode on and wait 5 min to set it off. now it's showing tws= 0%. Hope this helps.

Share This Page