1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Timeout too short when making callsSupport


  1. John Jason

    John Jason Well-Known Member

    I'm probably too stupid to be allowed to have a SGS2, but I do, and I love it. All except for when making calls, because the timeout on the screen is too short. Today I needed to call about 20 places one after the other. I would hang up one call and look at my list for the next phone number, and by the time I got my hands to the screen it had gone black. Every time I had to push the power button on the side in order to get the screen back.

    I have the timeout set to 10 minutes in Settings > Display > Screen Timeout, but apparently it does not affect the timeout in the keypad screen when making calls. I can't find any place to change the setting for the keypad when making calls.

    Can anyone point a dummy to the right place to change the setting?

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    That is being caused by the proximity sensor. When you make a call and hold the phone to your face the sensor turns the screen off. This is for saving the battery and keeping you from hitting buttons with your face. It is supposed to come back on after a couple of seconds when you move it back from your face.

    There isn't a way to change the time it goes off I know of. You can turn the sensor off if you want to. Press the call button, then your menu button, then call settings, then uncheck the box for proximity sensor.
  3. John Jason

    John Jason Well-Known Member

    Thanks for the suggestion, but I don't have the same screen as you.

    I press the Call button on the main screen, which brings up the keypad. I press the Menu button and my options are Speed Dial Setting, Send Message, Add 3 Sec Pause, and Add Wait. I don't have a Call Settings option.

    I looked everywhere for a Proximity Sensor, but can't find it.

    However, I think the Proximity Sensor is not the source of the problem. I finish a call and set the phone down, and the screen is still visible. I pick it up and the screen is still visible. It just goes to black a few seconds before I can start keying in the next number. The physical orientation of the phone has nothing to do with it. It's a timeout issue.
  4. Atma

    Atma Well-Known Member


    What android version are you running?
  5. John Jason

    John Jason Well-Known Member

    I have 2.3.6. It is the version that came with the phone from T-Mobile, as patched and updated by T-Mobile.
  6. Atma

    Atma Well-Known Member

    I would recommend updating to the latest version, Ice Cream Sandwich 4.0.4. IF you use Kies, you will probably have to go to ICS 4.0.3 first.
  7. John Jason

    John Jason Well-Known Member

    Thanks for the suggestion, but I read here about too many problems with ICS. Other than the timeout on the keypad screen everything on my SGS2 works great. Upgrades usually mean "replace old bugs with new bugs."

    I was hoping there would be someone here using the same stock version of Android who knows how to fix the timeout on the keypad screen when making calls.
  8. Love Helpin

    Love Helpin New Member

    Atma likes this.
  9. Atma

    Atma Well-Known Member

    Welcome to the forums Love Helpin :hello:

    Thanks for the suggestion.
Loading...

Share This Page