Tina Timelapse on Milestone 2.2


Last Updated:

  1. wesselrossing

    wesselrossing New Member This Topic's Starter

    Joined:
    Jul 25, 2010
    Messages:
    3
    Likes Received:
    0
    I got a comment on my application Tina Timelapse, it only said that it does not work on Milestone 2.2. Could someone verify this, and maybe tell me what is going wrong?

    The application is already available in the market.
     

    Advertisement
  2. markb

    markb Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    148
    Likes Received:
    26
    Hi wesselrossing,

    I don't have a milestone, but I do have 2.2 on a Nexus One.
    I tried your app.

    I did 2 time-lapse sequences. App seemed to work fine.
    I checked the gallery, but couldn't see any images.

    I checked the SD card, and I can see a TinaTimelapse folder, and in there are 2 folders, one for each of my time-lapse sequences. And those folders have the images that I expected to find.

    Personally I think the Gallery app on the phone is a buggy piece of crap.
    If I take photos with the standard camera app they never appear in the gallery straight away.
    Sometimes I'll go in and out of the gallery several times, hoping it will refresh, but it doesn't.
    Pictures turn up eventually. But I'm not sure how to make it work properly.

    This was a problem in earlier versions of Android as well.
    I have a camera app in the market (SoundCam) and I had complaints about the images not appearing in the gallery. When I asked people to check the SD card, they found the images were there, just not shown in the gallery.

    It looks like your app is working, but you're suffering from bugs in the Gallery app.
    You could ask your users to check the SD card to confirm the pics are there, just in case there are other problems specific to the Milestone.

    If you work out a way to get the Gallery to refresh I'd be very interested in hearing about it.

    Mark

    p.s.

    I went back into the gallery about 10-15 minutes later, and the time-lapse images turned up.

    I found a discussion here:
    http://code.google.com/p/android/issues/detail?id=7575
     
    wesselrossing likes this.
  3. wesselrossing

    wesselrossing New Member This Topic's Starter

    Joined:
    Jul 25, 2010
    Messages:
    3
    Likes Received:
    0
    Thanks markb!

    I will inform my users about your findings. Just an idea I got from reading your response and the Google Code discussion. You both mention the images appearing after a while/after a reboot. This sounds to me that the gallery app has to be killed for it to update properly.

    I also found this (here):

    Code (Text):
    1.  
    2. new Intent(Intent.ACTION_VIEW, Uri.parse("content://media/interna/images/media"))
    3.  
    If we force feed the folder containing our images into the gallery it might show them and update itself.
     

Share This Page

Loading...