Tiny Box Telechip TCC8902 - wow!

Last Updated:

  1. bthoven

    bthoven Well-Known Member

    I used to play around with the Rockchip RK2918 Android TV Box, named G-Box, which I posted a review on this board earlier.


    It was a good and fast box, but with two main issues: too small fonts/icons for TV, and audio sync issue (a bit of issue). So I decided to sell it.

    As I've not seen anyone really review Android TV Box equipped with Telechip 8902, so I decided to buy a no-name box from China at rather cheap price ($77, china post to Bangkok, Thailand). It took 16 days before it arrived at my house.

    I know that Telechip CPU performance, according to its specification, seems poorer than other CPUs in the market now, but whether it can at least serves my purposes; and so far it is.

    Brief spec:
    Telechip TCC8902 720Mhz with builtin 2D/3D
    RAM: 512MB
    ROM: 2GB
    With or without Wifi (I choose to order a builtin Wifi)
    Android 2.3
    Official Android Market (quite a new version)
    Front: IR receiver
    Back: DC-in, HDMI, LAN (RJ-45), AV out (accept 3.5mm input jack)
    Left side: 2xusb, sdcard slot
    Accessories: hdmi cable, AV cable (3.5mm jack-to-yellow, red, white RCA jack), AC adapter (5v, 2A), and small remote control

    This is my only one night of experience playing with the box. I'll keep on updating my feedback.

    My overall first impression

    0. it is a tiny box! I wondered it is as small as Apple TV, very light

    1. the IR remote operating angle is surprisingly good and responsive (no mouse control, just jump to next command with four directional keys (my distance from TV is 2.5m). Press the power button on remote will put the box into the standby mode; push it again to wake it up.

    2. the text and icon displays are very clear and big, very suitable for viewing on TV. This is what I

    Attached Files:

  2. bthoven

    bthoven Well-Known Member

    Some more updates on this box (in my original post).
  3. xmancool

    xmancool Well-Known Member

    Hi, i have a few questions?

    1- You bought it online? where?
    2- The only way to install apks in this box is through market?
    3- Can you test PSX and Nintendo64 emulators?
    4- The sound problem on mkv files could be solved using another player?

  4. bthoven

    bthoven Well-Known Member


    1. yes, bought from **********.com. You search for Android TV box and sorted by lowest price first. Then you should see it listed in first or second webpage.

    2. You can also install from SDcard, just copy apk file to sdcard, and use any file explorer to browse and click to install.

    3. let me try. I'm not familiar with game :)

    4. I want to try too, but the problem is it won't recognize my ntfs/fat32 formatted hard drive which contains all my mkv files. I'll try to find and copy a smaller mkv file to my FAT formatted drive and try to play it with some other players, e.g. mobo, mx, etc.

  5. xmancool

    xmancool Well-Known Member

    bthoven likes this.
  6. bthoven

    bthoven Well-Known Member

    Got a newer firmware from seller. Upgrading with the upgrade command and surprisingly, all the installed apps and settings remain intact!.

    After the upgrade, it can recognize FAT32 sdcard/usb thumb drive. Playing mkv file with Moboplayer smoothly but still no sound. Mx video player won't play the same mkv file.
  7. bthoven

    bthoven Well-Known Member

    I'm not sure what I've done to the box. I usually can press menu button on remote, at home screen, and choose + to add either shortcuts or widgets. Now, choosing + on the menu won't do nothing (other command in the same menu, e.g. wallpaper, and settings are still working). So I can't add widget on the home screen.

    Any tips to solve the problem, apart from reset the box?

    update: the plus sign command to add widget and shortcuts only works at 1st home screen only. As my first home screen is all occupied by shortcuts/widgets, the plus sign command can't be further processed. Nothing wrong with the box.
  8. sm1

    sm1 Member

    Hello. I have the similar box from pandawill.
    This box is powered by Android 2.3.3 so Gingerbreak can't root it. ZergRush exploit seems to can it but needs to be recompiled to use other folders since this device can't give access to requested folders.
    My box is working with 500GB NTFS HDD via external powered USB hub.
    Have you tried to use powered USB hub?
    Could you post here or in PM latest firmware provided?
  9. bthoven

    bthoven Well-Known Member

    Hi sm1,

    The new firmware I got from the seller is version 20111110.115111.

    Please pm your email address, if you still want it.
  10. sm1

    sm1 Member

    Hi. I've sent you pm with email. Could you forward message from seller or just copy/paste it and send via PM?
  11. bthoven

    bthoven Well-Known Member


    I decided to put at megaupload because of over 100MB size. Here it is:

    MEGAUPLOAD - The leading online storage and file delivery service

    It is a zip file, once downloaded, just copy to root of your thumb drive (don't unzip it), then use firmware update menu in the box to browse for this file, and simply confirm. It will take a few minutes to upgrade and reboot itself.

    Goog luck.
  12. sm1

    sm1 Member

    Tried this firmware and it doesn't update my device. It do something than after reboot the firmware version remains the same.
  13. bthoven

    bthoven Well-Known Member

    As I mentioned in earlier post, no visual or noticeable change after upgrading to version 20111110.115111. The only improvement I got is my box is now able to read FAT32 thumbdrive (and of course, new version number display in the firmware section).

    Do you see the firmware update progress bar during the upgrade?
  14. bvu

    bvu New Member

    I have the same box, but I have a problem with booting.
    After showing the blinking Android tv logo for a while it stops showing a black screen.
    Is there a way to restore it to the factory settings???
    Or does anyone know about this problem???
  15. bthoven

    bthoven Well-Known Member

    I've not got instruction from the seller. It's no harm trying this way:

    1. download the update.zip file from my above post I uploaded at megaupload
    2. copy update.zip to one of your sdcard at root level directory (better format the card before copy)
    3. unplug your tv box and insert sdcard into it
    4. plug power to your tv box, and see whether it starts the firmware update

    Until I get a proper firmware update instruction from the seller, please try the above and let me know if works or not.
    bvu likes this.
  16. bvu

    bvu New Member

    I tried what you suggested and now I am very happy because my tv box is alive again.
    Thanks very much!! :)

    Can you please tell me if there is a way to get Adobe 10.x flash working on this box??
  17. bthoven

    bthoven Well-Known Member

    Glad it did work for you.

    For Flash, I have no idea Telechip will support it.
  18. in_msz

    in_msz Well-Known Member

    try this for solving audio problem.
    Download Mx player and its proper codecs.

    When your playing the file there is audio tab on the right side upwards click it and there you will find the 2 sources of audio. Select the unused source you may get the audio.

    If this works you may make that source by default n settings
    bthoven likes this.
  19. sm1

    sm1 Member

    Just tried to update firmware by provided there.
    It works! No any visible changes even firmware number the same but my box now playing FAT/FAT32 usb sticks.

    Applied firmware by using SD card in NTFS. Then putted update.zip into root folder of SD card then performed system update from SD card. Device rebooted then asked me to don not switch off then showed me logo then reboot again then loaded as usually.

    Thanks, bthoven, for this firmware.

    Do you have any news about rooting of device? With root we can do it really device of my dream about CarPC. Now I made some workaround tasks to achieve this goal but root access can make this a bit easier.
  20. bthoven

    bthoven Well-Known Member

    Hi SM1,

    Great the firmware is useful to you.

    I just got a set of tools from the seller (she sent me to resolve the booting problem of this box); but I have no idea how to use it. I'll upload it to megaupload for you guys who might be able to use this tool for rooting.

    BTW, what is CarPC? and after the upgrade, all your own installed apps and settings remain intact? or they are all wiped out?
  21. sm1

    sm1 Member

    Please share it with us. Maybe we can make recovery from it? With recovery we can try to make firmware that already rooted like Cyanogenmod
  22. sm1

    sm1 Member

    Hmm, it is hard to explain in two words. But I try to use this device as smart head device in my car to provide mainly navigation and any formats player (including lossless).
    As display I use rear view mirror with display built-in. This display have 2 AV inputs. 1 used for rearview camera. The second one is for TV Box. Right now I'm working on Android application that provides such functions
  23. sm1

    sm1 Member

    No any visible changes found even firmware version remains the same. No apps wiped out. Nothing new except support for FAT/FAT32 USB sticks.
  24. bthoven

    bthoven Well-Known Member

  25. sm1

    sm1 Member

Share This Page