tip: how to install liberated ROM


  1. RocketRay

    RocketRay Active Member

    I was mystified as to how to get a liberated ROM onto my Aria. Docs & threads seemed to assume I knew my way around the tools. I did finally figure it out, and since there are probably others who are similarly confused, here's what I did:

    First, I got the Unrevoked3 reflash utility and got my phone rooted. All you do is put your phone in USB debugging mode (checkbox under Settings->Applications->Development), connect it to your computer charge only, then run reflash.

    Should probably mention here that the other threads cautioned you to do the Nandroid backup, so I'll echo that sentiment. You do that in recovery mode covered below.

    Next, I took the R005 liberated ROM ZIP file and copied it to the SD card on my phone. On my first try I renamed the file and when I tried to install it it failed the checksum, so important not to rename the file. Once it's on the SD card, you power off the phone, then power it on while holding the volume down switch. That puts it into recovery mode. Choose "recovery" using the volume up/down, then press the power switch to select. Next choose "install zip", power to select. Finally choose the ROM ZIP file you want to install, and off it goes.

    Advertisement
    markbc likes this.
  2. anika200

    anika200 Well-Known Member

    Nice RocketRay thanks for the write up. Thats how I did it too.
  3. magste672112

    magste672112 New Member

    I found my directions I think from UnLocker to root and then load the liberated rom
  4. Gride250

    Gride250 Active Member

    Is the liberated rom your referring to the one with 2.2 and no Google apps? I got the CyanogenMod rom loaded into mine but when I try and load the Gapps from the zip i downloaded it wont work. I tried it in rom manager and through the boot screen.

    When i scroll down to the correct zip file using the vol up/down button and try and execute it, it starts installing and then says can not find the specified file.

    I put this folder in the clockwork folder just like all of my custom roms. Its got me stumped! I love the cyanogen mod but i cant use it if i dont have the google apps like gmail, market and such.
  5. ls377

    ls377 Active Member

    Re-download and try it again, sometimes files can get corrupted in the transfer. Also, make sure you have the mdpi version.
  6. Mythic

    Mythic Well-Known Member


    actually you can rename them BUT there can NOT be any spaces in the name... if you need a space use either "." or "_" (dot or dash) to seperate any words like HTC_lib_uot_kitchen_mod_10.15.2010 so that its a one word sequence... i had the same checksum issues with roms after i renamed them... formatted the same roms in the format above and they worked perfect...
  7. RocketRay

    RocketRay Active Member

    I use Linux, so I did this:

    cp liberated_aria_b005_signed.zip /media/aria/b005.zip

    Then b005.zip failed CRC. So:

    rm /media/aria/b005.zip
    cp liberated_aria_b005_signed.zip /media/aria

    And that worked.

    Oh well, happy w/ CM6 now. :)

Share This Page